Link to home
Create AccountLog in
Avatar of Yashy
YashyFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Windows has encountered a problem communicating with a device connected to your computer

hi guys,

Friend has a toshiba laptop which has gone kaputt. The OS is Windows 7. It comes up with the following message when it goes past the loading screen:

Windows has encountered a problem communicating with a device connected to your computer.

We've tried the blasted F8 button to go into safe mode and it just won't do it. He's gone into the BIOS and the HDD can be seen. No USB devices are attached or any external devices for that matter for it to cause this issue. We've tried pressing F5 and it took him to the screen 'Choose an operating system to start...' and it shows the Windows 7 option.

And below it is the option to select F8 for the advanced menu. When he selects it, then it attempts to load and goes to the same error screen 'Windows has encountered a problem...' etc.

Any help guys would be fab. Really need your help:)

Thank you
Yash
Avatar of R. Andrew Koffron
R. Andrew Koffron
Flag of United States of America image

did you try safemode command prompt?

if it works try and roll it back to a date that worked.  might be able to identify the issue.
if it's failed hardware you can probably do a windows install and find what doesnt work, provided it's not a critical component.

pull the drive and backup or use a boot CD and copy the data to an external USB drive.  but backup any important data before going on.

in windows 7 type "rstrui.exe" it should find it without path. but might need.
C:\Windows\System32\rstrui.exe
Avatar of Yashy

ASKER

This is the problem, he can't get into safe mode as when he presses F8 it does't take him to that screen.

This is as good as it gets (screenshot)
IMG-20131229-WA0003.jpg
If you have the Win 7 disk ,boot from it and try a repair.
SOLUTION
Avatar of R. Andrew Koffron
R. Andrew Koffron
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
ASKER CERTIFIED SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Go into BIOS and change the PXE boot, as well as USB boot options to Disabled or unchecked. One requires network, the other a USB boot device.
Avatar of Yashy

ASKER

Guys I tried absolutely everything. I'm unable to get ISO files booting from a USB. I'm doing this over the phone so I'm wondering whether it's because the ISO file is not bootable.

I'll need to close the case, as sorry as I am to do that without a decent answer, thanks for all your support man.