Solved

citrix client logon message

Posted on 2013-12-30
12
1,397 Views
Last Modified: 2014-01-07
Hi,
just recently, one of our 2003 terminal servers which has 20 user cals wasnt allowing access and was giving a citrix mesage "citrix client logon message: the system has reached its licensed logon limit.  Please try again later." This came out of nowhere and i believe its because we still have remnants of citrix components in the server even though we have not used citrix for over 3 years.  I cannot uninstall citrix at this time since it is looking for the citrix disk which i no longer have access to.  This message comes up even when we have only 2 users logged on and even if i log on as administrator.  Any ideas?  thanks
0
Comment
Question by:dankyle67
12 Comments
 
LVL 25

Expert Comment

by:Tony1044
ID: 39747307
Do you have a screen shot?

Assuming the users are using RDP and not the ICA client/receiver it may be down to the error generated being misinterpreted.

Any event id's on the server? Particularly 1000's as these are indeed lack of licenses.

Did anything change prior to the error? Any MS updates for example?

Have you examined the terminal server licenses console to see if there are any issues with the registration of the TS CALS?

Finally - tried a reboot of the server?
0
 

Author Comment

by:dankyle67
ID: 39747319
I am rebooting the server now but i also took it off the domain and will rejoin domain after the reboot so hopefully that will do the trick but as i mentioned, this is a terminal server that has a  lot of available licensese and only about 6 users access it remotely so wondering what could have changed in the past few days that would kick out the citrix licensing errors even though we havent used citrix for over 3yrs.
0
 

Author Comment

by:dankyle67
ID: 39747377
After the reboot, was able to login 6 separate users no problem so for now its working but never think i'm out of the woods until i test the heck out of a server to make sure i dont get the same message.  I went into terminal server licensing under that server and noticed that none of the licenses were being issue even when i had the 6 remote users logged in so where can i find the actual licensing server that is issuing the terminal server licenses?
0
 
LVL 11

Expert Comment

by:Manjunath Sullad
ID: 39747557
You need to allow more than 99 anonymous connections, you must customize the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\MaxAnonymousUsers

Refer Citrix ID:  CTX153078 and CTX116725
0
 
LVL 25

Expert Comment

by:Tony1044
ID: 39748063
Not sure what you think Citrix Anonymous accounts have to do with the issue?

Perhaps I am missing something?

Dankyle67 - what is the underlying server OS? Is it 2000 or 2003?

What are your clients? If they are Windows XP and they were licensed before around April 2003/2004 and the server OS is 2000 / 2003 from the same sort of period they will use a built in TS CAL - MS used to include a TS CAL in their product but dropped it.

It may be that they're using a built in TS CAL.

If not, then you need to investigate the server event viewer during the time your users were getting the denied messages to see which licenses it thought were the problem.
0
 

Author Comment

by:dankyle67
ID: 39748465
I tried logging in 2 users and on the 3rd user it gave me same message again about logon limit exceeded so it seems to be allowing only 2 remote users as though the server is no longer a terminal server mode but instead in application mode which only allows 2 concurrent sessions.  The system event id error was 19 and is referencing a metaframe event so i really think this is being caused by citrix components still within the registry since as i mentioned i could never fully uninstall citrix a few years ago since the uninstall always looked for the cd and we no longer have that citrix cd.  I might try the anonymous 99 user route in the registry since it cant hurt since we dont have citrix anyway.  The strange thing is why would this show up after years of working without any license issues?
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:dankyle67
ID: 39748477
The other event id error code was 9017 "This computer running metaframe presentation server will now stop accepting connections.  This server is no longer in or could not enter a licensing grace period."  This would really support the theory that the server still thinks it is a metaframe presentation server and the licensing is being controlled currently by citrix instead of the terminal server which still doesnt make sense why it would act up now when usually the grace period for citrix licensing is 90 days and this terminal server has been running for over 3yrs.
0
 
LVL 25

Expert Comment

by:Tony1044
ID: 39748487
Well I presume you're connecting via RDP and not ICA? If the latter was tried and there are no licenses/no data store then it'd error out like that.

Connecting purely to Terminal Server via RDP will not try to consume a Citrix license. It (RDP/Terminal Server) knows nothing about nor cares about Citrix.

Are you sure that terminal services is enabled? Add/remove programs - Windows programs (or whatever it was called - been a long time since I used 2000/2003). If it's only got remote administration enabled then there's your problem - two users and one admin on the console. It does sound like this may be the case.

Other way round by the way - you WANT it in Application mode. Otherwise it's only in Admin mode and allows only the two connections...
0
 

Author Comment

by:dankyle67
ID: 39748526
I have always used rdp to access this server and no longer even have ica client so thats why its so strange, as though something triggered citrix licensing to take over but all users i know of use rdp so my thought was to try and fully delete citrix in the server but would you know how to do that in registry?  We actually activated the extra terminal server licenses over 3yrs ago and like i said why would it be working all that time and now all of a sudden it seems like citrix has taken over even though we only use rdp 3389 to login.
0
 
LVL 2

Expert Comment

by:Adam Anderson
ID: 39753548
is your citrix licensing server up and check for errors on the citrix licensing server
0
 

Author Comment

by:dankyle67
ID: 39754930
We have not used citrix for over 3yrs and this server when we tried uninstalling citrix at that time, it failed so pretty sure that the remainin citrix components somehow created a situation where this server thinks it is still a citrix server even though we have not logged into it using ica client but only rdp for over 3yrs.  I think i will have no choice but to restore the c drive from a few weeks ago prior to this problem occuring.  We have a valid terminal server licensing server on another server since i just created a new terminal server on one of our other servers and we were able to log on 8 concurrent users no problem.
0
 
LVL 25

Accepted Solution

by:
Tony1044 earned 500 total points
ID: 39755098
But...when you use the RDS or RDP client to connect, it has no interaction with Citrix licensing components - they're not added into the GINA, for example (Graphical Interface for Network Logon - i.e. the security layer that controls Ctrl + Alt + Del among other things).

What is the problem getting hold of the media, by the way?
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Join & Write a Comment

#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
CITRIX XENAPP 6.5 FARM CUSTOM POLICY - CHANGE MANAGEMENT WINDOW REBOOT SCHEDULE
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now