Importing Access file to SQL Server

I am trying to get data from an Access.accdb file into SQL Server Express 2012. I see that the import options for SQL Server do not allow for an .accdb type import, so I saved the database to an .MDB format.  

When I try to import to SQL Server, however, I get an error message.  See attached file.

Anyone know what the problem is or how to get around it.  What is the best way to import an Access.accdb file into SQL Server Express 2012?
2013-12-30-225434.jpg
WoodrowAAsked:
Who is Participating?
 
Dale FyeCommented:
I prefer SQL Server Migration Assistant, free download at Microsoft Download Center
0
 
PatHartmanCommented:
I always go the other way.  Try using the upsizing wizard to transfer from Access to SQL Server.  The other option is SSMA (SQL Server Migration Assistant).  Use the bit-wise version that matches your version of Access regardless of your OS.
0
 
Detlef001Commented:
This happen just because as the can be a reason as the default string columns, importation, size is 50 characters.

This truncation occurs before the data goes to the database. You must set this in the first step of the Import Wizard, in the Columns section.

Can be other reasons also but yes at a moment of time please have a look at this situation also.

Thanks.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
WoodrowAAuthor Commented:
Thank you for responding.

I am using Access 2013.  The upsizing wizard is no longer a part of Access 2013.  The SQL Server Migration Assistant does not specifically mention Windows 8 (or 8.1 - what I have) as an Acceptable OS.  Will it work with Windows 8?
0
 
Dale FyeCommented:
I do not know the answer to that question.  If you don't get an answer to that shortly, post back and I'll see if I can get a couple of other Access experts who may have more SQL Server and possibly Windows 8 on one of their systems to answer that question.
0
 
PatHartmanCommented:
Why don't you download it and try.  You will probably have to change the default setting for your date fields when using SSMA since it defaults to a size that is incompatible with Access./
0
 
WoodrowAAuthor Commented:
Thank you all
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.