• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1004
  • Last Modified:

VS 2010 C# Access violation on Win8.1, works on Vista

I just installed a fresh version of Win8.1 and Visual Studio 2010.  I have a C# program that worked before and still works on my laptop.  However, when I run it in debug on my Win8 box, I get the following errors:

A first chance exception of type 'System.NullReferenceException' occurred in MixerNet.dll
A first chance exception of type 'System.NullReferenceException' occurred in MixerNet.dll
'MixerNetTest.vshost.exe' (CLR v4.0.30319: MixerNetTest.vshost.exe): Loaded 'h4v3tvsv'. Module was built without symbols.
The program '[5216] MixerNetTest.vshost.exe' has exited with code -1073741819 (0xc0000005) 'Access violation'.

The "loaded 'h4v3tvsv'" part changes every time I run the debugger.  It just fails when I try to run the .exe.  I loaded VS 2013 and got the same error.  

Folder that contains the project has full control for everyone.  Any direction as to what's going on is appreciated.
  • 2
1 Solution
Jacques Bourgeois (James Burger)PresidentCommented:
A couple of hints.

Did you install the same edition of Windows 8.1 as what you have on your Win8 computer? Some components.

I heard that there are a few components in framework 4.0 and 4.5 that do not work well with Windows 8.1. You might try to target framework 4.5.1 from VS2013.
StarDusterIIAuthor Commented:
Sorry, not sure I understand your first question.  I probably wasn't clear.  There is only one PC with Windows 8.1 on it.  I just used a generic Win8 to refer to it.

I changed from .Net Framework 4 Client Profile to .Net Framework 4.5.1 (no client profile here) and got a new error.  However, that one said I didn't have rights to change the registry so I ran the troubleshooter and had it run as Administrator and that worked.  I went back to VS 2010 and did the same thing there, reset the framework to 4 Client Profile and it worked there too.  

You weren't quite there but it pushed me into the solution, so I'll give you the credit!  ;-)
StarDusterIIAuthor Commented:
Wasn't quite the answer but led me to it
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now