We help IT Professionals succeed at work.
Get Started

Incorrect Function on Offline File Sync Windows 7 SBS 2011

ctagle
ctagle asked
on
3,081 Views
Last Modified: 2014-07-09
Hello everyone,

I have a windows 7 laptop that is part of a sbs 2011 domain and is used in the field quite frequently.  Because it is in the field and out of the office alot I set it up with offline files so they can edit files in the field and sync when they come back to the office.  The problem I'm having is that on every single file that I try to synchronize no matter which share i'm doing it from, be it redirectedfolers, share, etc... it tells me incorrect function when it tries to synch the file.

in the view sync results window i get the following on every file (the path changes depending on the location)

filename(\\servername\redirectedfolders\username\desktop)  incorrect function

So far I've tried -
disabling and re-enabling offline files
reinitializing the cache with a microsoft fix it tool
changing the name of the csc folder at c:\windows to csc.old to get it to recreate it
flushing the dns cache (this did correct a name resolution issue but it didn't affect the offline files issue)
checking the permissions, the user has full rights to the folder
checked the size of the cache limits on the hard drive, they are set to 112 gigs
went into the gpo for the redirection on the server and set up the users documents as a administratively offline folder.
set it to where the gpo for folder ridrection doesn't grant the user exclusive rights to the users redirected folder (it was set to do so before) (not sure if this is relevant to offline files or not)
scanned the computer for viruses using two well known programs (some websites suggested this error may indicate a virus), kaspersky (corporate version they are currently paying for) and the free malwarebytes scanner, both said it was pristine.

I've been through 4 full pages of links on google and nothing has really worked, any help with this would be greatly appreciated.  also offline files works on other computers on the network, its just this one having this problem.

I am personally beginning to suspect a DNS or permissions problem but I could be wrong, at this point i'm not sure what it could be.

as a side note I have VPN enabled on the server, the ip that the vpn connected users can connect to is 192.168.1.250, the ip address that everyone internally uses is 192.168.1.245, the incorrect resolution issue i spoke of earlier was the computer resolving to 192.168.1.250 when it was connected to the internal network, so i put a oneline batch file to flush the dns cache at logon and now it resolves correctly.  i'm not sure if this would affect the offline files or not.  

again thanks in advance for any help.
Comment
Watch Question
Business Consultant (Owner)
Most Valuable Expert 2012
Expert of the Year 2018
Commented:
This problem has been solved!
Unlock 1 Answer and 22 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE