Why won't my pivot table slicer group the dates into months, with the new data?

I am currently working with a pivot table someone else created. The data set has dates in one of the columns in the correct format. The slicer has the dates categorized by month and excludes the dates in which there was no data.

Here is my problem: I added a few new months of data. Everything is calculating just fine in the Pivot table. However, my slicer where I should be able to pick the month now has these new months listed as all their individual dates. I want to put the December dates under "December" and so on. The data that was present before I loaded anything additional still has this feature.

How do I group these dates, to be able to them as months? By the way, the grouping function is grayed out.
lora2014Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

byundtMechanical EngineerCommented:
I can't be sure (since you didn't post a workbook that demonstrates the problem), but the symptoms sound like the new dates are text instead of date/time serial numbers. To check, try changing the format of the new dates. If you can't change it, the date data are text that looks like dates.

To convert text into real date/time serial data, here are two good methods:
1.  Select a blank cell, then copy it
2.  Select the data to be converted
3.  Use the Paste Special...Add item
4.  Format the data using one of the date formats

1.  Select the data to be converted
2.  Open the Text to Columns menu item
3.  Choose Delimited in the first step of the wizard
4.  In the second step of the wizard, uncheck all the delimiter options
5.  In the third step of the wizard, select the column with your dates, and make sure you choose MDY or other date specification for your raw data
6.  Format the data using one of the date formats
lora2014Author Commented:
Thank you for your response. I however found a solution from my colleague as follows:

1. Remove all items in the Pivot table from the Rows Tables section
2. Add the dates to the rows (turn off any filters)
3. Select the dates - ungroup
4. Re-add the dates to the Rows tables section
5. Select the dates - group
6. Choose to group by month and year
7. Insert a slicer for the date and year
8. Remove the dates from the Rows table
9. Re-add any items removed in item 1

The issue was that with there being so many filters in the Rows Table, the dates could not be manipulated at all.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lora2014Author Commented:
Because...it worked. There was no issue with the dates data, just the Pivot Table. It had too many filters going in the rows.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Excel

From novice to tech pro — start learning today.