How do I install Linux Mint 16 on a VirtualBox hosted on Windows 7 (64 bit)?

Hi:

I am trying to install Linux Mint 16 on a Virtual Box on my Windows 7 machine.
I've run into some installation issues.

Can someone point me to a tutorial that walks me through the installation process?
I've got the latest version of VirtualBox (64 bit)
I've also got the .ISO for linux mint 16 mate 64 bit.

There are a couple of tutorials which are not specific to Mint 16. I followed those, but it does not seem to install correctly.

I run through the wizard:
1) Select Linux -> Linux 2.6/3.x
2) Create the virtual drive

When I go to start the virtual machine (to install the ISO),
the box "reboots", but then does not take me to the home screen from
where I can run the Linux install from.

I looked at the logs and don't see any obvious errors or exceptions occurring.

I've attached what the basic Linux Mint page looks like when I try running.

Any advice/tips would be greatly appreciated.

Thanks,
JohnB
LVL 1
jxbmaSoftware ConsultantAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
davidlevans13Connect With a Mentor Commented:
That's not cool...  nothing is going on !

I started doing this after an IT twitter guy mentioned it and it is a bit of a learning curve.

I now have 4 versions of Linux in VB machines... but it took a while to learn how to make it work.

Google search is my best IT friend.
Cool thing about VB is you can just delete the machine you just created and start all over again in about 2 minutes.
So, try that with the help from Virtual Box.
Not sure if you read this... https://www.virtualbox.org/manual/ch01.html

It's a lot of reading but just skim for highlights. Good thing about using Linux OS on virtual is it's free and you can just keep trying.

If I knew how to do a step by step guide I would do it...
0
 
TobiasHolmCommented:
Hi!

Mount the ISO-file on the host. Press "L"-key when booting the VirtualBox machine, and select to boot from the ISO-file.

Or delete the virtual hard drive file and create a new one, then boot the VirtualBox machine with the ISO-file mounted.

Regards, Tobias
0
 
jxbmaSoftware ConsultantAuthor Commented:
I've got the ISO file loaded on DVD and in drive.
When I click "Ctl - L", I don't see the option to "boot from ISO-file"

I see:
Start Linux Mint
Start in Compatibility mode
Integrity Check
Memory Test
Boot From Local Drive

It looks like Linux Mint just sort of hangs on the reboot.

JB
0
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

 
davidlevans13Commented:
Not sure if really important but I run the ISO for Linux off my C drive. I just download it to C drive and direct Virtual Box to that location.

I am using Win 7 64 bit and Virtual Box too.

I currently have 3 VMs on my machine just to play with. One is Linux Mint.
0
 
TobiasHolmCommented:
My mistake. Press F12 during boot in VirtualBox to see the bootmenu (see attached pic). Select "C" to boot from CD/DVD.
Boot menu in VirtualBox.
Boot Linux and click to install.
Boot Linux.Install Mint.
Press "Continue" a couple of times. I just changed keyboard layout and username/password.

When the installation is done, remove the virtual DVD and restart the virtual machine.
Restart Mint.
Regards, Tobias
0
 
jxbmaSoftware ConsultantAuthor Commented:
I must be missing something here.
I downloaded linuxmint-16-mate-dvd-64bit.iso to my windows 7 machine.
I burned the ISO to a DVD (via Windows).
I create a Linux Mint 16 instance on my machine.
I start up the instance, hit F12 and get the "boot menu"
I select "c" to boot from CD Rom
I see count down message "Linux Mint rebooting in..."
It counts down and then does nothing.

What am I missing here?
Why is VirtualBox not recognizing the DVD?

Apparently, I'm not the only one having issues.
I found this link:
http://forums.linuxmint.com/viewtopic.php?f=46&t=145794

It looks like ISO is too large for the DVD?
I haven't found any resolution yet.

Thoughts?

Thanks,
JohnB
0
 
davidlevans13Commented:
I just walked through the set up...  After you assign all the disk space, RAM etc and it creates the new file...  click start and when you get to the point pictured, just browse to where your ISO file is...  IF it is on the HDD of the machine you are working on, you can skip the CD and just direct the VB to that ISO..  as I did in this pic.
Virtual-Box.JPG
0
 
jxbmaSoftware ConsultantAuthor Commented:
Hey David:

That's pretty much what I did, except that I'm trying to install Linux Mint 16 rather than Ubuntu.

I'm thinking it's an issue with Mint 16?

JB
0
 
davidlevans13Commented:
I am just downloading the ISO for Mint 16 Cinnamon 64 bit now and will try to set it up... I'll let you know how it goes.
0
 
jxbmaSoftware ConsultantAuthor Commented:
Not to be naïve, but what is the difference between "Mint 16 Cinnamon 64" and "Linux Mint 16 Mate"?

I'm a windows guy trying to come up to speed with this.

Thanks,
JohnB
0
 
davidlevans13Commented:
Mate and Cinnamon are just 2 versions of the same program. Different interface..  I am not really super knowledgeable about different versions of Linux things.

You can switch from Mate to Cinnamon and vice-versa once you are installed
0
 
davidlevans13Commented:
Okay so...

I installed the Linux Mint in a VB machine. To do that I clicked on the Install Mint icon on the desktop that appears upon the first opening..  went through the install process and then it asks to restart. I clicked yes. Then the screen went black and nothing happened. SO... I shut down the machine using Machine>Close>Power Off Machine.

Then, back to VB control panel, highlight the new machine and click Start... and it loads.

So far so good

P.S.  Oh, at no time did I click F12.
0
 
davidlevans13Commented:
Thinking about this...  It seems that you needn't press F12 when the new machine first opens... If you have assigned the source ISO like in my picture above then you just let it countdown and don't push F12... just let it load.

Then you get the "Live" screen that has the "Install Mint" ( or whatever it says) icon, and you go from there.

Only trouble I had after that was having to force shutdown the machine when it was supposed to restart after install.
0
 
jxbmaSoftware ConsultantAuthor Commented:
Hi David:

What version of Virtual Box are you running? (I've got 4.36)

I followed the steps you outlined to the point of selecting the Mint-Mate ISO.
When I select the ISO I get the "Reboot Countdown".
I don't see an "Install Mint Icon" when first opening.
It just goes straight to rebooting and then pretty much hangs.

I gave it 2GB of RAM and 30 GB in disk space.

What am I missing here.
I'll bet that it's something foolish.

I've attached a snapshot of the Linux Mint desktop in Virtual Box that I see after reboot.

JB
LinuxMintImage.png
0
 
jxbmaSoftware ConsultantAuthor Commented:
Thanks for your excellent effort on helping me with this.
I 'd been googling a bunch to try to figure this out.
I was finally able to find a link in the VirtualBox forum.
I needed to do the following to get this to work:

1) Go the BIOS and make sure that hardware memory virtualization was turned on.
   (Now THAT was an obvious one...)
2) Use Ubuntu as my selected guest target
3) Increase my RAM to 2GB

I've been able to install it on one of my windows boxes.
I'm going to continue to test and install on my other box shortly.

Thanks again,
JohnB
0
 
davidlevans13Commented:
That BIOS setting never occurred to me...  I did that to mine when I built my machine. DOH.

I am glad to hear you got it running. I have fun just playing with it and learning enough to install it on other people's old laptops so they can still use them for email and surfing.
It is really good for that.

Enjoy.
Thanks for the points.. ( I always forget about the points thing...  I just like to help)
0
 
gheistCommented:
Profile should be Debian or Ubuntu
And you have to forcibly eject CD when system is rebooting (Debian and Ubuntu gives you prompt to get rid of CD)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.