[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 802
  • Last Modified:

Exchange setup for Netgear n300 router

Because I am switching from SBS 2003 to sbs 2011 I also have to switch from a 2 NIC system to a router based system. I have bought a Netgear N300 and installed it between my Cable modem and my switch. With the Netgear Geniew I have changed the routers IP-address to one that belongs to my LAN. Since my SBS server also runs DHCP I have disabled the routers function as a DHCP server. Wireless is not enabled.

My workstations can access the internet without problems, but Exchange doesnt collect the mail and I need help for that.
0
TheoRichel
Asked:
TheoRichel
  • 10
  • 9
  • 2
  • +1
1 Solution
 
Nick RhodeIT DirectorCommented:
You need to setup port 25 and 443 to forward to the exchange server on the router
0
 
Kash2nd Line EngineerCommented:
you need to make sure that all traffic is allowed to pass through to your main netgear from cable modem which i suppose, should be anyway.

I would try and create a rule on netgear to filter traffic for email to the IP address of the mail server.

On exchange server itself, can you successfully browser internet.

why not change the IP range on netgear to a different one which isn't a hard thing to do or make sure the ip addresses don't conflict.
0
 
Alan HardistyCommented:
Is Exchange collecting the mail or is it being delivered to it?

If you are collecting it, have you setup the POP3 Collection?

If it is being delivered, have you configured your new router to open the ports suggested above to the LAN IP address of your SBS 2011 server?

Have you also run the Fix My Network Wizard since adding the router?

Alan
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
TheoRichelAuthor Commented:
As to the suggestion of NRhode, I have added two port forwarding "rules" but they seem to have no effect.  From my server - where Exchange is located - I can surf the internet, as I can on all my workstations.
On these workstations Exchange says to be 'connected', so on the lan there are no problems. The whole thing of course came about when I installed that router.

What 'Fix My Network'-wizard?
0
 
Alan HardistyCommented:
The Fix My Network Wizard in in the SBS Console Under Network> Connectivity.

If you haven't run it - please do.  Use it anytime you make a change to your network.
0
 
TheoRichelAuthor Commented:
@Alan: That wizard is not in SBS 2003 (It is in 2011).

I have  however ran the Connect to internet wizard (the predecessor of the Fix-wizard) and it didnt help. I have probably made an error, but what.

Anyway, my Event log tells shows Event ID's 1019, 1023 and 1036
0
 
Alan HardistyCommented:
Sorry - are you in the middle of migrating or trying to fix the 2003 server?

If you are fixing the 2003 server use the Connect To The Internet Wizard under Start> Server Management> To Do List.
0
 
TheoRichelAuthor Commented:
Well both actually, I am migrating to 2011, and that Winversion requires a router, which I am setting up now.
Meanwhile I have opened up port 110 (or rather forwarded) on my router
0
 
Alan HardistyCommented:
Port 110 will allow you to collect mail via POP from your server. Is that what you want?
0
 
Kash2nd Line EngineerCommented:
i was under impression that you have migrated over to new exchange and was having issue collecting mail in the new version.

as per my original comment, you have to have all ports open for and make sure the traffic is flowing and once emails are flowing then close irrelevant ports.

You may want to NAT traffic to your email server internally.
0
 
TheoRichelAuthor Commented:
I have been working with Exchange for years. Now I have changed from a two NIC server to a server with one NIC and a router (Netgear N300). Ever since my mail does not come in anymore. I have run the Connect to Internet-wizard several times, but to no avail. Manually I have set port forwarding on the router of ports 25, 110 and 443 to the ip-address of my server.
0
 
Alan HardistyCommented:
Do you still have ISA server installed?

If you do - please remove it.
0
 
TheoRichelAuthor Commented:
No ISA server has never been installed on my system.
0
 
Alan HardistyCommented:
Okay - odd!

Have you disabled the WAN NIC and reconfigured the LAN NIC on the SBS 03 server?

Can the SBS 03 server get onto the internet?
0
 
TheoRichelAuthor Commented:
Yes I have disabled the WAN NIC and my server can get on the internet. I do not think I reconfigured anything on the LAN NIC.
0
 
Alan HardistyCommented:
Make sure you set the Gateway on the LAN NIC as it will probably be missing.

Was mail delivered to your SBS 03 server prior to the Dual-NIC setup?

Have you started the migration?
0
 
TheoRichelAuthor Commented:
And the gateway on the LAN NIC is the same as the Router IP?

'Was mail delivered to your SBS 03 server prior to the Dual-NIC setup?'
You mean DURING the dual NIC-setup? Yes

No I havent started the migration yet. Have to be in the hospital tomorrow so will have to quit now and continue in 24 hours. Thanks so far.
0
 
Alan HardistyCommented:
Yes - the Gateway is the router IP Address (LAN side).

Okay - so it should be delivered to the server as long as inbound port 25 is open and forwarded to the LAN IP Address of the SBS 03 server on the Netgear using the Firewall Rules on that.

No probs - once the 03 server is running happily, have a read through the following article, it's the one I always use for SBS 2003 to SBS 2011 migrations:

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/A_4234-Migrate-Small-Business-Server-2003-to-Small-Business-Server-2011.html

God luck tomorrow.

Alan
0
 
TheoRichelAuthor Commented:
OK, I am NOT home right now so the info I can give is limited. However: I have a webpage with a link to  My intranet with an IP-Address that starts with 212.x.x.x It worked alright until I installed My router. When I go to Shields Up I see that My outsider IP starts wit 82. This should Be 212 ets, I think. According to My ISP this is caused by My router/server.
0
 
Alan HardistyCommented:
You probably have the router set for DHCP so it collects the wrong IP from your ISP.

You should be able to specify the correct Fixed IP address on the router and then it should be happy and your mail should be delivered properly.
0
 
TheoRichelAuthor Commented:
I am changing that nr right now, but what should I then give in as subnet mask and default gateway
0
 
Alan HardistyCommented:
Your ISP should be able to give you those details.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 10
  • 9
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now