File/Folder permissions in Win7

I am trying to comprehend file/folder permissions in Windows 7. I created a file and a folder(file1 and folder1) and provided both read permissions in explorer.  I placed file1 and folder1 in an Explorer folder with an authenticated, system, administrator, and users with more permissions.  
Problem: I was still able to write to file1.  How do I make file1 truly read only?
gumball60Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

richmondjCommented:
If you're just making a file read only, right click on it, and in the attributes check "Read-only" and hit Apply.

If you're a command line type of person:

attrib +r filename.ext
JohnBusiness Consultant (Owner)Commented:
At the individual file / folder level, security is the same as it has been back to NT4 Workstation in terms of how to apply it.

Security has changed in detail and Windows 7 secures main folders like Program Files and such like.

But if you understood file security from earlier systems, it is very similar in Windows 7.

... Thinkpads_User
gumball60Author Commented:
I am still trying understand why after applying read-only permissions to file1 and placing it an Explorer folder with higher permissions....why my read-only did remain for file1? Is it an inheritance issue from the folder?
Expert Spotlight: Joe Anderson (DatabaseMX)

We’ve posted a new Expert Spotlight!  Joe Anderson (DatabaseMX) has been on Experts Exchange since 2006. Learn more about this database architect, guitar aficionado, and Microsoft MVP.

JohnBusiness Consultant (Owner)Commented:
If permissions have been applied to an individual file before placing in a folder, placing in that folder does not change the files permissions. You can set file permissions to what you want as was noted in an earlier post.

.... Thinkpads_User
richmondjCommented:
If by default, if you copy a file to a folder (or move a file from another volume) the file will inherit permissions from its parent.

To remove the default permissions, you have to go into Security > Advanced and break inheritance (uncheck "Include inheritable permmissions...") to keep the parent permissions from automatically applying.
gumball60Author Commented:
Richmondj...The "Include inheritable permmissions..." is grayed out.  I can not uncheck it.
richmondjCommented:
Is there a "Change Permissions..." button?  If so, you have to hit that first.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gumball60Author Commented:
Ooops...got it
file1 is now read-only
Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.