• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1037
  • Last Modified:

lost user home folder on server 2008 after moving user from XP to WIN7 pro

Previously on server 2003 and migrated to server 2008 R2.   All clients on xp machines with folder redirection (my documents) to user's home directory on d:/data/username (//servername/data/%username%.  No problems with my xp machines/users.  One user just moved to win7 pro and the home directory on the server changed to d:/data/my documents.

Folder redirection - documents enabled using GPO....  

target tab:
   settings -- basic redirect everyone's folder to the same location
   target -- redirect to the user's home directory

settings tab:
    checked off -- also apply redirect .... to 2000, 2003 windows xp.

I am not moving anyone else until I know where we went wrong
0
rmartes
Asked:
rmartes
  • 3
  • 3
2 Solutions
 
Will SzymkowskiSenior Solution ArchitectCommented:
When you use folder re-direction in Windows 7 there is a bug that converts the home folder to display "my docmuments". If you UNC to the users network drive with the proper name all data resides there and nothing is missing (\\servername\username\). There are a few methods you can take to work -a-round this...

1. create a subfolder under the users folder called Documents, then make that your re-direction point (this way the root folder is not be modified.

2. You can do this via Group Policy and create the folders manually.

3. Or you can Deny permissions on the desktop.ini file for "read" access.

The below link describes this in further detail.

http://support.microsoft.com/kb/947222

Will.
0
 
rmartesAuthor Commented:
were is the desktop.ini file in the server and how many are they?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Will SzymkowskiSenior Solution ArchitectCommented:
Desktop.in is a hidden file. It is located on the desktop. Open Folder options and make sure that "Hide Protected operating ssytem files" is unchecked, then apply this to all folders. You will then be able to see the desktop.ini on the desktop of all the profiles.

In XP there was a folders called "All Users" where you could apply this. In Windows 7 there is a folder called default with is equivalant to "all users"

Will.
0
 
rmartesAuthor Commented:
ok so this is done on the client machine not the server then?
0
 
Will SzymkowskiSenior Solution ArchitectCommented:
Becasue you are redirecting the documents folder to the network drive there should be a desktop.ini file in there home directory.

Will.
0
 
rmartesAuthor Commented:
Great!!  I saw where I forgot to uncheck - "Hide Protected operating sytem files".  That worked, but what about I still have a mixed environment so I'm going to have to do this every time.  I don't use roaming profiles and users do move around from computer to computer.   There has to be a better way......

Thanks
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now