Solved

Perc 6/i missing disk

Posted on 2014-01-02
18
1,732 Views
Last Modified: 2014-01-06
Windows server sbs2003
Power edge 1300 with a perc 6/I with a raid5 across 3 harddisk with a hotspare
Not sure what happen during the weekend but I got (non foreign)
VD mgmt.
Disk2 missing
Disk3 missing
The Controller sees 4 disks but the Group Disk and  Virtual Disk 0 only 2 disks (disk0 and disk1).
Can I delete the Virtual Disk without destroying the data on the 2 good hard-disks?
0
Comment
Question by:75carlos
  • 7
  • 7
  • 4
18 Comments
 
LVL 16

Expert Comment

by:R. Andrew Koffron
ID: 39753063
run a backup off what you have once it was a 3 disk set should still run on 2,
do not pass go, do not wait, don't reboot till your backup finishes if the data is important.

import a spare(new if possible, both offline disks are suspect now) disk and let the array re-build.  do another backup.
0
 
LVL 16

Expert Comment

by:R. Andrew Koffron
ID: 39753079
if I'm understanding the question, no, deleting the VD with the drives in will kill the data, but you could pull them and possibly put them into another controller and import media than rebuild the missing drive but , it's iffy, and I'd really try and re-build the VD off the two intact disks.  if you can't get a new disk to import and go into the array it's most likely a bad controller.


whatever you do if you end up looking for a new machine don't go with the low-end H310 controller, it's a joke, sustained data throughput is horrific in RAID5.
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 39754246
I don't think this can be a PowerEdge 1300 with a PERC 6.

"non foreign"

By this, do you mean you do NOT have a foreign configuration available?  In CTRL-R, go to the PD MGMT screen ... what is shown there?
0
 

Author Comment

by:75carlos
ID: 39754391
Don't have the screen in front of me but sill remember....
disk0    online
disk1    online
disk2   ready
disk3  ready

BUT, disk3 slot is empty...if I press F2 (available operations)over disk2 or disk3 I only get  something like "setup Global HS".  If I choose the option get message "this will not be applied to the current VD..."  or very similar phrasing....
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 39754434
Help me understand - this is important (!):  

Do you actually have 3 or 4 disks plugged into the system?  Your original post said 3, and your last post said 'disk 3 slot is empty', but you have disks 0-3 showing ... if your array is offline/inaccessible, 4 disks would make more sense, since if you had only 3 disks in a RAID 1 with 1 disk offline, your RAID 5 should still be online and its data accessible.  What we do next can either destroy or recover it, but it depends on how many disks and its exact configuration.

The above is what is showing on the PD MGMT screen?  Have you always had that number of disks?  Have you moved any disks?
0
 

Author Comment

by:75carlos
ID: 39754484
there was a raid5 with 3pd and a fourth as HSpare.
Yes I remove and put back the 2 pd that did show as "missing" (disk2 and disk3) after this they continue missing and not other option was available.

Last afternoon I did order a similar HD (a WD2500YS) which will arrive on Monday. At the same time I ran to Tigerdirect and got a similar one (but for desktop) just to try.

So at this point I have the 2 original PDs (disk0 and disk1) and this desktop HD  (sata 7200 rpm 250Mb) as disk2....slot fourth or disk4 is empty.

I did restart just in case but still showing:
disk0    online
disk1    online
disk2   ready*
disk3  ready
*it correctly identify the new hard-disk, it has a different model.....

Not matter what I do it seems that the VD is not able to "see" the new hard-disk, that's why my question about delete the VD and be able to reconstruct it or something...
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 39754542
"Not matter what I do it seems that the VD is not able to "see" the new hard-disk, that's why my question about delete the VD and be able to reconstruct it or something... "

First, is your array ONLINE and ACCESSIBLE?  You can boot to it, etc.?
0
 

Author Comment

by:75carlos
ID: 39754637
I don't have the server with me for now, but the server can't boot. Which also I can't understand.....
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 39754802
What is the last thing you see when you attempt to boot?  Do you see an OS blue screen or other OS error message?  Do you see the 5-second CTRL-E prompt?  or does it stop at the controller with some error message?  With 3 disks and 1 offline, it [the OS] should still be operational.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:75carlos
ID: 39755177
It goes all the post and the last message is, I think:

"....Press F1 to reboot, F2 to go to Setup...."
0
 
LVL 16

Expert Comment

by:R. Andrew Koffron
ID: 39755182
you'll need to assign the new disk as a hot spare I think (doesn't sound like you have anything to loose at this point.)

but your machine should boot on 2 disks, just be slow as hell.  so it sounds like there's a bigger issue than a single failure and a lost hot spare.

is it possible the hot spare got pulled in previously and the Array was not 0-1-2-3?
something like 0-2-3-4  if the hot spare was already activated and two more drives failed you're screwed.  restore from last backup.

my gut feeling is if the machine won't boot, you're most likely going to end up restoring the machine.

import the foreign disk, since you know what one is new, make it the hot spare. and the card should automatically make it pop into the degraded array.
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 39755302
He doesn't have a foreign configuration to import ... disks 2,3 are showing as Ready.  If disks 0,1,2 were in a RAID 5 and disk 2 is the only one not online with the array, AND the data is not accessible, there really isn't much point in doing anything else.  I mean, you could retag the array to make disk 3 appear as failed from the array, BUT it won't change the accessibility of your data.  Getting F1/F2 means that BIOS finds NOTHING bootable about your array - no boot files, etc. ... whatever happened, it appears that those files were damaged beyond recognition.

I would boot to your OS disc and attempt a startup repair of the OS - see if it even recognizes an installed OS - then attempt to repair it.

IF disks 0,1,2 were in a RAID 5, and 0,1 are showing Online, BUT you cannot boot the OS (or repair it), then you might as well start your restore from backup, because the current states of disks 2,3 don't matter.
0
 

Author Comment

by:75carlos
ID: 39755380
I'll checking this out Monday morning
0
 
LVL 16

Expert Comment

by:R. Andrew Koffron
ID: 39756103
he did add the desktop hard drive so at some point there was foreign media.  I'm not sure when and where in the process it was added.

I agree with PowerEdge that this is probably going to end up a restore.

I suggest getting all the original drives onto a new controller. and attempt tp Import them as a full set. Perc controllers (I think all RAID controllers) write the info of how they're setup so you can move them to a new card in the event of failure. as it really sounds like the controller is the problem, as a RAID5 +Hotspare setup should still run (albeit slowly) with just Disk0 and Disk1

I however wouldn't attempt the OS repair, until I'd exhausted all data recovery paths, and tried a new controller.  

this all depends how important the data is, and how far behind the backup schedule I was.
it's a lot of wheel spinning if there's not critical data.
0
 
LVL 32

Expert Comment

by:PowerEdgeTech
ID: 39756847
You could put all the original disks on the controller and do what is called a 'retag', where you delete the configuration, then reconfigure it with the exact same settings, WITHOUT initializing it.  I haven't suggested this, because I think it has a ZERO percent chance of working, since you can't currently access your OS with 2/3 RAID 5 drives online.  If you did a retag, you would need to force disk 2 offline immediately following the retag, but that would just leave you right back where you started.  My feeling is that something happened along the way (possibly when new disks were being introduced) that caused all this.
0
 

Author Comment

by:75carlos
ID: 39760140
My last comment was not posted...not sure why.

disk2 is gone, it was not seen by the controller. So I have 3 of the old disks. I deleted the Disk-Group and create a new Group-Disk with a new VD (raid5 )which is able to see the 3 disks, all of them online. The disks have not be Initialed.

I did not install the new disk on slot 4 yet. I reboot and the last enter on the bios was "Error loading operating system"

Trying to do as much possible before have to restore.....another thinking is that it never was a raid5 across 3 disk and a HS. It was a raid5 across 4 disks....Why I prepare the config in this way I don't remember, I do not need that amount of space, but can't find another explanation...=>  got a Raid5 on 4disk and lost 2 of them.....

any other option based on ther last entry at the BIOS?
0
 
LVL 32

Accepted Solution

by:
PowerEdgeTech earned 500 total points
ID: 39760203
That's exactly what I asked/said earlier:

"Do you actually have 3 or 4 disks plugged into the system?  Your original post said 3, and your last post said 'disk 3 slot is empty', but you have disks 0-3 showing ... if your array is offline/inaccessible, 4 disks would make more sense, since if you had only 3 disks in a RAID 1 with 1 disk offline, your RAID 5 should still be online and its data accessible."

If you retagged as a 3-disk RAID 5, and it was actually a 4-disk RAID 5, and you didn't force offline disk 2, then you need to just delete it and restore from backup, as this would have ruined the original RAID 5.
0
 

Author Closing Comment

by:75carlos
ID: 39760813
Thank you guys.

I got an error from the controler when I tried to create a dedicated HS...I think that was the reason I did create a 4 hd R5 instead of a 3hd R5 with HS.  I didn't remember this fact and assume it was a 3disk R5.
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Join & Write a Comment

Moving your enterprise fax infrastructure from in-house fax machines and servers to the cloud makes sense — from both an efficiency and productivity standpoint. But does migrating to a cloud fax solution mean you will no longer be able to send or re…
Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now