Solved

Internal web site redirect

Posted on 2014-01-03
4
313 Views
Last Modified: 2014-01-08
I have an internal website running and would like an easy way for my users to be able to access the site rather than having to put the server name etc... currently its http://company-tools/website.

I would like to maybe create a dns entry that will allow then to go to maybe company.com and it redirect internally to that internal address that i have. Is that possible?
0
Comment
Question by:eli290
  • 2
4 Comments
 
LVL 6

Expert Comment

by:ButlerTechnology
ID: 39753610
I don't think that a DNS entry is possible.  DNS works on the fqdn of the address not the file path.  You should be able to put a simple redirect to the directory.  What web server are you using?
0
 
LVL 25

Expert Comment

by:Zephyr ICT
ID: 39753631
If it's IIS you could use the redirect tool or adjust the web.config file and add the redirect there, this can look something like this (IIS7):

<system.webServer>
    <rewrite>
        <rules>
            <rule name="Root Hit Redirect" stopProcessing="true">
                <match url="^$" />
                <action type="Redirect" url="/website" />
            </rule>
        </rules>
    </rewrite>
</system.webServer>

Open in new window


Replace "redirect" with rewrite if needed.

The redirect tool way:

1- Select your site and click HTTP Redirect in the IIS section (You might need to install this tool first http://www.microsoft.com/en-us/download/details.aspx?id=7435)
2- Select "Redirect requests to this destination"
3- Write down the directory you want to redirect to. In your case "http://company-tools/website"
4- In the next step, Redirect Behavior you might have to select "Only redirect requests to content in this directory (not subdirectories)", or it might not work, experiment with it ...
0
 

Accepted Solution

by:
eli290 earned 0 total points
ID: 39753642
What I ended up doing was simply shortened the address to the root. The way I did this was within

IIS manager,

right click on default web site --> Manage Website --> Advanced Settings --> Then I just changed the physical path to the directory that I needed. Worked like a charm
0
 

Author Closing Comment

by:eli290
ID: 39764670
Was able to find an easy fix for my own question
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have a multi-homed DNS setup in windows, you can have issues with connectivity to the server that hosts the DNS services (or even member servers of your domain if this same DNS server is a DC). This is because windows registers all of its IPs…
Occasionally you run into the website or two that will not resolve properly using your own DNS servers.  Some people simply set up global forwarders for their DNS server.  I don’t recommend doing this because it can cause problems resolving addresse…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…

816 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now