• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1001
  • Last Modified:

SQL Server 2008 stops working every time I restart my computer

Every time I restart my PC I find that SQL Server Services in SQL Server Configuration Manager has reset SQL Server (SQLEXPRESS) to the 'Stopped' state.
0
TimHudspith
Asked:
TimHudspith
  • 2
  • 2
  • 2
  • +4
2 Solutions
 
SStoryCommented:
The following discussion talked of a similar issue. They said: "it appears the cause was due to the servers resources being reduced to zero and when that happened it sometimes crashed SQL server"
(source: http://stackoverflow.com/questions/3227249/sql-server-2008-r2-express-service-stopping-on-server)
0
 
Shaun KlineLead Software EngineerCommented:
Have you checked the Services control panel to determine if the Startup Type is set to Automatic?
0
 
TimHudspithAuthor Commented:
Yes, Start Mode is Automatic.
0
What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

 
Carl TawnSystems and Integration DeveloperCommented:
Check the System and Application logs to see if there are any messages related to the SQL Server startup.
0
 
SStoryCommented:
Did you see if you are running out of resources as the article I posted mentioned? Is it causing the machine to shutdown and disable for this reason?
0
 
tigin44Commented:
can you post the sql server start up log...
0
 
13ShadowCommented:
Check that the recovery response is set to Restart the Service and change the Restart the service after to 3 minutes (under the service properties Recovery tab).  Maybe it tries starting too soon and there are no resources available.
0
 
Eugene ZCommented:
what is your OS?
if win7/2008
set service to Start Mode is Automatic (delayed start)
and set the service recovery "first failure restart 1" or 2

also make sure you have installed a fresh service pack for Sql server \os
--
BTW: what sql  version do you have?  

more - you need to check event viewer related errors

and as per above post -- you may need  more Ram\NEW pc
Possibly uninstall some apps
check startup apps
run start->run-> msconfig to see hat can be disabled on startup
0
 
TimHudspithAuthor Commented:
Strangely, this hasn't happened the past few days (this is SQL Server 2008 on Windows 7). I looked at the Windows event viewer and SQL Server logs - I'm not sure what the exact message is that I should be looking for but nothing stood out. As for setting the service recovery to "first failure restart 1" or 2, where do I do this?
0
 
Eugene ZCommented:
buy more memory, check what can you uninstall to free resources, check  startup PC options- what services on startup can be "unchecked" see above post-recommendations .
also make sure you have installed MS Critical Updates and Running periodically Anti virus on your PC.

service recovery:

Start->Run-> type there  services.msc->  find SQL Server (SQLEXPRESS) -> right click -> properties-> Tab recovery -> set "First Failure"  to "Restart service"  etc

-> OK
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

  • 2
  • 2
  • 2
  • +4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now