Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Authentication Problem in Google Chrome Browser

Posted on 2014-01-03
6
Medium Priority
?
7,596 Views
Last Modified: 2014-09-25
I have recently downloaded the latest Google Chrome browser v31, when I run my Visual Studio web project locally in Google Chrome I receive an Authentication Required dialog, "The server http://localhost:80 requires a username and password". I am forced to click Login everytime. Is there a setting in Google Chrome that am missing?  I use IE11 browser without any problems.
When I run the same project on the production server using the same browser, there is no authentication problem. The problem is always on the development computer.  I use at Active Directory to access the users login with anonymous access disabled on the opening page.
Here is the code snippet:
    //ON-LOAD
    //=======
    protected void Page_Load(object sender, EventArgs e)
    {
        if (Page.IsPostBack) { }
        else if (!(Page.IsPostBack))
        {

            String sUserName = User.Identity.Name;
            string[] words = sUserName.Split('\\');
            gstrLogin = words[1];
            //gstrLogin = "Sam";  //USE FOR TESTING

        }
    }
0
Comment
Question by:mctc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 18

Expert Comment

by:Matthew Kelly
ID: 39794288
The reason this is likely confusing to the experts is that Chrome uses the same Internet Settings for authentication as IE. Additionally, Chrome does have support for Auto NTLM (it didn't always).

I believe the default is supposed to be local intranet sites are trusted, but just in case:

In Chrome, if you click "Settings -> Show Advanced Settings... -> Change Proxy Settings..." and then click on the "Security" tab, add "http://localhost" to the "Trusted Sites" list. Uncheck the https button if you aren't using it.

Restart the browsers (and use it once in IE to cache the credentials) then try again.
0
 

Author Comment

by:mctc
ID: 39798095
I tried the expert comment and followed the directions. I could not run the project (using Visual Studio) in Google Chrome without the "Authentication Required" dialog showing up when the project run in debug mode.

I did notice that when I clicked the Log In button with my username & password it displays the page correctly. This is different then before, where it displayed "This webpage is not available".
However, the "Authentication Required" dialog continues to be a problem.
0
 
LVL 18

Accepted Solution

by:
Matthew Kelly earned 1500 total points
ID: 39798801
This is just a shot in the dark, but try adding localhost to "Local Intranet" sites as well; again it should auto detect it as local intranet. Local intranet sites won't prompt for logon.

I am unsure why it wouldn't be trusted (Auto NTLM prompts for credentials from untrusted sites). The setting is in the Security tab; if you click Custom Level at the very bottom you can see the selection -- it should be auto logon to intranet sites; and sites without a tld domain should be automatically detected as local intranet.

I am running Visual Studio 2012 and use Google Chrome as my browser for debugging (it is the default browser on my computer and VS2012 defaults to the default browser). Without any setting changes it does NTLM authentication without prompting.
0
 

Author Comment

by:mctc
ID: 39851076
I tried the  Internet Properties, security tab, local intranet settings had a check mark in "Automatically detect intranet network", Trusted sites already had the http://localhost website entered.
I went in to the Security tab clicked Custom Level and selected "Automatic logon only in Intranet zone" from "Automatic logon with current user name and password" through the Chrome advanced settings. I closed the browser and reopened the project in visual studio using Chrome several times to make sure the setting was set.
However, it did not fix the issue...
I am still prompted with a completed username and password dialog box and I have to click the Login button each time which then lets me view the webpage. I tried changing the username and password to something different, but nothing seems to resolve the dialog un & pwd issue.
0
 
LVL 18

Expert Comment

by:Matthew Kelly
ID: 39858028
Sorry, I don't have any further ideas as this should "just work".
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Because your company can’t afford for you to make SEO mistakes, you’ll want to ensure you’re taking the right steps each and every time you post a new piece of content. This list of optimization do’s and don’ts can help you become an SEO wizard.
Australian government abolished Visa 457 earlier this April and this article describes how this decision might affect Australian IT scene and IT experts.
This tutorial walks through the best practices in adding a local business to Google Maps including how to properly search for duplicates, marker placement, and inputing business details. Login to your Google Account, then search for "Google Mapmaker…
Learn how to create flexible layouts using relative units in CSS.  New relative units added in CSS3 include vw(viewports width), vh(viewports height), vmin(minimum of viewports height and width), and vmax (maximum of viewports height and width).

661 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question