smtp settings for GoDaddy

Ok this is wierd.  I am working on a php page and all I have ever done is us asp.  The site is working fine but I want to send an smtp email from a "contact" form on the site and I don't know what the parameters are for a godaddy email account.  Here is my code...its not working...any help would be much appreciated:

	if ($errmsg == '') {
		$content = "A customer has submitted contact information through the website form:\n\n";
		$content .= "Email Address: " . $email . "\n";
		$content .= "Phone Number: " . $phone . "\n";
		$content .= "Additional comments: " . $comments . "\n";
		/* mail setup recipients, subject etc */
		$recipients = "";
		//$recipients = "";
		$headers["From"] = "";
		$headers["To"] = "";
		//$headers["To"] = "";
		$headers["Subject"] = "Intro Lesson Signup";
		/* SMTP server name, port, user/passwd */
		$smtpinfo["host"] = "";
		$smtpinfo["port"] = "25";
		$smtpinfo["auth"] = true;
		$smtpinfo["username"] = "username";
		$smtpinfo["password"] = "pwd";
		/* Create the mail object using the Mail::factory method */
		$mail_object =& Mail::factory("smtp", $smtpinfo);
		$mail_object->send($recipients, $headers, $emailbody);

Open in new window

For whatever it
Bob SchneiderCo-OwnerAsked:
Who is Participating?
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
Ok, your DNS and mail appears to be on Godaddy but your hosting is on BHI using IIS7.

I'm pretty sure that "" is not a SMTP host.  The SMTP server (to send email) that I use is '' on port 465 which requires SSL.  I'm using '' to receive email on port 995 which also uses SSL.  I'm not using 'Mail::factory method' so you'll have to look that up to see what the requirements are.
lruiz52Connect With a Mentor Commented:
smtp settings for godaddy is;
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.