Server 2008 R2 VPN

I have a 2008 R2 server with Routing and Remote Access setup. I also installed WINS. I can successfully connect VPN users. I added the WINS server in the VPN client side (Windows 7) software. I can browse \\servername and it shows the shared folders, just not all the subfolders under them. If I do \\serverIP or \\FQDN that shows all folders and subfolders.

Can someone point out what I am missing?
LVL 5
JasonDuncanworksAsked:
Who is Participating?
 
John Gates, CISSPConnect With a Mentor Security ProfessionalCommented:
Try this:
On the server, in the Routing and Remote Access "Properties" window, "IPv4" tab, "Enable broadcast name resolution" is checked.
On the laptop, in the VPN connection settings, IPv4, Advanced, on the WINS tab, NetBIOS is explicitly set to enabled.

-D-
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
The remote computer that connects over VPN needs to have the domain name appended to the  entry for the VPN network.

Please add it to the network settings of the VPN connection.
0
 
John Gates, CISSPSecurity ProfessionalCommented:
When at a command prompt does pinging the servername render the correct ip?
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
John Gates, CISSPSecurity ProfessionalCommented:
On the client you are attempting to connect with (sorry, should have stated that).
0
 
JasonDuncanworksAuthor Commented:
Thanks for your replies!

Nappy_d - I looked through the network settings on the VPN client and did not see where to append the domain name.

dimante - From the client machine I can ping the server by name and IP. This all resolves properly.


The clients are Windows 7 fully patched, the Server is 2008 R2 fresh install fully patched.

On my Windows 8 machine that is not joined to the domain and with adding anything to the VPN client I can see all subfolders from \\servername
0
 
John Gates, CISSPSecurity ProfessionalCommented:
This may sound odd but here goes.  It seems then you have a permissions issue...  Are you signed in as the same user on both machines? (The win 7 and win 8 boxes)?

\\<ip address>  \\computername are the same thing.  

What are the server logs showing?  Take a look and see if anything is listed regarding access errors.
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
Do this on your VPN connection for the DNS settings.  Once you have completed these settings, restart your VPN and ping the server name.  It should then respond with the fqdn:

Right click on the Properties of your VPN Connection
Step1
Go to the Networking tab
Click on IPV4
Click on Properties
Step2
Add the DNS server on the remote VPN site
Click on advanced
step3
Click on the DNS tab
Click on append these DNS suffixes
Add your DNS suffixes i.e. myCompanyDomain.com
step4
0
 
JasonDuncanworksAuthor Commented:
Thanks for everyone's replies. I tried the above suggestions and still have the same issue. I will keep trying and testing through the week.

Thanks again!
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
can you ping the server over vpn using only the netbios name and get a response?
0
 
JasonDuncanworksAuthor Commented:
Yes I can ping the server name over vpn and get a response.
0
 
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
And is that server response before or after the setting changes I suggested above?
0
 
JasonDuncanworksAuthor Commented:
It responds with and without those settings.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.