Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 325
  • Last Modified:

Exchange 2003 OMA testing error

Hi All,

I have a problem with Exchange 2003. When I wanted to access the OMA through web browser using a PC I received the following error:

<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="Off"/>
    </system.web>
</configuration>
 


<!-- Web.Config Configuration File -->

<configuration>
    <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
</configuration>
 
What do you think what could be the problem?
0
agriboy1980
Asked:
agriboy1980
1 Solution
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Hi

This does not look like the error you recieved but more a hint to get more detailed errors by adding <customErrors mode="Off"/> to the web.config. Did you try?
0
 
agriboy1980Author Commented:
uff, can you explain it in details how should I do this pls?

thx
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Hi

Open IIS and walk to the OMA entry, click it and select basic settings which will show you where the directory is on the harddisk.
Browse to this directory and open web.config (might require an elevated (as admin) rights tekst editor) then below the entry <system.web> you enter <customErrors mode="Off"/> like your posts mentions. Save it and open up the page to see what error it throws.
0
Lessons on Wi-Fi & Recommendations on KRACK

Simplicity and security can be a difficult  balance for any business to tackle. Join us on December 6th for a look at your company's biggest security gap. We will also address the most recent attack, "KRACK" and provide recommendations on how to secure your Wi-Fi network today!

 
agriboy1980Author Commented:
Hi,

I have done it but I still receive the very same thing.
Do you have any suggestions pls?
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
No more detailed error?
0
 
agriboy1980Author Commented:
It seems like nothing has happened, maybe I should restart some services?
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Nope, when IIS sees the web.config changed it will automatically restart the service.
Can you close the web.config and open it again, is the entry still there?
0
 
agriboy1980Author Commented:
Yepp, check it below.

<system.web>
            <!--  DYNAMIC DEBUG COMPILATION
              Set compilation debug="true" to enable ASPX debugging.  Otherwise, setting this value to
              false will improve runtime performance of this application.
              Set compilation debug="true" to insert debugging symbols (.pdb information)
              into the compiled page. Because this creates a larger file that executes
              more slowly, you should set this value to true only when debugging and to
              false at all other times. For more information, refer to the documentation about
              debugging ASP.NET files.
      -->
            <compilation defaultLanguage="c#" debug="false" />
            <!--  CUSTOM ERROR MESSAGES
              Set mode="on" or "remoteonly" to enable custom error messages, "off" to disable. Add
              <error> tags for each of the errors you want to handle.
      -->
            <customErrors mode="off" />
            <!--  AUTHENTICATION
              This section sets the authentication policies of the application. Possible modes are "Windows", "Forms",
              "Passport" and "None"
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
Ahhh sorry forgot to mention, the line is case sensitive, change off to Off
0
 
agriboy1980Author Commented:
yesss, now I got something different:

Denied access to the following path: C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\oma\55aaeb43\5ef66257

[UnauthorizedAccessException: Megtagadva a következo elérési út hozzáférése: „C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\oma\55aaeb43\5ef66257”.]
   System.IO.__Error.WinIOError(Int32 errorCode, String str) +393
   System.IO.Directory.InternalCreateDirectory(String fullPath, String path) +632
   System.IO.Directory.CreateDirectory(String path) +195
   System.Web.Compilation.PreservedAssemblyEntry.DoFirstTimeInit(HttpContext context) +85
   System.Web.Compilation.PreservedAssemblyEntry.EnsureFirstTimeInit(HttpContext context) +97
   System.Web.Compilation.PreservedAssemblyEntry.GetPreservedAssemblyEntry(HttpContext context, String virtualPath, Boolean fApplicationFile) +29
   System.Web.UI.TemplateParser.GetParserCacheItemFromPreservedCompilation() +91
   System.Web.UI.TemplateParser.GetParserCacheItemInternal(Boolean fCreateIfNotFound) +217
   System.Web.UI.TemplateParser.GetParserCacheItemWithNewConfigPath() +125
   System.Web.UI.TemplateParser.GetParserCacheItem() +88
   System.Web.UI.ApplicationFileParser.GetCompiledApplicationType(String inputFile, HttpContext context, ApplicationFileParser& parser) +171
   System.Web.HttpApplicationFactory.CompileApplication(HttpContext context) +43
   System.Web.HttpApplicationFactory.Init(HttpContext context) +485
   System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +170
   System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +414
.
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
In IIS Basis settings for the virtual directory OMA also shows you which user is used to connect to this C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322

User or application pool, if you use a user here it should have access to the path. ( check to click on test settings)
If you use application pool to connect check its user in application pools-> the pool used by OMA and check advanced options. If the user is NETWORKSERVICE try to change this to Local System and try the website again.
0
 
agriboy1980Author Commented:
At the OMA properties/folder security I found something that is might not good.
There is an Authentication tab and there "anonymus access.." is unchecked where the user is greyed out (IUSR_MAIL)
What do you think, should I check that?
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
could you post a printscreen, i dont understand completely what you are saying.
0
 
agriboy1980Author Commented:
here you are :)
exch.bmp
0
 
Patrick BogersDatacenter platform engineer LindowsCommented:
From memory i only select basic authentication, not anonymous and not integrated Windows. You can try it. BUT: the error states the user has no directory rights to that path so that is where i would focus on.

As you go, note the changes you have made. Once you find the solution it is handy to revert some actions. (like the customErrors=Off, you dont want that staying there)
0
 
sameertCommented:
0
 
Alan HardistyCommented:
Can you please advise what in the link posted above you followed that made this work for you in case the link breaks in the future.

Thanks

Alan
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now