Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Remote desktop connection from Windows 7 to Windows 2008 and Windows 2008 - 256 colours(8bit)

Avatar of FrancisV1971
FrancisV1971 asked on
SoftwareInternet ProtocolsIT Administration
4 Comments1 Solution1525 ViewsLast Modified:
Hello,
I'm running Windows 7 x86 and I want to connect to the pc's from the office (1pc is windows 2003 and the other is windows 2008) using Remote Desktop Connection. The problem is windows 7 minimum color depth is 15 bits and because the internet connection is slow I can't actually accomplish anything at all. I click today, the windows minimize tomorrow. After reading a lot I came to the conclusion that the connection will be better if I run the RDP session with less colours (256colours/8bit).
In order to be able to connect to the company computers I have to login with my username and password through some kind of SSH tunellier called Bitvise Tunellier(+SocksCap Control).If I try to connect without logging in first in the tunellier it doesn't work. The admin says it's related to security policies, but that's not my problem.
I did a lot of research and I found as a potential solution this little trick :

- Save all the remote desktop settings for the connection and save it to a RDP (.rdp) file by choosing Save As in the General tab.
- Open that .rdp file in a text editor (Notepad)
- Find the line that begins with session bpp:i:
- Change this line to session bpp:i:8
- Use (double click) that .rdp file to open a RDP session to the remote computer.

The problem is that .rdp file is not an .exe file, and Sockcap Control only accept paths to executables.

If anyone have any idea how can I run the RDP session in 8bit color depth in this scenario OR how can I force SocksCap Control to accept my .rdp file to run through it, please let me know. I'd rather prefer to run the msts.exe which is already added to SocksCap Control than the .rdp file thing, but any help will be highly appreciate.
Thank you in advance for you time and efforts.
Francis
ASKER CERTIFIED SOLUTION
Avatar of Qlemo
QlemoFlag of Germany image"Batchelor", Developer and EE Topic Advisor
Commented:
This problem has been solved!
Unlock 1 Answer and 4 Comments.
See Answers