Not enough USB controller resources

Posted on 2014-01-05
Last Modified: 2014-01-12
My Kodak i2400 scanner was working fine.  Then suddenly I get an error message that there are "not enough USB  controller resources."  Additionally, in the Hardware manager, when I right click on properties I get an error message that "The Device Will Not Start Code 10."  

Obviously I've googled the messages and I get generic responses.  Nothing specific to my hardware device or driver.  I've gone to Kodak's website and my hardware is windows 8 compatible and i have the most recent driver.

My system:
Windows 8 64 bit
16 GB Corsair Dominator Ram 2000
i7 4770k CPU OC'd from 3.5 to 4
Gigabyte GA z87-D3HP MoBo (with the latest chipset drivers, etc. from Gigabyte)

I brought a lot of work home with me that needed to be scanned and dealt with by tomorrow so I'll be up all night -- inputting data by touch typing.... ough.  Ouch.  Help.

PS Technical support by Kodak will call me tomorrow morning to troubleshoot the hardware (scanner) and it's covered by an overnight replacement service.  But I really don't believe it's the hardware.........  although one MSN report says the Code 10 can be a bad or conflicted driver -- or a problem with the hardware itself.

HELP.  Thanks.  And Happy New Year.
Question by:AFTerry
  • 2
  • 2
  • 2
  • +2
LVL 34

Assisted Solution

by:Dan Craciun
Dan Craciun earned 100 total points
ID: 39758597
Uninstall the driver/software using Add/Remove Software and/or Device Manager, reboot, reinstall.
If that does not work, you're probably out of luck and it's a hardware issue.

LVL 51

Accepted Solution

Joe Winograd, EE MVE earned 200 total points
ID: 39758632
Try a different USB port, and I suggest a USB2 port, not USB3. Although USB3 is theoretically downward compatible with USB2, I've had some USB2 devices fail on USB3 ports. Also, try a different cable. I never cease to be amazed at how often a bad cable is the culprit. With no moving parts, I often wonder how they can go bad, but they do! Regards, Joe
LVL 82

Assisted Solution

by:Dave Baldwin
Dave Baldwin earned 100 total points
ID: 39758647
I'd start with just unplugging the cable, rebooting, and then plugging it in again to see if it decides to work.  I've had my USB printers 'loose their minds' a couple of times and that brought them back.
LVL 91

Assisted Solution

nobus earned 100 total points
ID: 39758651
test the scanner on another pc - it can have problems
or test with another scanner
Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.


Author Closing Comment

ID: 39774116
I tried all of the suggestions and I learned that each has merit and are taken together the solutions are a process of elimination LIST.

Ultimately: after plugging the USB cord out of a 3.0 into 2.0 (ON THE BACK OF THE COMPUTER!!!!) it worked.

When I spoke to Kodak Tech support they told me the problem is that computer panel front ports "tend" to not get as much power as needed for some devices and the back panel USB ports do...
LVL 51

Expert Comment

by:Joe Winograd, EE MVE
ID: 39774123
Very interesting! Thanks for posting your results. Regards, Joe
LVL 91

Expert Comment

ID: 39774353
well -wa could not know, since you never told us your setup
LVL 82

Expert Comment

by:Dave Baldwin
ID: 39774406
I've had that happen, I just didn't think of it.

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

This is an article about Leadership and accepting and adapting to new challenges. It focuses mostly on upgrading to Windows 10.
In this article, I will show you HOW TO: Install VMware Tools for Windows on a VMware Windows virtual machine on a VMware vSphere Hypervisor 6.5 (ESXi 6.5) Host Server, using the VMware Host Client. The virtual machine has Windows Server 2016 instal…
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now