Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Dell 6224 VLAN Setup

Posted on 2014-01-06
10
Medium Priority
?
738 Views
Last Modified: 2016-11-23
Hi,

I'm trying to setup 2 vlans on dell 6224.
vlan1(default vlan) - 192.168.1.0/24
vlan150-192.168.150.0/24

The default vlan1 is assigned to all the 24 ports.
I have setup the management ip 192.168.1.111 and i can login to the switch using that.

I want to assign g/1-g/12 to vlan1 and g/13-g/24 to vlan150. Also i want vlan1 ip to be 192.168.1.111 and vlan150 ip to be 192.168.150.111. I do not want any communication between these two vlans. When i try to do certain changes it says cannot apply to default vlan.

How can i achieve this? please help.

Thank you.
0
Comment
Question by:Sajith Silva
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
10 Comments
 
LVL 47

Expert Comment

by:Craig Beck
ID: 39759276
Can you post the switch config please?
0
 

Author Comment

by:Sajith Silva
ID: 39759316
console#
console#
console#show running-config
!Current Configuration:
!System Description "PowerConnect 6224, 3.3.8.2, VxWorks 6.5"
!System Software Version 3.3.8.2
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 150
vlan routing 150 1
vlan association subnet 192.168.150.0 255.255.255.0 150
exit
stack
member 1 1
exit
ip address 192.168.1.111 255.255.255.0
ip default-gateway 192.168.1.2
interface vlan 150
name "VLAN150"
routing
ip address 192.168.150.111 255.255.255.0
exit


username "admin" password 00436d6ae2ed27bbe87fa24b73b5a249 level 15 encrypted
aaa authentication login "defaultList" line
aaa authentication enable "enableList" line
line console
password 00436d6ae2ed27bbe87fa24b73b5a249 encrypted
exit
line ssh
password 00436d6ae2ed27bbe87fa24b73b5a249 encrypted
exit
!
interface ethernet 1/g1
switchport mode general
exit
!
interface ethernet 1/g2
switchport mode general
exit
!
interface ethernet 1/g3
switchport mode general
exit


!
interface ethernet 1/g4
switchport mode general
exit
!
interface ethernet 1/g5
switchport mode general
exit
!
interface ethernet 1/g6
switchport mode general
exit
!
interface ethernet 1/g7
switchport mode general
exit
!
interface ethernet 1/g8
switchport mode general
exit
!


interface ethernet 1/g9
switchport mode general
exit
!
interface ethernet 1/g10
switchport mode general
exit
!
interface ethernet 1/g11
switchport mode general
exit
!
interface ethernet 1/g12
switchport mode general
exit
!
interface ethernet 1/g13
switchport mode general
switchport general allowed vlan add 150
switchport general allowed vlan remove 1
exit


!
interface ethernet 1/g14
switchport mode general
switchport general allowed vlan add 150
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g15
switchport mode general
switchport general allowed vlan add 150
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g16
switchport mode general
switchport general allowed vlan add 150
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g17
switchport mode general


switchport general allowed vlan add 150
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g18
switchport mode general
switchport general allowed vlan add 150
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g19
switchport mode general
switchport general allowed vlan add 150
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g20
switchport mode general
switchport general allowed vlan add 150
switchport general allowed vlan remove 1
exit


!
interface ethernet 1/g21
switchport mode general
switchport general allowed vlan add 150
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g22
switchport mode general
switchport general allowed vlan add 150
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g23
switchport mode general
switchport general allowed vlan add 150
switchport general allowed vlan remove 1
exit
!
interface ethernet 1/g24
switchport mode general


switchport general allowed vlan add 150
switchport general allowed vlan remove 1
exit
enable password 00436d6ae2ed27bbe87fa24b73b5a249 encrypted
exit
0
 
LVL 47

Expert Comment

by:Craig Beck
ID: 39759330
Ok so which commands are you getting errors on?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:Sajith Silva
ID: 39759350
I want the vlan1 interface IP to be 192.168.1.111. When I run the command it gives me "Cannot apply routing to default vlan". All I want to do is have two different vlans for 2 different networks.
*192.168.1.0/24
*192.168.150.0/24
0
 
LVL 26

Assisted Solution

by:Soulja
Soulja earned 600 total points
ID: 39759705
My experience with Dell switches in the past has been that the default vlan can't be used as a routed vlan. You my need to create an additional vlan to route with vlan 150.
0
 

Author Comment

by:Sajith Silva
ID: 39761968
I have left the default vlan on g1-g12. Vlan150 is on g13-g24 and I have given a IP for that vlan150. When i try to ping that IP from a laptop(192.168.150.112) it does not respond. Do I have to add any routing?
0
 
LVL 26

Expert Comment

by:Soulja
ID: 39762727
If the laptop is in vlan 1 than you might not be able to ping vlan 150.  What is the status of the vlan 150 interface?

Another  suggestion as a test would be to create another vlan interface ex. vlan 250 192.168.250.1.  assign an interface to the vlan. Then try pinging it from vlan 150.
0
 

Author Comment

by:Sajith Silva
ID: 39762736
Laptop is on vlan150. Also i have tried to add the routes but it's not registering on the switch.
0
 
LVL 47

Accepted Solution

by:
Craig Beck earned 300 total points
ID: 39762758
You won't need any routes as the switch will already have the routes it needs.

The laptop will need to use the IP address of the switch on VLAN150 as its default gateway.
0
 
LVL 26

Assisted Solution

by:Soulja
Soulja earned 600 total points
ID: 39762977
If you can't ping the vlan 150 interface and your laptop is sitting on that same vlan, than I would double check the ip configuration on the laptop.

As Craig stated. No routes are needed since the vlan subnets would be seen as connect routes automatically.
0

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a how to to configure a UCS Ethernet-uplink portchannel via the console. It is easy to do and can be done quite quickly. In certain versions of the UCS manager the portchannel has issues coming up and this is a workaround. I am…
This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Want to learn how to record your desktop screen without having to use an outside camera. Click on this video and learn how to use the cool google extension called "Screencastify"! Step 1: Open a new google tab Step 2: Go to the left hand upper corn…
Suggested Courses

670 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question