?
Solved

SMTP Relay Exchange 2010

Posted on 2014-01-06
4
Medium Priority
?
823 Views
Last Modified: 2014-01-07
Hello Everyone,

I have an Exchange 2010 server setup and I installed a ShoreTel phone system yesterday. When it comes to the SMTP feature, I have receive connectors that have been working and we are not an open relay.

For example, the shoretel server smart host set to smtp.office365.com with basic authentication and TLS. If I send it to an email address associated with the O365 account it works to various email accounts except my domain.

Something must be blocking it. I see that the eml message is stuck in the "queue" folder under IIS.

Help please!
0
Comment
Question by:ryanbarnes86
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 53

Expert Comment

by:Will Szymkowski
ID: 39760290
Can you test and remove "authentication" add the IP of the shoretel to the list of servers and then test and see if this works? You could also create a New Receive Connector and do the same test.

Will.
0
 

Author Comment

by:ryanbarnes86
ID: 39760296
hey Will - Thanks for the reply. What kind of receive connector would that look like?
0
 
LVL 53

Accepted Solution

by:
Will Szymkowski earned 2000 total points
ID: 39760385
Do the following...
- Open EMC
- Server Config>Hub Transport
- Create a New Receive Connector
- Create a Custom Connector
- Create a Name for the connector>click next
- specify the FQDN of the mail server
- Receive Mail from the following remote server (enter the IP of the shoretel server)
- Open the new receive connector>click Authentication Tab
- Make sure that TLS is enabled>click on the Permissions Tab
- Make sure that Anonyoums Users, Exchange Users and Exchange Servers are checked

Will.
0
 

Author Comment

by:ryanbarnes86
ID: 39763500
Thanks all who helped out. I already had the receive connector setup properly but here is what we ended up doing.

1.) In the ShoreTel Director system, removed the smart host fields.
2.) On the ShoreTel Windows Server (FTP, IIS, Application Server for ShoreTel), I went under IIS 6.0 and made it the relay. by doing the following:
Basic Authentication with credentials for Exchange 2010 with TLS
Unchecked the box under the "Advanced" section for "Delivery" that said send directly to host first.

That was the key... outside the other normal settings ShoreTel recommended. Darn ShoreTel.
0

Featured Post

Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A couple of months ago we ran into an issue that necessitated re-creating our Edge Subscriptions. However, when we attempted to execute the command: New-EdgeSubscription -filename C:\NewEdgeSub_01.xml we received an error indicating that the LDAP se…
Why do some people recommend buying business VoIP from an ISP? What are the benefits to my company? What are the costs?
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
This video discusses moving either the default database or any database to a new volume.
Suggested Courses
Course of the Month12 days, 4 hours left to enroll

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question