• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 10108
  • Last Modified:

Proxy config greyed out

We have two machines, both windows 7, both in the same OU with the same GPO settings.


One has the LAN settings (Proxy page) with everything greyed out.  The other does not have this greyed out.  

Looking at our GPOs, I see nothing that would do this.  
Checked here:
User Configuration\Administrative Templates\Windows Components\Internet Explorer\Disable changing proxy settings


Also, just to be sure:
User Configuration\Administrative Templates\Windows Components\Internet Explorer\Internet Control Panel\Disable Connections page


The only difference is one is running SP1, while the other is not.  I am updating now to test and see if SP1 somehow does this.


Any other places where this could be greying out the proxy settings?
0
ServerNotFound
Asked:
ServerNotFound
  • 5
  • 2
2 Solutions
 
BlueYonderCommented:
Go to the registry and follow theses instructions http://www.ehow.com/how_6346436_disable-proxy-settings-registry.html.  Make the DWORD in step 3, 0.
0
 
Jeremy WeisingerSenior Network Consultant / EngineerCommented:
Just to be sure, can you run a gpresult /h on both computers and view the settings?
1
 
ServerNotFoundAuthor Commented:
We found that the one machine was built using an unattend file with the proxy settings.  When we started to use GPO to push the settings out, this machine broke.


Jeremy, gpresult was tested and is the same

Blue, we are not looking for a reg hack.  These settings are not set, nor do we want to set them.

The registry of the machine with the attend file used has proxy info in the registry.  The vanilla one has no info in the registry for the proxy, yet it still works.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
Jeremy WeisingerSenior Network Consultant / EngineerCommented:
Since the setting was made using the Unattend file, you will need to reverse the settings made to the registry. There's no group policy setting to turn it off. You can use a script or Group Policy Preferences to deploy the change.
0
 
ServerNotFoundAuthor Commented:
We had deleted the setting from the place in HKLM, but on reboot it reappears in the same location...

HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\WINDOWS\CURRENTVERSION\INTERNET SETTINGS
0
 
ServerNotFoundAuthor Commented:
Unattend was this:




      <settings pass="oobeSystem">
    <component name="Microsoft-Windows-IE-ClientNetworkProtocolImplementation" processorArchitecture="amd64" publicKeyToken="XXXXXXXXXXXXXXX" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">
      <POLICYProxySettingsPerUser>0</POLICYProxySettingsPerUser>
      <HKLMProxyEnable>true</HKLMProxyEnable>
      <HKLMProxyServer>http://server.notfound.com/proxy/proxy.pac</HKLMProxyServer>
    </component>
  </settings>
0
 
ServerNotFoundAuthor Commented:
Found an easy way to fix it.  We set ProxySettingsPerUser to 1.
0
 
ServerNotFoundAuthor Commented:
Found the fix
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now