Serial port on Virtual machine not working? How can I test if it is setup correctly?

hi guys,

I have a VM running a Windows XP Pro using Vmware Workstation 8.0. There is a serial port on the actual physical host. To which a scanner is attached. I've added a serial port on the VM and have selected it to 'Auto Detect' and it says in brackets 'COM1' next to it which in my opinion should indicate that it has seen it?

However, the application which picks up the scanner is not doing so right now.

How can I test that the serial port is working? I've tried following this guide http://www.ni.com/support/serial/verhyper.htm and it didn't work either:(

Any help would be great
Thanks again
Yashy
LVL 1
YashyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization ConsultantCommented:
When the VM starts, enter the BIOS and change the COM port settings, to a port value, rather than Auto Detect.

I would suggest 2F8, which is COM2, and then check you have COM2 defined in Windows Device Manager.
YashyAuthor Commented:
Thank you sir:)

When you say 'check you have COM2 defined', do you mean on the virtual host I should go into the device manager and go into the 'Port' settings? But then what do I set those values to? Same as that which exists on the physical host?
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization ConsultantCommented:
Correct, set to the same value, that you have defined in the VM BIOS in the VM OS.

This also assumes you have already added the COM serial port device in VM settings, and set/selected the physical serial port on the host, which is known and tested to be working.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

YashyAuthor Commented:
I've gone into the BIOS and made the changes in the VM Bios to Enable instead of Auto Detect. COM2 is now 2F8. COM1 is 03F8.

However, on the VM, in the options you can only select 'Com1 (Auto Detect)'. It's still not working using COM1. The other available options are COM3 or COM4.

But in the device manager on the VM, COM 2 can be seen.

Any ideas?
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization ConsultantCommented:
The VM settings are correct, to "map" to your serial port on the host?

your host serial port is known to be working?

It does not really matter what COM is in use, but it's important that the address 2F8 is registered in the Windows XP OS? (in device manager)
YashyAuthor Commented:
Well i'd need to test the actual serial port to ensure it is working. Maybe via the actual hyperterminal on the XP OS?
compdigit44Commented:
You could test the scanner / device from your host workstation running Workstation to see if he device is able to be detected and work.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.