How do I share folders between my Windows 7 Host and Linux Mint 16 Guest using VirtualBox?


I'm a newbie to the world of VirtualBox, Linux Mint and such.

I'm in the process of setting up a Linux Mint VM on my Windows 7 machine.

I'm currently trying to set up a folder that I can share for uploads/downloads
between my Windows 7 Host Machine and my Linux Mint 16 Guest.

I powered down my VM and created a (permanent) shared folder (pointing to
a directory on C: drive).

I've googled around and found tons of different ways to do this (I found it quite

Can someone point to an easy straight forward method for achieving this?

jxbmaSoftware ConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization ConsultantCommented:
The simplest way is to use, Shared Folders, which is a special function included in Guest Additions.

Have you installed Guest Additions in your Linux VM?

Then configure Shared Folders as follows in your VM

HOWTO: Use Shared Folders
jxbmaSoftware ConsultantAuthor Commented:
I'm still not quite there.
Sorry if I can't seem to get this yet.

So far I've:

1) Installed the Guest Additions to my Linux VM
2) Added the Shared Folder through the settings dialog of my VM in VirtualBox UI
3) Created a folder off my home directory in the VM

At this point I'm trying to mount the drive, but can't quite figure out the format of the command.

I'm trying to use the following command:
VirtualBox Share Name: FooShare
Directory defined in VM home: SharedFolder

sudo mount -t vboxsf FooShare ~/SharedFolder

Clearly this is not correct.
Can you please help point out where the train came off the tracks for me?

jxbmaSoftware ConsultantAuthor Commented:
sudo mount -t vboxsf FooShare ~/home/instance/SharedFolder

It appears that I mount the shared drive successfully.
I don't see any error messages.

However when I either attempt to go to that folder and do an "ls " command in Terminal, or navigate to "SharedFolder" through the file browser, my mouse cursor turns into a "wait cursor" and just basically spins.

Is this a permissions problem?
I'm logged in as "root".

Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

What is path on the c:\? Can you post the following ?
ls -lah ~/home/instance/SharedFolder

Open in new window

jxbmaSoftware ConsultantAuthor Commented:
Hi Mazdajai:

When I run the following command:
ls -lah ~/home/instance/SharedFolder

I get the following error message:
ls: cannot access /home/instance/SharedFolder: No such file or directory

This is weird because I can see it from the Terminal session and the file browser.

Can post the commands you enter?

' ~/home/instance/SharedFolder' is different than '/home/instance/SharedFolder'

Can yo try -
mkdir /mnt/SharedFolder
sudo mount -t vboxsf FooShare /mnt/SharedFolder
ls -lah /mnt/SharedFolder

Open in new window

jxbmaSoftware ConsultantAuthor Commented:

The behavior is exactly the same.
The steps you suggested are steps (unless I'm missing something) that I've tried previously.

It just "hangs" in terminal mode.
I can type characters into the next line.
Is it expecting additional parameters?

There has to be something basic that I'm missing here.

jxbmaSoftware ConsultantAuthor Commented:
Any more insight here?
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization ConsultantCommented:
I've just tested this (with latest version of Virtualbox  4.3.6 r91406 and Linux Mint 16), and it does exactly the same thing, this is *NOT* normal. It hangs, when try to list the mounted folder.

the ls command should list the contents of the folder /mnt/sharedfolder

another option would be to connect to your Windows 7 Desktop via the Network.

see here
Interesting... Have you run apt-get update? Assuming iptables / AppArmor or SeLinux is turned off?

I will reproduce this in my lab tonight.
I have the same issue, this seems to be a known bug -

On the bottom line, you should able to write to the share.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jxbmaSoftware ConsultantAuthor Commented:
Mmm. VirtualBox; a technology that's almost useful.
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization ConsultantCommented:
@jxbma - should this have not been points split?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.