• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 506
  • Last Modified:

VLAN problem

I'm having a VLAN problem I believe. We have a Sonicwall F/W using several sonicwall Access points for our wireless. They all sync to the firewall. We have that Firewall and 3 switches Switch A,B,and C. There is a connection from the F/W to Switch A, a connection from switch A to Switch B in the same rack. Switch C is in another part of the facility and connected via fiber. most of the Access points are plugged into switched A and B and they work. we have 3 APs plugged into switch C that I cannot get to connect. From any PC I can connect to and ping siwtch C and get into its Web login but not the AP's plugged into it. The sonicwall created a VLAN for each SSID and we have VLAN 100, 200, 300, 400. On Switch A and B its set to have ports 1-24 tagged for all those VLAN ID's so I set switch C up the same way and yet I cannot connect to them. What am I missing?
0
Axis52401
Asked:
Axis52401
  • 9
  • 8
1 Solution
 
giltjrCommented:
Were the access points connected to switch C configured correctly?  They need to tag those VLAN's also.
0
 
Axis52401Security AnalystAuthor Commented:
Yes, Switch C is a replacement so at one point they did connect. The sonicwall even shows them listed in the Sonicpoint menu, they show as offline right now.
0
 
giltjrCommented:
What type of switch is switch C?  Can you hide any private info and post the config?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Axis52401Security AnalystAuthor Commented:
Its a HP 1910 Switch, do you know if that config can be exported like with a cisco?
0
 
Axis52401Security AnalystAuthor Commented:
Here is a screen shot of the VLAN settings, port 9 connects to the other switch ports 1-3 to the Access points
vlan.docx
0
 
giltjrCommented:
I would suggest trying to configure the ports as trunks.  I need to check and see what hybrid does on HP switches.

According to the below site there are secret CLI commands:

http://glazenbakje.wordpress.com/2012/08/21/hp-v1910-secret-commando-list-how-to-enable-it/
0
 
giltjrCommented:
Just a quick warning, in trunk mode only ONE VLAN can be untagged, I just noticed that on some of the ports you have two untagged VLAN's.
0
 
giltjrCommented:
What is VLAN 50 used for.  It is untagged, but you also have VLAN 1 as the PVID.  

If I understand what I have read about the HP 1910, any untagged frame will be tagged using the PVID, so all untagged traffic will be assumed to be in VLAN 1.
0
 
Axis52401Security AnalystAuthor Commented:
I'm using the WEB GUI not the command line interface. I don't know what that will do, the other switches, Switch A for example (see screen shot is setup ths way.
vlan2.docx
0
 
giltjrCommented:
O.K. it looks like VLAN 50 is used to communicate with the AP's and on the ProCurve VLAN 50 is untagged on most of the ports.

It looks like you can either leave those ports as hybrid or change them to trunks.

In either case you need to make VLAN 50 as the native (PVID) VLAN.

Reading more of the HP doc, hybrid mode should only be used is special cases, so I would change those ports to trunks.
0
 
Axis52401Security AnalystAuthor Commented:
OK, so do I need to change the ports to Tagged for VLAN 50? I think we've tried that amongst a few other things today? How do I make VLAN 50 as the native (PVID) VLAN? SHould I change those ports and if so what ports 1-3 or port 9 too (port 9 in the port that connects to the other switch) to trunks.
0
 
AkinsdNetwork AdministratorCommented:
I will assume these are lightweight APs (LWAP) and not Autonomous.

If so, the APs need to connect to a DHCP server, (unless IP is statically assigned) then to the controller.

If that is your setup, you'll need to set the ports where the APs connect to as access ports and assign them to vlan 50.

I hope this helps
0
 
Axis52401Security AnalystAuthor Commented:
I found  setting to VLAN 50 as the native (PVID) VLAN I think (see screenshot) still no connection to the AP's
vlan3.docx
0
 
Axis52401Security AnalystAuthor Commented:
The AP's have static addresses assigned on them, how do I set the ports where the APs connect to as access ports and assign them to vlan 50.
0
 
giltjrCommented:
You need to remove VLAN 50 from being tagged.
0
 
giltjrCommented:
If you look at the ProCurve setup, you will see that VLAN 50 is untagged on all ports but 4.
0
 
Axis52401Security AnalystAuthor Commented:
That did it, thanks for all your help
0
 
giltjrCommented:
But leave it tagged on Ge1/0/1.  Just make it untagged only on the ports connecting to the AP's.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 9
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now