Exchange 2010 Imap question

We have set SBS 2011 server with exchange. We have a third part SSL cert and all remote users can use exchange.  We have one user that is using apple mail and because of the issues with the latest version needs to use IMAP.

I have set IMAP up but and everything works but in in outlook when I set the "my server requires authentication" I get an error that says the client  does not support the authentication method.  

I have tried the three authentication methods listed for IMAP but I still get the error.  If I do not check the box I don't get an error but I can only send mail to internal users.
JsawyerJnJAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Paris VicenteInfrastructure DesignerCommented:
Did you restart de IMAP4 Service after configuration?

Please take a look here for the possible ways -> Start and Stop the IMAP4 Service

For a better comprehension on POP and IMAP take a look here Authentication POP/IMAP


Hope this could help you.

Regards
JsawyerJnJAuthor Commented:
yes I started and stopped the service several times. Nothing changes.  I did notice some thing strange when I tried to add a port for smtp on my lab server it works but on this production server I get a message when I telnet that says service is not available.

Regards
David Paris VicenteInfrastructure DesignerCommented:
Can you do put the info and logs here after run this commands:

1.Use the command Get-ReceiveConnector | select identity to get the Identity of receive connectors of Exchange 2010 server.

2.Run the command Get-ReceiveConnector -id “receive connector” | fl and post the return.

Regards
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

JsawyerJnJAuthor Commented:
[PS] C:\Windows\system32>Get-ReceiveConnector

Identity                   Bindings                   Enabled
--------                   --------                   -------
EXMAIL\Default EXMAIL      {0.0.0.0:587, 10.0.3.75... True
EXMAIL\Windows SBS Fax ... {127.0.0.1:25}             True
EXMAIL\Windows SBS Inte... {10.0.3.75:25}             True


[PS] C:\Windows\system32>Get-ReceiveConnector -id "Default Exmail"

Identity                   Bindings                   Enabled
--------                   --------                   -------
EXMAIL\Default EXMAIL      {0.0.0.0:587, 10.0.3.75... True
David Paris VicenteInfrastructure DesignerCommented:
Thanks, but the last command is not complete.

Can you please use the FL ( format list )

Get-ReceiveConnector -id "Default Exmail" | FL

And post it.

Regards
JsawyerJnJAuthor Commented:
Sorry about that.

[PS] C:\Windows\system32>Get-ReceiveConnector -id "Default Exmail" | FL


RunspaceId                              : 824a8bb9-add0-4d6c-93a4-98ac1bc9c4d5
AuthMechanism                           : Tls, Integrated, BasicAuth, BasicAuth
                                          RequireTLS, ExchangeServer
Banner                                  :
BinaryMimeEnabled                       : True
Bindings                                : {0.0.0.0:587, 10.0.3.75:25}
ChunkingEnabled                         : True
DefaultDomain                           :
DeliveryStatusNotificationEnabled       : True
EightBitMimeEnabled                     : True
BareLinefeedRejectionEnabled            : False
DomainSecureEnabled                     : False
EnhancedStatusCodesEnabled              : True
LongAddressesEnabled                    : False
OrarEnabled                             : False
SuppressXAnonymousTls                   : False
AdvertiseClientSettings                 : False
Fqdn                                    : EXMAIL.aemgrp.local
Comment                                 :
Enabled                                 : True
ConnectionTimeout                       : 00:10:00
ConnectionInactivityTimeout             : 00:05:00
MessageRateLimit                        : unlimited
MessageRateSource                       : IPAddress
MaxInboundConnection                    : 5000
MaxInboundConnectionPerSource           : unlimited
MaxInboundConnectionPercentagePerSource : 100
MaxHeaderSize                           : 64 KB (65,536 bytes)
MaxHopCount                             : 60
MaxLocalHopCount                        : 8
MaxLogonFailures                        : 3
MaxMessageSize                          : 58.59 MB (61,440,000 bytes)
MaxProtocolErrors                       : 5
MaxRecipientsPerMessage                 : 5000
PermissionGroups                        : ExchangeUsers, ExchangeServers, Excha
                                          ngeLegacyServers
PipeliningEnabled                       : True
ProtocolLoggingLevel                    : None
RemoteIPRanges                          : {10.0.3.2-10.0.3.255, 10.0.3.0-10.0.3
                                          .0}
RequireEHLODomain                       : False
RequireTLS                              : False
EnableAuthGSSAPI                        : False
ExtendedProtectionPolicy                : None
LiveCredentialEnabled                   : False
TlsDomainCapabilities                   : {}
Server                                  : EXMAIL
SizeEnabled                             : EnabledWithoutValue
TarpitInterval                          : 00:00:05
MaxAcknowledgementDelay                 : 00:00:30
AdminDisplayName                        :
ExchangeVersion                         : 0.1 (8.0.535.0)
Name                                    : Default EXMAIL
DistinguishedName                       : CN=Default EXMAIL,CN=SMTP Receive Con
                                          nectors,CN=Protocols,CN=EXMAIL,CN=Ser
                                          vers,CN=Exchange Administrative Group
                                           (FYDIBOHF23SPDLT),CN=Administrative
                                          Groups,CN=First Organization,CN=Micro
                                          soft Exchange,CN=Services,CN=Configur
                                          ation,DC=aemgrp,DC=local
Identity                                : EXMAIL\Default EXMAIL
Guid                                    : 9d836b15-0038-4276-a193-cddfdf718236
ObjectCategory                          : aemgrp.local/Configuration/Schema/ms-
                                          Exch-Smtp-Receive-Connector
ObjectClass                             : {top, msExchSmtpReceiveConnector}
WhenChanged                             : 1/6/2014 9:48:12 PM
WhenCreated                             : 12/19/2013 10:04:36 PM
WhenChangedUTC                          : 1/7/2014 2:48:12 AM
WhenCreatedUTC                          : 12/20/2013 3:04:36 AM
OrganizationId                          :
OriginatingServer                       : EXMAIL.aemgrp.local
IsValid                                 : True



[PS] C:\Windows\system32>
David Paris VicenteInfrastructure DesignerCommented:
Thanks.

At first glance looks ok.

You can telnet port 143 from internal network?
Can you confirm that X509 certificate name is correct in your case will be EXMAIL

Please verify that this files exits on your server:

C:\program files\Microsoft\Exchange Server\V14\ClientAccess\PopImap\Microsoft.Exchange.Pop3.exe.config

C:\program files\Microsoft\Exchange Server\V14\ClientAccess\PopImap\Microsoft.Exchange.Imap4.exe.config

AND the following lines exits:
The following lines were supposed to be there and had to be added manually:

<dependentAssembly>
 <assemblyIdentity name="Microsoft.Exchange.Compliance" publicKeyToken="31bf3856ad364e35" culture="neutral" />
 <codeBase version="14.0.0.0" href="file:///C:\Program Files\Microsoft\Exchange Server\V14\bin\Microsoft.Exchange.Compliance.dll" />
 </dependentAssembly>



1. Test-ImapConnectivity on the server and see if return the Success result. It proved that IMAP works properly on your server side;

2. Setup IMAP profile in the Outlook client, if works properly. It proved that the IMAP connection betwen the Outlook and server is OK;

You can see here the configs for How to configure Outlook for POP3/IMAP and SMTP Connectivity in SBS 2008/2011 Standard


 I also suggest that you could create a whole new mailbox on your server, then configure the IMAP profile in a client to verify if the issue still remained or not. I believe it could be a checkpoint.

Of course, please run the following command in the EMS:

Get-ImapSettings | FL and post it


I have hope that this can lead you on a good way.

Let us know
Regards
suriyaehnopCommented:
Try this:

Telnet <Exchange running IMAP services> 143  - Do you receive the banner

Run EMS - Get-IMAPSettings -Server <sername> | FL - Verify the LoginType. By default it was set to SecureLogin

Download Putty application and run telnet session to IMAP server, verify the imap settings for user is working.

http://htluo.blogspot.com/2009/01/how-to-test-imap-connection.html

refer to this article as well

http://www.msexchange.org/articles-tutorials/exchange-server-2007/mobility-client-access/using-pop3-imap4-access-exchange-2007-part1.html

Try using same settings as mine
IMAP.doc
JsawyerJnJAuthor Commented:
The problem was I was looking at the wrong connector it was the Windows SBS Internet connector not the default.

It appears to work after I changed the settings.  I will test some more tomorrow.

Thank you

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JsawyerJnJAuthor Commented:
I was led to the correct solution with this persons advice.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.