Solved

Redirect http://mail.mydomain.com to https://mail.mydomain.com/owa

Posted on 2014-01-06
16
975 Views
Last Modified: 2014-01-26
I need to redirect http://mail.mydomain.com to https://mail.mydomain.com/owa. Basically I do not want users to have to type /owa or /exchange on the end of the URL.

I have configured the IIS server exactly the way this tutorial shows:

http://briandesmond.com/blog/redirecting-owa-urls-in-exchange-2010/ 

After making all of those changes and doing a IISRESET.EXE command, I open up a web browser and type mail.mydomain.com and I given a 403 not authorized page. It says the server denied the specified URL.

I do have OWA rules setup in ISA server. Could their possibly be something in there that is causing this issue?

Thank you
0
Comment
Question by:Yeloball
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 4
  • 2
  • +1
16 Comments
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 39761227
You can't do an IIS redirect. It will break Exchange Web Services. I would remove it immediately.

Instead modify the default IIS home page in the root of the Default Web Site and just drop in a quick and easy javascript redirect in the IISSTART.HTM page.

Code here.
http://www.tizag.com/javascriptT/javascriptredirect.php
0
 

Author Comment

by:Yeloball
ID: 39761240
Should I remove the IIS redirect from all virtual directories, or just the default website?
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 39761255
Definitely remove it from the default website. What action is it performing on the other virtual directories?
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Comment

by:Yeloball
ID: 39761261
Exchange, Exchweb, and public have /owa in the redirect, and the box checked to only redirect requests to content in this directory (not subdirectories)

I put that Javascript code in and it did not work.

I am trying to go from http to https
0
 
LVL 21

Expert Comment

by:Hendrik Wiese
ID: 39761574
Changing the Default Web Site Redirect URL to https://exchange.iemas.co.za/owa will not break the  Exchange Web Services so leave that as is but ensure that the check box is checked to only redirect requests to content in this directory (not subdirectories)

Next:
1. On your Exchange, Exchweb and Public leave the setting as /owa
2. Remove the check from only redirect requests to content in this directory (not subdirectories) on Exchange, Exchweb and Public

The above is the correct setup. Let me know if it makes a difference after changing the settings?

Hope this helps
0
 

Author Comment

by:Yeloball
ID: 39761992
HendrikWiese,

I made these changes you provided and did a iisreset and it is still not working.

This is not working on the inside or the outside.
0
 
LVL 21

Expert Comment

by:Hendrik Wiese
ID: 39762023
How many CAS servers have you got? If more than 1 did you make the changes on all of them?

Cheers!!
0
 

Author Comment

by:Yeloball
ID: 39762034
I only have 1 CAS server. I looked at my bindings in IIS, do I need to have my domain name listed in there of mail.mydomain.com?

Thanks
0
 

Author Comment

by:Yeloball
ID: 39762038
If so, does it need to be put in there at mail.mydomain.com.owa or just mail.mydomain.com

Additionally; does it have to be on port 80, 443, or both?

Thanks
0
 
LVL 4

Expert Comment

by:SEHC
ID: 39762059
HI


here is how to make the change


1.Start IIS Manager.
2.Expand the local computer, expand Sites, and then click Default Web Site.
3.At the bottom of the Default Web Site Home pane, click Features View if this option isn't already selected.
4.In the IIS section, double-click HTTP Redirect.
5.Select the Redirect requests to this destination check box.
6.Type the absolute path of the /owa virtual directory. For example, type https://mail.contoso.com/owa.
7.Under Redirect Behavior, select the Only redirect requests to content in this directory (not subdirectories) check box.
8.In the Status code list, click Found (302).
9.In the Actions pane, click Apply.
10.For the new settings to take effect, open a Command Prompt window, and then type iisreset /noforce to restart IIS.


this should do it unless you are running a TMZ server then you need to also make the changes on the TMZ server
0
 

Author Comment

by:Yeloball
ID: 39762087
SECH,

Correct, this is the way it is setup, but still receive a 403 not authorized error when going to URL mail.mydomain.com

I am able to get to it by going to http://mail.mydomain.com/owa and https://mail.mydomain.com/owa
0
 
LVL 21

Expert Comment

by:Hendrik Wiese
ID: 39762571
Are you testing this from your CAS server and local machine? My setup is done in the exact same way that I explained to you earlier.  So it is very weird that your is not working.

Are you sure all your settings are correct?
0
 

Author Comment

by:Yeloball
ID: 39762581
Yes, I am testing from CAS and local machine. I have this published through ISA server 2006. I think this is where the issue might reside because of the 403 forbidden error. Do you have any experience with that?
0
 
LVL 21

Expert Comment

by:Hendrik Wiese
ID: 39764190
Hi,

You can try to follow the following tutorial to ensure that your ISA is setup correctly: Outlook Web Access redirection via Microsoft ISA 2006

Hope this helps.
0
 

Accepted Solution

by:
Yeloball earned 0 total points
ID: 39798957
Found that the IIS was pointing to the wrong directory for the website. Changed it back and everything worked properly.
0
 

Author Closing Comment

by:Yeloball
ID: 39809860
The directory in IIS was not pointing to the default website, it was pointing to another directory which was not allowing the RDweb page to show.
0

Featured Post

Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Suggested Courses

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question