Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 462
  • Last Modified:

Apple & TCP/IP

Hi, This morning I am attempting to configure a brand new, just out of the box TP-Link TL-R470T load balance router. I hooked it to my iMac via ethernet and watched the TCP/IP tab in the Advanced Network Preferences window expecting it to pick up 192.168.0.xxx from DHCP in the router. It did not, it just assigns a private address after a minute, presumably due to no DHCP service being available.

The ethernet connection shows as physically connected both in Network Preferences on the iMac and on the LED display on the router, but no addressing is taking place. I used the brand new ethernet cable out of the box with the router.

Doesn't this work the same as with a Windows computer?
0
westone
Asked:
westone
  • 10
  • 4
  • 4
  • +1
1 Solution
 
Miguel Angel Perez MuñozCommented:
Probably has DHCP disabled, try resetting to defaults (usually has a button to do this). On Windows must be same.
0
 
Zephyr ICTCloud ArchitectCommented:
You need to configure a fixed IP-address in the same subnet e.g: 192.168.0.2 with 255.255.255.0 as subnetmask. Then connect to your router and configure it.
0
 
westoneAuthor Commented:
I have tried the reset several times, pressing it briefly, pressing it for at least 30 seconds, and pressing it while the router powered up. DHCP is still not handing out any numbers.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
westoneAuthor Commented:
I have also tried manually configuring the IP settings, conforming to the IP scheme given in the setup guide. It won't surf to the default IP address of the router given in the setup guide.
0
 
westoneAuthor Commented:
Maybe it is a rare case of dead on arrival.
0
 
MiftaulCommented:
Network devices in its factory default are not configured as DHCP server. I havent worked on this particular device TP-Link TL-R470T load balance router.

In most cases, you need to set a static address to your workstation in the same subnet the device interface is on (its found on the documentation that comes with the device). You Telnet or logon to the device in GUI and configure it to work however you want.

169.254.x.x addresses are assigned to a device when the device is configured to obtain IP address automatically but it doesn't find any DHCP server, particularly in windows machines. The link LEDs are up because the Layer2 connectivity is established, but we need Layer3  reachablity to configure the device.
0
 
Zephyr ICTCloud ArchitectCommented:
Are you also connected to another network through WiFi by any chance? If yes, try disconnecting from that network and try connecting to the router again with the fixed IP address  ...
0
 
westoneAuthor Commented:
Miftaul, I have rarely, if ever, worked with an off the shelf consumer grade router that did not have DHCP turned on by default. The setup guide specifically states to have TCP/IP configured to obtain addresses automatically. If you read my previous posts you will see that I am unsuccessful at manually configuring TCP/IP and browsing the GUI. This is not a business class router. There is no telnetting into this thing.
0
 
westoneAuthor Commented:
spravtek, I disconnected from my WLAN and had no other network connections active when attempting to connect to the router. Thanks for the suggestion, though.
0
 
Zephyr ICTCloud ArchitectCommented:
You haven't configured a gateway have you? ... Just checking...

So, even with the fixed ip and connected through wire with the router you are unable to ping said router?
0
 
MiftaulCommented:
westone. There are many consumer grade devices that doesn't come up with DHCP pre-configured, say SonicWALL TZ/NSA.

Like this very TL-R470T+, it doesn't have DHCP configured in its factory default. You need to set an IP in subnet 192.168.0.0/24 to the workstation to have Layer3 reachablity with the TL-R470T+. The device itself is at 192.168.0.1 by default.
0
 
westoneAuthor Commented:
No, I haven't configured this iMac as a GW. However, when setting manual IP settings it does allow for the router address, which I did configure according to the address in the setup guide. I don't think that is what you meant though.

I only tried to surf to the default router IP: http://192.168.0.1

I don't know how to ping in OS X. If you can tell me I'd like to know. It would be handy.
0
 
westoneAuthor Commented:
@ Miftaul: For your benefit, this directly from the setup guide:
 
You can configure the PC to get an IP address automatically, select “Obtain an IP address automatically” and “Obtain DNS server address automatically” in the screen above. For Windows 98 OS or earlier, the PC and router may need to be restarted.
0
 
MiftaulCommented:
You can ping in Application -> utilities -> network utilities.

Could you please set the default gateway to 192.168.0.1 and see (I know its unnecessary to set a default gateway for devices in the same subnet)
0
 
Zephyr ICTCloud ArchitectCommented:
Well ... You configured the fixed IP on the ethernet device on your mac with a fixed IP, you probably also used the router as gateway, normally this is no issue, but sometimes this can be ... So what you can do to test, is just leave the ip and the subnetmask and remove the gateway ...

To ping on a mac, just open a terminal, app launcher, search Terminal, and type "ping 192.168.0.1"

Also type "ipconfig getifaddr en1" to get the ip config ... if en1 doesn't show IP config use en0 maybe ...
0
 
MiftaulCommented:
westone,

the setup guide for your exact device on the tp-link official website advises to setup the IP address manually. Link here

Please see page 10.
0
 
westoneAuthor Commented:
miftaul, look exactly on page 10 and see the quote I pasted above. TCP/IP CAN BE CONFIGURED for DHCP ON THE TP-LINK TL-R470T. [Edited by SouthMod]
0
 
westoneAuthor Commented:
spravtek,
The device does not respond to a ping. And thanks for that info, I didn't know the ping command was available in Terminal.

I had previously tried manual settings with and without the router IP entered. Same result either way. I will have an opportunity to hook this to another computer (Windows) later this morning, but I am expecting the same result. It looks like it may be bad.

Thanks for the help.
0
 
westoneAuthor Commented:
Thanks for the help!
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 10
  • 4
  • 4
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now