Solved

Apple & TCP/IP

Posted on 2014-01-07
20
459 Views
Last Modified: 2014-01-10
Hi, This morning I am attempting to configure a brand new, just out of the box TP-Link TL-R470T load balance router. I hooked it to my iMac via ethernet and watched the TCP/IP tab in the Advanced Network Preferences window expecting it to pick up 192.168.0.xxx from DHCP in the router. It did not, it just assigns a private address after a minute, presumably due to no DHCP service being available.

The ethernet connection shows as physically connected both in Network Preferences on the iMac and on the LED display on the router, but no addressing is taking place. I used the brand new ethernet cable out of the box with the router.

Doesn't this work the same as with a Windows computer?
0
Comment
Question by:westone
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 4
  • 4
  • +1
20 Comments
 
LVL 19

Expert Comment

by:Miguel Angel Perez Muñoz
ID: 39762033
Probably has DHCP disabled, try resetting to defaults (usually has a button to do this). On Windows must be same.
0
 
LVL 25

Accepted Solution

by:
Zephyr ICT earned 500 total points
ID: 39762044
You need to configure a fixed IP-address in the same subnet e.g: 192.168.0.2 with 255.255.255.0 as subnetmask. Then connect to your router and configure it.
0
 

Author Comment

by:westone
ID: 39762046
I have tried the reset several times, pressing it briefly, pressing it for at least 30 seconds, and pressing it while the router powered up. DHCP is still not handing out any numbers.
0
Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

 

Author Comment

by:westone
ID: 39762050
I have also tried manually configuring the IP settings, conforming to the IP scheme given in the setup guide. It won't surf to the default IP address of the router given in the setup guide.
0
 

Author Comment

by:westone
ID: 39762053
Maybe it is a rare case of dead on arrival.
0
 
LVL 11

Expert Comment

by:Miftaul
ID: 39762056
Network devices in its factory default are not configured as DHCP server. I havent worked on this particular device TP-Link TL-R470T load balance router.

In most cases, you need to set a static address to your workstation in the same subnet the device interface is on (its found on the documentation that comes with the device). You Telnet or logon to the device in GUI and configure it to work however you want.

169.254.x.x addresses are assigned to a device when the device is configured to obtain IP address automatically but it doesn't find any DHCP server, particularly in windows machines. The link LEDs are up because the Layer2 connectivity is established, but we need Layer3  reachablity to configure the device.
0
 
LVL 25

Expert Comment

by:Zephyr ICT
ID: 39762064
Are you also connected to another network through WiFi by any chance? If yes, try disconnecting from that network and try connecting to the router again with the fixed IP address  ...
0
 

Author Comment

by:westone
ID: 39762066
Miftaul, I have rarely, if ever, worked with an off the shelf consumer grade router that did not have DHCP turned on by default. The setup guide specifically states to have TCP/IP configured to obtain addresses automatically. If you read my previous posts you will see that I am unsuccessful at manually configuring TCP/IP and browsing the GUI. This is not a business class router. There is no telnetting into this thing.
0
 

Author Comment

by:westone
ID: 39762068
spravtek, I disconnected from my WLAN and had no other network connections active when attempting to connect to the router. Thanks for the suggestion, though.
0
 
LVL 25

Expert Comment

by:Zephyr ICT
ID: 39762075
You haven't configured a gateway have you? ... Just checking...

So, even with the fixed ip and connected through wire with the router you are unable to ping said router?
0
 
LVL 11

Expert Comment

by:Miftaul
ID: 39762099
westone. There are many consumer grade devices that doesn't come up with DHCP pre-configured, say SonicWALL TZ/NSA.

Like this very TL-R470T+, it doesn't have DHCP configured in its factory default. You need to set an IP in subnet 192.168.0.0/24 to the workstation to have Layer3 reachablity with the TL-R470T+. The device itself is at 192.168.0.1 by default.
0
 

Author Comment

by:westone
ID: 39762101
No, I haven't configured this iMac as a GW. However, when setting manual IP settings it does allow for the router address, which I did configure according to the address in the setup guide. I don't think that is what you meant though.

I only tried to surf to the default router IP: http://192.168.0.1

I don't know how to ping in OS X. If you can tell me I'd like to know. It would be handy.
0
 

Author Comment

by:westone
ID: 39762110
@ Miftaul: For your benefit, this directly from the setup guide:
 
You can configure the PC to get an IP address automatically, select “Obtain an IP address automatically” and “Obtain DNS server address automatically” in the screen above. For Windows 98 OS or earlier, the PC and router may need to be restarted.
0
 
LVL 11

Expert Comment

by:Miftaul
ID: 39762112
You can ping in Application -> utilities -> network utilities.

Could you please set the default gateway to 192.168.0.1 and see (I know its unnecessary to set a default gateway for devices in the same subnet)
0
 
LVL 25

Expert Comment

by:Zephyr ICT
ID: 39762115
Well ... You configured the fixed IP on the ethernet device on your mac with a fixed IP, you probably also used the router as gateway, normally this is no issue, but sometimes this can be ... So what you can do to test, is just leave the ip and the subnetmask and remove the gateway ...

To ping on a mac, just open a terminal, app launcher, search Terminal, and type "ping 192.168.0.1"

Also type "ipconfig getifaddr en1" to get the ip config ... if en1 doesn't show IP config use en0 maybe ...
0
 
LVL 11

Expert Comment

by:Miftaul
ID: 39762129
westone,

the setup guide for your exact device on the tp-link official website advises to setup the IP address manually. Link here

Please see page 10.
0
 

Author Comment

by:westone
ID: 39762150
miftaul, look exactly on page 10 and see the quote I pasted above. TCP/IP CAN BE CONFIGURED for DHCP ON THE TP-LINK TL-R470T. [Edited by SouthMod]
0
 

Author Comment

by:westone
ID: 39762189
spravtek,
The device does not respond to a ping. And thanks for that info, I didn't know the ping command was available in Terminal.

I had previously tried manual settings with and without the router IP entered. Same result either way. I will have an opportunity to hook this to another computer (Windows) later this morning, but I am expecting the same result. It looks like it may be bad.

Thanks for the help.
0
 

Author Closing Comment

by:westone
ID: 39763388
Thanks for the help!
0

Featured Post

Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

626 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question