Solved

Internet Published Calendars Requiring OWA Logins??

Posted on 2014-01-07
2
436 Views
Last Modified: 2014-01-07
I'm running Exchange 2010 SP1.  I have internet publishing for calendars setup and the ability to "publish calendar" is available to the users with the appropriate sharing policy.

I have published calendars with both Public and Restricted access levels.  On both sets, I sent the internet share links to myself and have tried to access them from outside the corporate network.  When attempting to use any of the links (either HTML web view or ICS subscription) for either of the calendars (Public with its readable URL or Restricted with the obscure URL) I am taken to the OWA login form.  

The login form URL does show the redirect target of the calendar page, but that completely obliterates the desire to be able to publicly share these calendars.  We want anonymous internet users to be able to open an ICS file and subscribe to our calendar.

How can I get the published calendars to just open without first dropping the internet user into our Exchange server's OWA login page?
0
Comment
Question by:AcmeWidget
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
2 Comments
 

Author Comment

by:AcmeWidget
ID: 39763082
I forgot to mention, the /owa/Calendar virtual directory has Anonymous authentication enabled and all other authentication types (including Forms) disabled.
0
 

Accepted Solution

by:
AcmeWidget earned 0 total points
ID: 39763138
The URL generated by Exchange started with http:// and our system is set to redirect all non-SSL traffic to the https:// site.  This was causing the redirect to the login form at https://owaserver

Manually altering my link's URL to https://owaserver/owa/Calendar/xxxxxx (added the SSL "s") solved the problem and allowed me to open the ICS file without authentication.

If you are encountering the same issue, check your URL and try hand crafting it to use HTTPS.
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
Phishing attempts can come in all forms, shapes and sizes. No matter how familiar you think you are with them, always remember to take extra precaution when opening an email with attachments or links.
how to add IIS SMTP to handle application/Scanner relays into office 365.
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…
Suggested Courses

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question