Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Paragraph formatting of Outlook email created from VBA

Posted on 2014-01-07
3
Medium Priority
?
1,218 Views
Last Modified: 2014-01-10
I am currently generating an email from a macro in excel to send to customers.  The problem I am having is that it is double-spacing all the paragraphs when I press enter.  I noticed that if I go into format text / paragraph / spacing for the email and check the box for "don't add space between paragraphs of the same style" pressing enter only single spaces my lines.  How can I get that box checked from vba when creating the email?  I have searched and searched and have not found anything that seems to address my issue.

Here is the .HTMLBody statement I'm using with its attributes:
.HTMLBody = "<p style='font-family:courier new;font-size:14'>" & hlink & "</p>"

Thanks.
0
Comment
Question by:Matt Johnson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 53

Expert Comment

by:Rgonzo1971
ID: 39764408
HI,

YOu could click

Don’t add space between paragraphs of the same style

and then Set As Default

HTML
Regards
0
 

Author Comment

by:Matt Johnson
ID: 39765188
I have multiple users on this tool, so I'd like to control it from my vba code.  If you are saying that isn't possible I can try settting defaults.  However, when I go to set the default as shown above, it isn't staying checked for subsequent emails.  I checked the box referenced above, clicked "set as default", and checked the option on the popup window to set this default for "all documents based on the NormalEmail template.".  If I click ok and then bring up a new email the paragraph spacing box is unchecked again.  I had our it administrator try it also and it did the same thing for him so it doesn't seem to be a permission or security issue.
0
 
LVL 53

Accepted Solution

by:
Rgonzo1971 earned 2000 total points
ID: 39765796
Hi,

You could use Shift-Enter instead of Enter so it on't double the spacing

Regards
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
In this article I discuss my selections of the Top Four free Outlook OST File Viewers available. Open, view and read even damaged OST files by using these tools. They all provide a clear preview of all data such as emails, notes, tasks, calendars, e…
The viewer will receive an overview of the basics of CSS showing inline styles. In the head tags set up your style tags: (CODE) Reference the nav tag and set your properties.: (CODE) Set the reference for the UL element and styles for it to ensu…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
Suggested Courses

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question