Odd issues resolving websites after basic Sonicwall installation.

Hello,

My problem is that I have purchased a TZ210 for the home to setup a small business. I have Verizon DSL and I was successful in getting them configured so that I had internet. However when I tried to go to ANY other website other than Google.com and Gmail, it would time out. I checked the sonicwall and it was inheriting the DNS IP's from Verizon just like the modem/router would. I then tried changing these to Google's DNS IP's of 8.8.8.8 and 8.8.4.4, This didn't resolve either and I received the same results. I am come to my wits end as well as a couple of my buddies so right the Soniwall is out and the Verizon DSL is reset. I did reassign IP's for them giving the Verizon box 10.0.1.1 with DHCP turned off and the Sonicwall 10.0.1.254. with DHCP on. I have some experience with Sonicwalls but this is the first time I am seeing this.

Thank you for your help.
Kevin PortellPollack, Pollack, Isaac & De CiccoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PerarduaadastraCommented:
Why does the Verizon box need a LAN IP? I would have thought that it would have been connected to the Sonicwall's WAN port. The Sonicwall would then perform all the necessary network functions for your LAN.
Kevin PortellPollack, Pollack, Isaac & De CiccoAuthor Commented:
My apologies. I turned that off and and turned on bridge mode. The problem ensued.
PerarduaadastraCommented:
The Sonicwall is in bridge mode? Then it can't route...

I suggest restoring the Sonicwall to its normal default configuration and connecting the modem to the WAN port in the normal way, and use the setup guide provided by Sonicwall. Then you can track down the misconfiguration that causing the grief. In fact, resetting the router to factory defaults might clear the error entirely, and allow you to configure it correctly this time around.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

Kevin PortellPollack, Pollack, Isaac & De CiccoAuthor Commented:
No, The modem/router that Verizon gives you is in bridge mode. Not the Sonicwall. That would be silly. I tried using the wizard however nothing worked.

Re-writen:

My problem is that I have purchased a TZ210 for the home to setup a small business. I have Verizon DSL and I was successful in getting them configured so that I had an intentet connection. However when I tried to go to ANY other website other than Google.com and Gmail, it would time out. I checked the sonicwall and it was inheriting the DNS IP's from Verizon just like the modem/router would. I then tried changing these to Google's DNS IP's of 8.8.8.8 and 8.8.4.4, This didn't resolve either and I received the same results. I have come to my wits end as well as a couple of my buddies.  So,  right the Soniwall is out and the Verizon DSL is reset.The Sonicwall has DHCP on and the modem/router is in bridge mode when the sonicwall is connected. I have some experience with Sonicwalls but this is the first time I am seeing this.
PerarduaadastraCommented:
I thought it was silly too, but I was too polite to say so...

Right, so you have successfully connected the modem to the router. From a computer on the LAN, can you ping 4.2.2.2 successfully? If so, try pinging bbc.co.uk
If that works then DNS is working; however, I suspect that it won't.

In the DNS settings for your ISP on the Sonicwall, reverse the primary and secondary server entries so that the secondary ISP DNS server becomes the first one that the Sonicwall uses; the secondary servers aren't as busy as the primary ones, and every little helps.

From the same computer, open a command prompt and type: ipconfig /all

The gateway and DNS server addresses should be that of the Sonicwall ; if they aren't, change them to that address in the DHCP server configuration page and save the changes. Then release and renew the IP address on each client computer and see if they can access the internet normally.

One other thing to consider: Does Verizon have any particular requirements in regard to devices connected to its network? I ask because here in the UK there is (or was) at least one provider that uses the MAC address of the first device after the modem to identify the connection - this meant that changing the router caused limited or no connectivity until the system caught up with the change.
Jeremy WeisingerSenior Network Consultant / EngineerCommented:
I would run nslookup and verify the sites you're trying to go to are resolved correctly on the client.

If they are then run a tracert on it. See if and where it drops.

If DNS doesn't resolve, check to see where the client is querying. Is it using the SonicWall? Is it using an external DNS server?

If it's the latter then the SonicWall might be blocking DNS outbound.
Kevin PortellPollack, Pollack, Isaac & De CiccoAuthor Commented:
Ok, so I can ping 4.2.2.2 and it resolves. I am currently using Googles free public DNS server (8.8.8.8) and everything is pings me however anything via port 80 seems to be blocked. Any features you know that would do this? Also, the nslookup resolves. I have even tried setting the WAN access rules to "Allow all" but same results.
Blue Street TechLast KnightCommented:
Hi LBSOverlord,

First off make sure you change WAN > {Anything} from Allow to Deny or Discard.

Let's step back a second here and do a direct-connect test. Connect your computer straight to the modem. Is the problem still there?

Then factory reset the SonicWALL by pressing the button on the back for 10-20 seconds with the power on until the wrench light starts blinking. Setup your computer to 192.168.168.168 and login and run the setup wizard if it doesn't pop-up. Make sure to select DSL and authenticate on the SonicWALL. This should resolve any config anomalies.

You may have to change your MTU settings to the appropriate value. Read this to set them correctly: http://www.experts-exchange.com/A_12615.html

Lastly, I'd allow the DNS to propagate from your ISP, rather than using google's because your ISP's DNS servers should be faster since they're in network.

Let  me know how it goes!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Kevin PortellPollack, Pollack, Isaac & De CiccoAuthor Commented:
So, it seems that with PPoE connections (Which Verizon uses) you have to change the Interface MTU to  1492. A bit odd however after doing this for an hour with Sonic wall support (I totally forgot I had) everything worked just fine. However I have noticed that I am getting dropped occasionally for 20 seconds. I have a continuous ping up that I monitor while I am at my desk and I notice that "Requests timed out". I recorded the time between the intuitions and that is how I came to 20 seconds. This happens once about every 2 to 5 minutes. But that is another question for another day. I am just happy to have my Sonicwall working.

Thank you everyone for your help

diverseit, I totally missed your assistance and the link to the MTU information before posting. Thank you!
Blue Street TechLast KnightCommented:
I'm glad you got it all straightened out. Thanks for the points!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.