Link to home
Start Free TrialLog in
Avatar of ozzalot
ozzalotFlag for United States of America

asked on

Server 2008 DHCP does not hand out IP address to wireless divices

Hello,

At one time we running RADIUS on our 2003 DC/DNS/DCHP server and everything worked fine.  We also have a few wireless access points that connect via WPA\TKIP and a password for guests.  Our network is one big network running on the same subnet.

When we upgraded to Server 2008(not R2) and used NPS things started acting weird on both type of access points, those using RADIUS and those just using a wireless password.  My workstation laptops connect to the wireless access points using RADIUS and Guests connect wirelessly using just a password.  The problem is if laptop is a new laptop or the laptop has not been here for an extended period of time it doesn't get an IP address on first connection.  I will get a local IP address of 192.168.x.x which we are not on.  I have manually go to the laptop and run ipconfig /release then /renew and it will get an IP address and then the laptop is works on wireless.  

This happens on both types of access points.  I've read where NPS settings needs to be set to give out an IP address via DCHP, but the problem I'm facing that I'm not only getting this problem with access points connecting via Radius, but also those that are just set up with a simple password like in a home wireless access point.  As i said it is all on the same subnet pointed to the same AD/DNS/DHCP server.   I don't understand why this problem is happening.  Laptops are running Windows 7 Pro or Enterprise. Any thoughts?
SOLUTION
Avatar of Perarduaadastra
Perarduaadastra
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of Patrick Bogers
Hi

In NPS how did you configure Radius clients ?

Second, where is the 192.168.x.x coming from? It is not 'thought up' because it is a valid internal IP adress in stead of an APIPA adress which it should return when it doesnt know what IP to give you.
Avatar of tmoore1962
tmoore1962

I would check the configs of the APs sounds like they may have DHCP helpers configured, is the new server's IP the same as the old server's ?  Also check and see if the AP's aren't configured to hand out dhcp from themselves
Are your access points really access points or wireless routers?  
I've seen in plenty of businesses where someone thinks they are clever and use a wireless router as an AP and they forget to turn off DHCP on the router.  

You've definitely got another DHCP server on your network.
Avatar of ozzalot

ASKER

How can I found if there is another DHCP on the network?  I will check the access points, but I don't think they are routers.
If there is a DHCP server active on an adjacent WLAN and it's handing out addresses to anything in range, that suggests that it has no security enabled. Find out who owns that WLAN, and advise them that it would be a really good idea if they enabled WPA-PSK security on it at the very least; that would at least stop it being such a hussy...
Check the DHCP sections in the AP, it will show you.
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
ASKER CERTIFIED SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Oops! It was late, yes, I mean rogue. :) Thanks vivigatt.
Avatar of ozzalot

ASKER

Sorry I haven't responded to your posts.  I've been so busy here at work.  I plan on trying to find that rogue DHCP server today and will report back my results.  Hope you guys had a good weekend.
I've requested that this question be deleted for the following reason:

Not enough information to confirm an answer.
Avatar of ozzalot

ASKER

I'm sorry i didn't reply back.  I got flooded with work. I want to thank all you for your help. you were right there was a wireless switch setup with DHCP.