Solved

Regional Language setting from English (US) to English (Australia) change via GPO Preference

Posted on 2014-01-08
19
1,127 Views
Last Modified: 2014-01-15
Hello there,

I need to change Regional Language setting from English (US) to English (Australia) in Windows 7 Virtual Desktops. I am thinking of doing it via GPO Preference.

Attached are the screenshots of the settings. Please advise will this work?

Please assist.

Thanks and Regards
GPO-PreferenceSetting.JPG
LangSetting.JPG
0
Comment
Question by:goprasad
  • 9
  • 9
19 Comments
 

Author Comment

by:goprasad
ID: 39766731
Anyone please assist.
0
 
LVL 18

Expert Comment

by:Jeremy Weisinger
ID: 39767050
That should work. Have you tested it?
0
 

Author Comment

by:goprasad
ID: 39767076
I just wanted to check am whether I am in right direction/path, OR is there any setting that ensures, it changes the language setting to English (Australia)
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 18

Expert Comment

by:Jeremy Weisinger
ID: 39767086
That setting will change it for all users that apply that policy.
0
 

Author Comment

by:goprasad
ID: 39767095
Thanks for that. Please advise why the location setting is greyed out to United States. Will this affect? Please advise.
0
 
LVL 18

Expert Comment

by:Jeremy Weisinger
ID: 39767122
That can't be changed through preferences because it's a computer setting and not a user setting.
See: http://technet.microsoft.com/en-us/library/cc754020.aspx

You could change it by modifying the registry: http://blogs.technet.com/b/askperf/archive/2012/08/16/how-to-change-regional-settings-for-all-users-on-a-computer.aspx
0
 
LVL 12

Expert Comment

by:Sandeep
ID: 39767447
0
 

Author Comment

by:goprasad
ID: 39778479
Applied the Group Policy preference, its not getting applied, the regional language settings is  still set to Eng (United States)
0
 
LVL 18

Expert Comment

by:Jeremy Weisinger
ID: 39778492
Where are you applying the policy? To an OU? Are there user objects in the OU or sub OU? Can you run a gpresult to see if the policy is getting applied or not?
0
 

Author Comment

by:goprasad
ID: 39781950
Attached are the screenshots on the settings that I have applied and the scope of the policy. I am not sure why the policy is not getting applied.

Please advise.
GPO-Scope.PNG
Preferences-setting.PNG
0
 
LVL 18

Expert Comment

by:Jeremy Weisinger
ID: 39782451
Are the users in the XenDesktop OU? If not then that is why the settings are not being applied, since they are user settings and not computer settings.
0
 

Author Comment

by:goprasad
ID: 39784126
Any authenticated user who logs on to one of the XenDesktop located in XenDesktop OU will get this policy applied.
0
 
LVL 18

Expert Comment

by:Jeremy Weisinger
ID: 39784182
So you are saying that the users are in the OU or is loopback processing configured?
0
 

Author Comment

by:goprasad
ID: 39784221
Users are not in that OU - scope is being set as you can see in the screenshots that I have provided that - Any authenticated user who logs on to one of the XenDesktop located in XenDesktop OU will get this policy applied.

I am not sure why this is not getting applied as I have other User policies in the same GPO that are getting applied no issues.

I am starting to think is there a way that you can change regional language settings via Registry setting using GPO. Please advise.
0
 
LVL 18

Expert Comment

by:Jeremy Weisinger
ID: 39784235
That is not how group policy processing works. The sco
0
 

Author Comment

by:goprasad
ID: 39784239
Can you please elaborate?
0
 
LVL 18

Expert Comment

by:Jeremy Weisinger
ID: 39784264
Yes, sorry, was responding from my phone and accidentally hit submit.

So the scope is the OU and the security filtering is the Authenticated users. So if you want to limit the scope, you can use security filtering to do that. (you can also use WMI filtering but that isn't relevant here)

You can have the User Configuration apply to users based on the policies that computer applies if you configure Loopback processing in the Computer Configuration

More info:
Group Policy Processing - http://technet.microsoft.com/en-us/library/cc785665(v=ws.10).aspx
Security Filtering - http://technet.microsoft.com/en-us/library/cc781988(v=ws.10).aspx
Loopback Processing - http://blogs.technet.com/b/askds/archive/2013/02/08/circle-back-to-loopback.aspx
0
 

Author Comment

by:goprasad
ID: 39784278
I am Citrix admin, Sorry I am not an GPO expert, what is the way out to ensure that this gets applied. My AD admin is saying that the scope is correctly defined as illustrated in screenshot.

He is now asking if I have any registry setting for this change. Please advise.
0
 
LVL 18

Accepted Solution

by:
Jeremy Weisinger earned 500 total points
ID: 39784311
If you want that setting to apply to the users only when they log on to the XenDesktop then you'll have to use loopback processing. If you want it to apply to the users no matter where they log on then the policy should be linked to the OU where the user objects are located in AD.
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
While working, an annoying popup showing below will come and we cannot cancel or close it form the screen. The error message will come again and again.
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question