Solved

Change RD Web Access Server URL

Posted on 2014-01-08
5
11,363 Views
Last Modified: 2014-09-15
I am setting up a remote desktop server in Server 2012 R2.  

Everything is setup ok but my certificate for the server is  a wildcard certificate that covers my outside domain.  *.domain.com

When I connect to the remote apps on the server the remote computer they are hosted on says:  server.domain.local so the cert. doesn't cover this.  

How can edit my RD Web Access Server URL to be server.domain.com.  I have this setup on my internal DNS so if I go to this address from a browser it resolves to the server locally and it works with the certificate.  So I want my configuration on the server to use that url instead of the local url.  

Thanks,
Mathew
0
Comment
Question by:mschirad
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 12

Expert Comment

by:duttcom
ID: 39766839
This cmdlet may be of some assistance -

http://gallery.technet.microsoft.com/Change-published-FQDN-for-2a029b80

A common scenario where the ability to change the published name is useful is when your internal domain is .local, .private, .internal, etc.  For instance, you purchase and install a wildcard certificate (*.yourdomain.com) for use with RDS, but when your users connect they receive a name mismatch error because they are attempting to connect to rdcb.yourdomain.local.  This cmdlet allows you to change the FQDN they will use to a name that will match your certificate (rdcb.yourdomain.com).
0
 

Author Comment

by:mschirad
ID: 39768274
The cmdlet looks like what I need to do but I am getting this error when running it:

Set-RDPublishedName : The term 'Set-RDPublsihedName' is not recognized as the name of a cmdlet...

I'm not sure why it won't recognize it.
0
 

Accepted Solution

by:
mschirad earned 0 total points
ID: 39771511
This is the cmdlet that works:

Set-RDSessionCollectionConfiguration –CollectionName RemoteApps -CustomRdpProperty "use redirection server name:i:1 `n alternate full address:s:server.domain.com"
0
 

Author Closing Comment

by:mschirad
ID: 39781802
After much searching and testing this is the cmd that worked for me
0
 

Expert Comment

by:GMSMRM
ID: 40324215
How do I find my server's collection name? the CMD is failing when entering 'RemoteApps'.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently, I was assigned the task of performing a hardware refresh in the datacenter. The previous Windows 2008 systems were connected to the SAN via fiber channel HBA’s and among other thing, had PowerPath installed in order to provide sufficient f…
The reason that corporations and businesses use Windows servers is because it supports custom modifications to adapt to the business and what it needs. Most individual users won’t need such powerful options. Here I’ll explain how you can enable Wind…
In this Micro Tutorial viewers will learn how to restore their server from Bare Metal Backup image created with Windows Server Backup feature. As an example Windows 2012R2 is used.
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles from a Windows Server 2008 domain controller to a Windows Server 2012 domain controlle…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question