Solved

An element does not appear on webpage, but I see it in design page

Posted on 2014-01-09
17
287 Views
Last Modified: 2014-01-09
In this image below, you'll see that the code for the SiteMapPath is called right after the page header in this master page. But when the page renders as a web page, it is missing this SiteMapPath control. Can you work with me to troubleshoot this?
code and design view
0
Comment
Question by:jeffleese
  • 9
  • 6
  • 2
17 Comments
 
LVL 19

Expert Comment

by:Rikin Shah
Comment Utility
Hi,

Make sure you have cleared all the cache from the browser.
0
 

Author Comment

by:jeffleese
Comment Utility
How to do that? In current IE, internet options > browsing history settings > Caches and Databases I tried turning that off, restarting IE and then on again. It had no effect as I recompiled to see local IE page, and missing control at all times.

If there is something else to do to clear cache, please remind me.
0
 
LVL 19

Expert Comment

by:Rikin Shah
Comment Utility
Hi,

Try Resetting the IE settings, this will do the necessary things. Go to Tools -> Options -> Advanced Tab and Click on Reset button.

I also would like to see that control out of the table/td, without any parent elements to see if it is not being hidden inside the table.

Have you tried <br> tag after div tag completes?
0
 
LVL 29

Expert Comment

by:Paul Jackson
Comment Utility
Have you created a web.sitemap file and placed it in the root of your solution
0
 

Author Comment

by:jeffleese
Comment Utility
Reset did not do it.
Now to focus on isolating. You want to try to put control out of the table.

Not sure if this is correct, but I tried as
<body class="page">
<form id="form1" runat="server" >
    <asp:ScriptManager ID="ScriptManager1" runat="server">
    </asp:ScriptManager>
<div class = "pageheader" >Depth by Distance
</div><br />
     <asp:SiteMapPath ID="SiteMapPath1" runat="server" CssClass="path">
            </asp:SiteMapPath>
<table width="100%" >

Open in new window


But still nothing. Was this the step you wanted?
0
 

Author Comment

by:jeffleese
Comment Utility
Paul,

I did not have a web.sitemap file in the solution root.

I used a file called desktop.sitemap file in a folder called desktop, which is used for making the tree on this masterpage.  

As a way to test your suggestion, I copied it and placed it at the root of the solution, renaming it web.sitemap. It contains an xml sitemap file with the sitmapnodes of the site.

But having it there had no effect.

Incidentally, this used to work before, but I've no idea what's preventing it working now.
0
 
LVL 19

Expert Comment

by:Rikin Shah
Comment Utility
Hi,

Yes. This is what I wanted to be.

Please confirm if you have all the files available in the directory to the links mentioned in the sitemap file. If the files are not available then the control will not show anything on it.
0
 
LVL 29

Expert Comment

by:Paul Jackson
Comment Utility
Ensure that the page you are trying to show the control on is listed in the web.sitemap file. The sitemap control will not be shown on pages that are not listed in the web.sitemap file.
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Author Comment

by:jeffleese
Comment Utility
Rikin, I checked all the sitemapnodes, and each points to a file I confirmed exists.

I checked that the default start page is listed in this sitemap file.

Thank you for trying and your good troubleshooting ideas.
0
 

Author Comment

by:jeffleese
Comment Utility
I furthered the isolation with:
         test<asp:SiteMapPath ID="SiteMapPath1" runat="server" CssClass="path" >

Open in new window


This showed the test text. Then I removed the CssClass="path" and then the path appeared.

So, something is wrong with the linking to the CssClass path info.

As I show in the top image, I am calling the css file as
    <link runat="server" href="./App_Themes/rosy/screen.css" media="screen" rel="Stylesheet" />

Open in new window


In that file, I have the .path style ok.


In web.config I use     <pages theme="rosy" /> which I think is for accessing the App_themes \ rosy folder where the stylesheets are.

When I comment out that line, then I get the SiteMapPath control, but I loose the web styles. I'm not sure where to isolate the problem yet, but it has something to do with the theming I think.
0
 
LVL 19

Expert Comment

by:Rikin Shah
Comment Utility
Hi,

What is there in the Path class?
0
 

Author Comment

by:jeffleese
Comment Utility
.path
    {
        font-family: Arial, Helvetica, sans-serif;
        font-size: small;
        color: #7467AD;
        background-color: Transparent;

    }

Open in new window

0
 
LVL 19

Expert Comment

by:Rikin Shah
Comment Utility
Hi,

I don't see any issues in this. Can you check assigning the same class to some other control and check in IE debug mode if the element does not get any inherited properties and text goes hidden/transparent.
0
 

Author Comment

by:jeffleese
Comment Utility
<td style="width: 66%; " >
         test<asp:SiteMapPath ID="SiteMapPath1" runat="server" CssClass="path" >
            </asp:SiteMapPath>

            <asp:Label ID="Label1" runat="server" Text="test2" CssClass="path"></asp:Label>
        </td>

Open in new window


With this other control, the CssClass="path" also makes the label go hidden, and the label appears if I remove it.
Here's what I see in IE in developer mode. Is that what you wanted to see?

developer mode
0
 
LVL 19

Accepted Solution

by:
Rikin Shah earned 500 total points
Comment Utility
Hi,

Check this and see if there are multiple classes on that control?
http://msdn.microsoft.com/en-us/library/dd565627(v=vs.85).aspx
0
 

Author Comment

by:jeffleese
Comment Utility
Rikin,
I'm going to accept this as full answer, because you assisted me to troubleshoot and clarify the scope of the problem. We did not solve it, and I am going to pursue the next step with an MSDN support staff if possible. You can see my summary of the problem at css hides control
0
 

Author Closing Comment

by:jeffleese
Comment Utility
Not a solution, but suitable as concluding the exercise of troubleshooting.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

This article describes relatively difficult and non-obvious issues that are likely to arise when creating COM class in Visual Studio and deploying it by professional MSI-authoring tools. It is assumed that the reader is already familiar with the cla…
Problem Hi all,    While many today have fast Internet connection, there are many still who do not, or are connecting through devices with a slower connect, so light web pages and fast load times are still popular.    If your ASP.NET page …
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now