Solved

Setting Permission

Posted on 2014-01-09
12
125 Views
Last Modified: 2014-02-11
I have a SHARE folder on SBS2011 where the group name "STAFF" has FULL ACCESS. The "STAFF" includes most domain users. The SHARE folder has many sub-folders. Today one of the users asked me if I can set the permissions on a specific sub-folder (under SHARE) so that some users would have FULL access where some has READ only access.
However all the users belong to the group "STAFF".
To be specific, say there are User1, User2, User3 and User4 that are members of the group "STAFF". The STAFF group has full access to D:\SHARE and its sub-folders. Now I need to set the permission on D:\SHARE\SubDir1\SubDir2\...\VacationLog folder so that User1 and User2 have Full Access whereas User3 and User4 have Read-Only access.
Yesterday I attempted, but was not successful.
Can you help?
0
Comment
Question by:sglee
  • 5
  • 4
  • 3
12 Comments
 
LVL 57

Accepted Solution

by:
Mike Kline earned 167 total points
ID: 39767908
Create a group called Read Access and place User 3 and User 4 in that group.   Apply Read access to SubDIR1

Although User3 and 4 are in both groups the most restrictive permissions win so they will only have read and those only in staff will still have full.

User 3 and 4 will have to log off and log back in after you add them to the new group.


Thanks

Mike
0
 

Author Comment

by:sglee
ID: 39767924
@mkline71,
I will try that and post the result.
0
 
LVL 142

Assisted Solution

by:Guy Hengel [angelIII / a3]
Guy Hengel [angelIII / a3] earned 333 total points
ID: 39767925
put user3 and user4 into a new group.
in the VacationLog folder, set that group to have a "Deny Write" permission.

note that the user3/4 may need to log in again in order that they get that new group membershop permissions ...
0
 

Author Comment

by:sglee
ID: 39767959
ReadUserGroup@Mike,
 
 After creating a new group "VacationReadUsers", I added the new group to Vacation folder with read/list permissions only, but I was able to change the contents of EXCEL file and save it.

  I will try "DENY" option as Guy Hengel suggested.
0
 
LVL 57

Expert Comment

by:Mike Kline
ID: 39767996
Guy is right, sorry  I was thinking of share and NTFS permissions for most restrictive.  These are all NTFS.

THanks

Mike
0
 

Author Comment

by:sglee
ID: 39768004
Permission PropertiesAfter adding "Write Deny" as Guy Hengel suggested, it worked.

Now I did not think of this: The group "STAFF" currently pretty much includes every domain users and not everyone should be able to make changes to the files in this folder.
If I want to allow only handful/selected users to have WRITE permission on this folder, what is the best way to accomplish that given the fact that STAFF group includes everyone pretty much and that group currently has full permission on VACATION folder.
0
 
LVL 57

Expert Comment

by:Mike Kline
ID: 39768014
On that particular folder you could make Staff only have read and then create a write group and give them write permissions.

Thanks

Mike
0
 
LVL 142

Assisted Solution

by:Guy Hengel [angelIII / a3]
Guy Hengel [angelIII / a3] earned 333 total points
ID: 39768019
then you do this:
* create a new group VACATION_LOG, and grant read+write on that folder to that group
* add user1 and user2 to that group
* specify for the STAFF folder thant WRITE permissions are removed, and not inherited

the risk is that if at some point someone is reapplying the permissions from root folder to subfolders, this may get lost
0
 

Author Comment

by:sglee
ID: 39768093
Security WarningAfter creating a new group "VacationWriteUsers" giving FULL Permission to User 1 and User2, I wanted to take out WRITE permission from STAFF folder.
So I went to "Advanced" and chose "Change Permission" for STAFF and when I uncheck the checkbox for "Include inheritable permission from this object's parent", I get this warning.
0
 
LVL 142

Expert Comment

by:Guy Hengel [angelIII / a3]
ID: 39768105
this is exactly what you want to achieve: this folder will NOT inherit any permissions you set at a higher level
0
 
LVL 57

Expert Comment

by:Mike Kline
ID: 39768107
Click add on that dialogue box, then you can go in and change the staff permission.

Thanks

Mike
0
 

Author Comment

by:sglee
ID: 39768146
After "unchecking" the checkbox, now I am free to set permission level to STAFF group.
I removed Full Control/Modify/Write permissions.

Thank you for your help.
0

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Alternative access for remote users 6 41
Folder size tool 6 61
Expand C partition 13 20
shadow copy on 2012 OS server 3 5
Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Find out how to use Active Directory data for email signature management in Microsoft Exchange and Office 365.
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now