Solved

event viewer error

Posted on 2014-01-09
9
627 Views
Last Modified: 2014-01-09
I am getting this error in the event viewer, can someone decode this for me?


General Information
*********************************************
Additional Info:
ExceptionManager.MachineName: SUNISYS01
ExceptionManager.TimeStamp: 1/9/2014 11:44:01 AM
ExceptionManager.FullName: Microsoft.ApplicationBlocks.ExceptionManagement, Version=1.0.3594.394, Culture=neutral, PublicKeyToken=null
ExceptionManager.AppDomainName: /LM/W3SVC/1/Root/NOVAtime-1-130337560023856378
ExceptionManager.ThreadIdentity:
ExceptionManager.WindowsIdentity: NT AUTHORITY\SYSTEM

1) Exception Information
*********************************************
Exception Type: System.NullReferenceException
Message: Object reference not set to an instance of an object.
Data: System.Collections.ListDictionaryInternal
TargetSite: Int16 a(System.Data.DataTable, System.String)
HelpLink: NULL
Source: nova3000_WebControls

StackTrace Information
*********************************************
   at nova3000_WebControls.combo.PayPeriod.a(DataTable A_0, String A_1)
   at nova3000_WebControls.combo.PayPeriod.a(TableCell A_0, String A_1, Boolean A_2)
   at nova3000_WebControls.combo.PayPeriod.CreateCombo(Boolean resetRefDate, Boolean activeOnly)
   at TimeAnywhere.attendance_summary.g()
   at TimeAnywhere.attendance_summary.h(Object A_0, EventArgs A_1)
0
Comment
Question by:TomBalla
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 23

Expert Comment

by:Patrick Bogers
ID: 39768815
Hi

Could you please post the event ID and application mentioned in the event log?
0
 

Author Comment

by:TomBalla
ID: 39768845
The event id is 0 and the application novatime 3000.
0
 

Author Comment

by:TomBalla
ID: 39768850
The source is ExceptionManagerPublishedException.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 23

Expert Comment

by:Patrick Bogers
ID: 39768885
Ahh i must have been blind...

Object reference not set to an instance of an object
.  this often means the webservice is expecting some data he cannot find.

If you can you should edit the web.config and add tight under <system.web>

<customErrors mode="Off"/>

Then open the page again to see what the more detailed error tells you.
0
 

Author Comment

by:TomBalla
ID: 39768951
Do I go IIS to get to web.config and system.web?
0
 
LVL 23

Expert Comment

by:Patrick Bogers
ID: 39768965
No, go into IIS -> find the website similair to NOVAtime.

Select it and click basic settings. This displays where the files are stored on harddisk.
Browse to this location and edit the web.config there (make a backup web.config first)

In the web.config you find an entry called  <system.web>
Right below it you enter    <customErrors mode="Off"/>     and save the file.

Now browse the website.
0
 

Author Comment

by:TomBalla
ID: 39768996
It says customerrors is off.

<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="MicrosoftWebControls" type="System.Configuration.NameValueSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    <section name="infragistics.web" type="System.Configuration.SingleTagSectionHandler, System, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
      <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
        <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
        <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
          <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere" />
          <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
          <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
          <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
        </sectionGroup>
      </sectionGroup>
    </sectionGroup>
  </configSections>
  <MicrosoftWebControls>
    <add key="CommonFiles" value="/NOVAtime/webctrl_client/1_0/" />
  </MicrosoftWebControls>
  <infragistics.web imageDirectory="~/Infragistics/images" javaScriptDirectory="~/Infragistics/scripts" />
  <system.web>
    <customErrors mode="Off" defaultRedirect="mycustompage.htm" />
    <authentication mode="Forms" />
    <compilation defaultLanguage="vb" debug="true">
      <assemblies>
        <add assembly="Infragistics2.WebUI.UltraWebChart.v6.3, Version=6.3.20063.53, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB" />
        <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
        <add assembly="Infragistics2.WebUI.Shared.v6.3, Version=6.3.20063.53, Culture=neutral, PublicKeyToken=7DD5C3163F2CD0CB" />
        <add assembly="System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
        <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
        <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
        <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
      </assemblies>
    </compilation>
    <authorization>
      <allow users="*" />
    </authorization>
    <httpRuntime executionTimeout="1200" maxRequestLength="4096" useFullyQualifiedRedirectUrl="false" minFreeThreads="8" minLocalRequestFreeThreads="4" appRequestQueueLimit="100" enableVersionHeader="true" />
    <sessionState timeout="30">
    </sessionState>
    <xhtmlConformance mode="Legacy" />
    <pages>
      <controls>
        <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
        <add tagPrefix="asp" namespace="System.Web.UI.WebControls" assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
      </controls>
    </pages>
    <httpHandlers>
      <remove verb="*" path="*.asmx" />
      <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
      <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
      <add verb="GET,HEAD" path="ScriptResource.axd" validate="false" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    </httpHandlers>
    <httpModules>
      <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    </httpModules>
    <!-- THIS IS THE BACKUP HARDCODE .NET MACHINE KEY, IS FOR APPLICATION TO LOAD BALANCING WITH SESSION STATE SERVER
     <machineKey
      validationKey="D5FFBEAB13263B41C278FFC3B5027E7537484A25107FA50F431FA0E9052161D032E3EDE4B96BF8F1B358508DAD0B33049FF244B6CE84A0D54672F87B4899A324"
      decryptionKey="C4CDC14893EC96280D281C5757D64F7FDC8C3B6195EDF4D6"
      validation="SHA1"/>
    -->
    <machineKey validationKey="D5FFBEAB13263B41C278FFC3B5027E7537484A25107FA50F431FA0E9052161D032E3EDE4B96BF8F1B358508DAD0B33049FF244B6CE84A0D54672F87B4899A324" decryptionKey="C4CDC14893EC96280D281C5757D64F7FDC8C3B6195EDF4D6" validation="SHA1" />
  </system.web>
  <appSettings>
    <add key="Identity" value="WEB SERVER" />
    <add key="DBC" value="1" />
    <add key="APP_SERVER" value="127.0.0.1" />
    <add key="TCP_PORT" value="" />
    <add key="DBE" value="SQL" />
    <add key="ORACLE_conString" value="" />
    <add key="USE_APP" value="0" />
    <add key="APP_PORT" value="8085" />
    <add key="USE_RPT" value="0" />
    <add key="RPT_PORT" value="8186" />
    <add key="RPT_SERVER" value="127.0.0.1" />
    <add key="SQL_conString" value="SERVER=SUNISBS01;DATABASE=NOVA3000_DEMO;UID=nti_cs;MAX POOL SIZE=100;" />
    <add key="PWD" value="g/bihC5tbfw=" />
    <add key="MaxMem" value="1599" />
    <add key="MessageWindowTimeOut" value="20000" />
    <add key="MACKey" value="ecf717da-3921-4ac1-b9f3-fe74f1289813" />
    <add key="ExtDB" value="SQL" />
    <add key="Ext_conString" value="" />
    <add key="ExtPD" value="" />
    <add key="RIATimeOut" value="60000" />
    <add key="RIARetryCount" value="3" />
    <add key="GraceTimeInMins" value="10" />
    <add key="USE_CALC" value="0" />
    <add key="CALC_PORT" value="8085" />
    <add key="CALC_SERVER" value="127.0.0.1" />
    <add key="CALCSERVER#" value="0" />
  </appSettings>
  <system.codedom>
    <compilers>
      <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" type="Microsoft.VisualBasic.VBCodeProvider, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" warningLevel="4">
        <providerOption name="CompilerVersion" value="v3.5" />
        <providerOption name="OptionInfer" value="true" />
        <providerOption name="WarnAsError" value="false" />
      </compiler>
    </compilers>
  </system.codedom>
  <system.webServer>
    <validation validateIntegratedModeConfiguration="false" />
    <modules>
      <remove name="ScriptModule" />
      <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    </modules>
    <handlers>
      <remove name="WebServiceHandlerFactory-Integrated" />
      <remove name="ScriptHandlerFactory" />
      <remove name="ScriptHandlerFactoryAppServices" />
      <remove name="ScriptResource" />
      <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
      <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
      <add name="ScriptResource" verb="GET,HEAD" path="ScriptResource.axd" preCondition="integratedMode" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    </handlers>
  </system.webServer>
  <runtime>
    <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0" />
      </dependentAssembly>
      <dependentAssembly>
        <assemblyIdentity name="System.Web.Extensions.Design" publicKeyToken="31bf3856ad364e35" />
        <bindingRedirect oldVersion="1.0.0.0-1.1.0.0" newVersion="3.5.0.0" />
      </dependentAssembly>
    </assemblyBinding>
  </runtime>
  <system.serviceModel>
    <bindings>
      <wsHttpBinding>
        <binding name="WSHttpBinding_IRegService" closeTimeout="00:01:00" openTimeout="00:01:00" receiveTimeout="00:10:00" sendTimeout="00:01:00" bypassProxyOnLocal="false" transactionFlow="false" hostNameComparisonMode="StrongWildcard" maxBufferPoolSize="524288" maxReceivedMessageSize="65536" messageEncoding="Text" textEncoding="utf-8" useDefaultWebProxy="true" allowCookies="false">
          <readerQuotas maxDepth="32" maxStringContentLength="8192" maxArrayLength="16384" maxBytesPerRead="4096" maxNameTableCharCount="16384" />
          <reliableSession ordered="true" inactivityTimeout="00:10:00" enabled="false" />
          <security mode="None">
            <transport clientCredentialType="Windows" proxyCredentialType="None" realm="" />
            <message clientCredentialType="Windows" negotiateServiceCredential="true" algorithmSuite="Default" establishSecurityContext="true" />
          </security>
        </binding>
      </wsHttpBinding>
    </bindings>
    <client>
      <endpoint address="http://registration.timeanywhere.net/NovatimeRegServices/Registration.svc" binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_IRegService" contract="RegistrationWS.IRegService" name="WSHttpBinding_IRegService">
        <identity>
          <dns value="localhost" />
        </identity>
      </endpoint>
    </client>
  </system.serviceModel>
</configuration>
0
 
LVL 23

Accepted Solution

by:
Patrick Bogers earned 500 total points
ID: 39769009
I see, please remove the defaultRedirect="mycustompage.htm"  part and try to browse the website. I expect a more detailed error.
0
 

Author Comment

by:TomBalla
ID: 39769046
I believe that got it working.  Thanks.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to leverage one TLS certificate to encrypt Microsoft SQL traffic and Remote Desktop Services, versus creating multiple tickets for the same server.
Learn about cloud computing and its benefits for small business owners.
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question