Windows Server 2012 R2 group permissions

Hello all,

I feel this should be a simple thing, but I cannot seem to figure out what's going on. I have a new instance of W2K12R2 setup, and it seems that having a user in the Administrators group doesn't actually give it Administrative permissions.

For example, in a folder called C:\Program Files\Test, I have just the SYSTEM user and the Administrators group defined with full control. Inheritance is not enabled, and my user account I'm logged on with is in the Administrators group. Despite this, I cannot access anything in Test unless I explicitly give my account Full control on this folder, even though I'm in the Administrators group.

When I click on the folder I will get a message informing me that "You don't currently have permission to access this folder. Click continue to permanently get access to this folder." When I click Continue, I get the access I need. When I look at the security properties, I notice it has added my account directly to the folder.

What am I doing wrong here?

Thanks,
James
JLankfordIT Data AnalystAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MaheshArchitectCommented:
It looks like User access control (UAC) issue since you are trying to access folder in root drive under sensitive folder (program files)

Just Turn off UAC from control panel \ gpedit.msc on 2012 r2 server, reboot and test if you are able to access without prompt.
Specially, disable all admin approval mode and "switch secure desktop" UAC settings from gpedit.msc  

Mahesh
JLankfordIT Data AnalystAuthor Commented:
Thanks for the response Mahesh; however I had already tried that. I even tried the same scenario with the Test folder under the root of the C: drive with the same results. I even created a D: drive, but the test folder there and still get the same results.
MaheshArchitectCommented:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JLankfordIT Data AnalystAuthor Commented:
I apologize for the delay in follow-up - sort of got pulled away from this for several days. I had not seen the article above; that was very good information. I have made the recommended changes per the article. I will see how the server behaves over the next few days before marking this as resolved.

Thanks for the response Mahesh!

James
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.