Solved

Web Site Wont work (HTTP 403)

Posted on 2014-01-09
8
711 Views
Last Modified: 2014-01-15
"This error (HTTP 403 Forbidden) means that Internet Explorer was able to connect to the website, but it does not have permission to view the webpage."

Asp.net 4.0.

I created a new web site and it if giving error above.  It is exactly like another site that works.  I even tried pointing it at the same directory (web.config, files, etc).  Still doesn't work.

The site will serve htm files, but not aspx files.

The only thing I see different is the handler mappings (in the IIS console).  On the site that works, most are enabled.  On the one that doesn't, most are disabled, including *.aspx.  I don't see how to enable them.  Not sure if this is problem or not.

All permissions are the same.  IIS_USER has full read/write access.

Help!  Urgent!
0
Comment
Question by:No1Coder
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
8 Comments
 
LVL 29

Expert Comment

by:Paul Jackson
ID: 39770383
If you are using Internet Information Services 7.0, after installing ASP.NET you might need to enable ASP.NET in the Internet Information Services (IIS) management console. IIS 7.0 introduces a new security lockdown console, which allows an administrator to selectively enable and disable functionality in IIS. When ASP.NET 4.0 is installed on a computer that uses IIS 7.0, the installation script creates a metabase key for that version of ASP.NET. This metabase key allows ASP.NET to appear in the console as a configurable component. A separate key is created for each installed version of ASP.NET, allowing each version to be separately configurable in the console.

To enable the Web service extension for ASP.NET 4.0


1.Click Start, click Control Panel, click System Security, click Administrative Tools, and then click Internet Information Services (IIS) Manager.


2.If you need to connect to a remote IIS Server, right click the Internet Information Services node and click the Connect... option.


3.Type in the computer name for the remote IIS Server and credentials if necessary.


4.Click the Web Service Extensions folder. The security lockdown console appears in the frame on the right.


5.In the Web Service Extensions window, right-click the ASP.NET v4.X.XXXX, and then click Allow.

http://msdn.microsoft.com/en-us/library/aa560277.aspx
0
 

Author Comment

by:No1Coder
ID: 39770747
I am using IIS7 on W2008.  These instruction to not match my system.

I can get into IIS console.  When I expand the sites, there is no Web Service Extension folder.  Also, my sites do not have virtual directories or applications.  

I was able to take an existing site that works (which has handler mappings enabled), and point at my new web site directory.  If I change the bindings, I can make it work.  There is nothing wrong with my site or web.config, it is the site config is IIS that is bad.

I still don't see how to update the handler mappings.  Also don't understand how to enable the web service extensions, and mentioned in this article.  The instructions don't seem to apply to W2008, IIS7.

I tried connecting to the server from a w2012R2 box.  When I connect, I get a strange dialog (attached).  I installed these.  I still don't see the Web Service Extensions folder on w2012R2 console either.  Still doesn't work.
Capture.JPG
0
 
LVL 3

Expert Comment

by:DaveKeyes
ID: 39771024
Check your app pool for your new site.  You need to set the framework to 4.0, normally it defaults to 2.0
0
Salesforce Has Never Been Easier

Improve and reinforce salesforce training & adoption using WalkMe's digital adoption platform. Start saving on costly employee training by creating fast intuitive Walk-Thrus for Salesforce. Claim your Free Account Now

 

Author Comment

by:No1Coder
ID: 39771027
The app pool is set to 4.0 (classic)
0
 

Author Comment

by:No1Coder
ID: 39771030
I am pretty sure it is the handler mapping thing.  How to I enable it?
0
 

Accepted Solution

by:
No1Coder earned 0 total points
ID: 39771378
Was able to fix by enabling  read and script permissions on the isappy-dll.  I don't know what turned this off on my server, but enabling fixed.
0
 

Author Closing Comment

by:No1Coder
ID: 39781794
fixed problem
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Background Information Recently I have fixed file server permission issues for one of my client. The client has 1800 users and one Windows Server 2008 R2 domain joined file server with 12 TB of data, 250+ shared folders and the folder structure i…
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question