Exchange 2010 Room Mailbox Accepting Conflicts

We created a Room Mailbox on Exchange 2010 server.  It is allowing conflicts and it is accepting items tentatively until someone goes in and approves.  How should the settings be updated to automatically process requests and decline conflicts?  Our current settings are:

AutomateProcessing                  : AutoAccept
AllowConflicts                      : False
BookingWindowInDays                 : 180
MaximumDurationInMinutes            : 1440
AllowRecurringMeetings              : True
EnforceSchedulingHorizon            : True
ScheduleOnlyDuringWorkHours         : False
ConflictPercentageAllowed           : 0
MaximumConflictInstances            : 0
ForwardRequestsToDelegates          : False
DeleteAttachments                   : True
DeleteComments                      : True
RemovePrivateProperty               : True
DeleteSubject                       : True
AddOrganizerToSubject               : True
DeleteNonCalendarItems              : True
TentativePendingApproval            : True
EnableResponseDetails               : True
OrganizerInfo                       : True
ResourceDelegates                   : {}
RequestOutOfPolicy                  : {}
AllRequestOutOfPolicy               : True
BookInPolicy                        : {}
AllBookInPolicy                     : True
RequestInPolicy                     : {}
AllRequestInPolicy                  : True
AddAdditionalResponse               : False
AdditionalResponse                  :
RemoveOldMeetingMessages            : True
AddNewRequestsTentatively           : False
ProcessExternalMeetingMessages      : False
RemoveForwardedMeetingNotifications : False
Joe BulleitAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

imkotteesSenior Messaging EngineerCommented:
settings looks good, do you have any delegate for this Room mailbox?
EEhotlineCommented:
From: http://technet.microsoft.com/en-us/library/bb124542%28v=exchg.141%29.aspx

This example allows all users to submit in-policy requests to the room mailbox 5th Floor Conference Room, but the request is still subject to approval by a delegate.

Set-CalendarProcessing -Identity "5th Floor Conference Room" -AutomateProcessing AutoAccept -AllRequestInPolicy $true

You have set your Allrequestinpolicy to True, so it requires the approval by a delegate. Try to change it to False

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
imkotteesSenior Messaging EngineerCommented:
EEhotline, Spot on. Thank you for pointing out.
Joe BulleitAuthor Commented:
The resolution was two-fold.  Setting these:

AllRequestInPolicy                  : False
AllRequestOutOfPolicy               : False

Since a conflicting request is "out of policy".  The only way we found that out was to add a delegate and receive the email notification.

Now the conference room auto-declines conflicting invites; so thank you for your help on that issue.

On our original conference room, it is set up as a user mailbox and when you book it as a resource, a message box appears stating
"(Name of resource) is already booked for the specified time. You must use
another time or find another resource."
so the users know that it is busy, as opposed to allowing them to think the meeting is ok and then receive a "declined" message.

Any ideas how to get this back for a resource?
Joe BulleitAuthor Commented:
After some Google searching, here's the answer to my last question:

You need to do a few extra steps to the room profile so you get the
conflicting notice without sending the email.

1. Open the room profile in Outlook
2. Go to Tools | Options and Calendar Option
3. Click on Resource Scheduling button
4. Check the boxes Automatically accept meeting requests and Automatically decline conflicting meeting requests

this will get your the pop up message of conflicting meeting and keep the
message unsent.


Thanks for your assistance and quick replies.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.