Local network configuration using a cable ISP

Greetings,

I have a small network that I support that is now using a cable provider for internet service and connectivity to the server. This network has been using static IP addresses (192.168.xx.xx) for connectivity but I'm guessing that this will have to change when we going through ComCast (ISP). When I connected a workstation to the MODEM it pulled an IP of 10.xx.xx.xx. While working with one of they're first level support folks I described what needed to be done and the tech said for me to use a static IP on the server of 50.243.xx.xx. How this could work I didn't  understand and proceeded to push the cut-over out until I can feel more confident with the configuration. What I'm interested in hearing back on is your thoughts on network configuration in this type of environment where we have three MODEMS in three different physical locations using an ISP to not only connect to the internet but also connect to a windows server 2008 R2.

Thanks experts.
bjbrownAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ktaczalaCommented:
You should never have a public IP address on your private LAN.
it should be set up as follows:
Internet >> Cable/comcast device >> Router/Firewall >> switch >> internal devices
Public IP  on external port of router/firewall i.e. ISP provided may be either static or dynamic
Private IP on internal port of router/firewall i.e 192.168.0.1
Local LAN private subnet i.e. 192.168.x.2 - 192.168.0.254
Dave BaldwinFixer of ProblemsCommented:
On my old Comcast modem that did not have a router, it did supply the public IP address if I had only one computer connected without a router.  As soon as I connected a router to it, the public IP address changed though.  

My current Comcast modem/router combo returns 10.0.0.1 as the gateway IP address.  The "XFINITY Network" status page shows both an IPV4 and an IPV6 address now.  The "Local IP Network" page shows that I can change the IPV4 Gateway Address (10.0.0.1) if I wanted to.  It doesn't offer that option for the local IPV6 gateway and DHCP.
aindelicatoCommented:
@Dave .. ISPs will generally change the IP address when the MAC address that connects to their modem changes, in the case when you switched from a computer to a router.

Listen to ktaczala.  It is explained perfectly.

Do NOT change your current LAN to match the Comcast IP addressing.

Leave the Comcast router serving 10.x.x.x IPs .. get yourself a firewall or router and configure to use your current IP subnet.  Make the router address .1 or .254 just to make it easy to remember as long as those aren't in use already.  That IP will be the gateway address for your network, you may have to change your DHCP scope settings to assign that gateway to your workstations.

Connect that firewall/router to the same switch that all your workstations and server are connected to.

You'll essentially be running 2 networks..

Private LAN - 192.168.x.x
DMZ - 10.x.x.x

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bjbrownAuthor Commented:
Thank you
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.