Solved

The name cannot be matched to a name in the address list

Posted on 2014-01-09
17
14,891 Views
Last Modified: 2015-10-11
Tearing my hair out with this one.

- Windows Server 2012 (not R2)
- Microsoft Exchange Server 2013
- Outlook 2010

We have two sites, each with their own DC and Exchange Server. Only one of them is used for Outlook Anywhere / remote access

While I'm on a PC outside of the network that is not joined to my company domain, I try and create a new outlook profile and set up my mail account in Outlook 2010. I get the error "The name cannot be matched to a name in the address list" when trying to autodiscover the settings. This is affecting all users.

I've looked at most of the obvious stuff:

 - Exchange Remote Connectivity Analyzer and Microsoft Connectivity Analyzer Tool finds no issues
 - "Hide name from address list" option is unchecked in ECP
 - The Global Address List appears to be fully populated
 - In the "Attribute Editor" section of the user account in Active Directory, the "showInAddressBook" attribute looks correct and lists the default global address list
 - I deleted the entire %LocalAppData%\Microsoft\Outlook folder and deleted all profiles, and cached credentials on the client. I also tried it on several different PCs, none of them worked.

Where things get interesting though, is when I connect to the company VPN.  After connecting to the VPN - everything connects and it works!

Then, after the account has been set up, if I then close Outlook, DISCONNECT from the VPN, and then open Outlook again, it continues to work. In both cases the Global Address List is fully populated with all the users.

This USED to work, about 6 months ago when I set up the servers originally I was able to connect fine. Something changed between then and now.

Any idea what's going on?
0
Comment
Question by:Frosty555
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
17 Comments
 
LVL 4

Expert Comment

by:Krishnamanoj83
ID: 39770514
Hi,

please follow below steps, this will fix the issue but every time you need to select the below option when creating profile.
while creating profile, from more settings tab and under security tab, click on always prompt for credentials, and click on ok and now type the user name and click on check names it will work.

this type of error occurs when there is any trust modifications, check if any recent modifications done from AD side.

Regards,
Krishna
0
 
LVL 31

Author Comment

by:Frosty555
ID: 39792908
Krishnamanoj83,

I don't seem to be able to get to the point where I can go into the Security tab.

I open Outlook, create a new profile, specify the email address and password, hit next, and it fails shortly after the autodiscover phase with "The name cannot be matched to a name in the address list".

Besides that, autodiscover is supposed to work and I can't expect my users to perform manual steps.

You said this type of error occurs when there is a trust modification - what does this mean, and how do I check for it or investigate it further? There's only one domain in the forest.
0
 
LVL 31

Expert Comment

by:Gareth Gudger
ID: 39810470
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 
LVL 14

Expert Comment

by:BlueCompute
ID: 39811740
Krishnamanoj83,

I don't seem to be able to get to the point where I can go into the Security tab.

When setting up the account, go 'Manual Setup' > Microsoft Exchange > More Settings and then you should see the Security tab that the previous expert referred to.
0
 
LVL 37

Expert Comment

by:Jamie McKillop
ID: 39811971
Hello,

Check your external URLs on you web services by running the following commands for each CAS server:

Get-OutlookAnywhere -identity <CAS Server> | fl
ExternalHostname should be your public DNS name (eg. mail.domain.com)

Get-ActiveSyncVirtualDirectory -identity <CAS Server> | fl
Get-WebServicesVirtualDirectory -identity <CAS Server> | fl
Set-OABVirtualDirectory -identity <CAS Server> |fl
ExternalUrl on all three should be your public DNS name (eq. mail.domain.com)

You also need to ensure the internal URL for your autodiscover service is set correctly

Set-ClientAccessServer -identity <CAS Server> | fl
AutoDiscoverServiceInternalURI should be the internal URL to the AS service. This needs to match a name on your cert. With a typical split-DNS config, it would be the same as your external hostname (eg. https://autodiscover.domain.com/AutoDiscover/AutoDiscover.xml)

-JJ
0
 
LVL 31

Author Comment

by:Frosty555
ID: 39832871
Well, I've been on the phone with Microsoft about this for six hours in total over the last few days without much luck. Not sure if maybe I drew the short stick with this particular support case but these guys haven't been particularly helpful.

We did a lot of fiddling looking at log files, authentication settings, SSL settings etc. in IIS and everything looks fine. ExRCA also doesn't complain about anything.

One thing that did have an effect - I was instructed to go into IIS->Autodiscover Site->Authentication, and edit the "Basic Authentication" option, setting the "Default Domain" to be the backslash character, "\".

This caused the error message to change from "The name cannot be matched", to "The connection to Exchange is unavailable".

Despite this, we have determined that I CAN, in fact, manually configure Outlook and it appears to work. Krishnamanoj83's suggestion of ticking the "Always prompt for authentication" checkbox has no effect on anything, but if I go to "Manually Configure" and I manually type everything in, it does seem to work.

However, I have to leave UNCHECKED the "Only connect to proxy servers that have this principal name in their certificate" option in the Exchange Proxy Settings.  If I tick it and I specify the principle name of "msstd:mail.mycompany.com", I get the same error as before, of "The connection to Exchange is unavailable" error.

Maybe this is a hint to the cause of my problem?

Here are the results of Get-OutlookProvider:

Name                          Server                        CertPrincipalName             TTL
----                          ------                        -----------------             ---
EXCH                                                        msstd:mail.mycompany.com           1
EXPR                                                        msstd:mail.mycompany.com           1
WEB                                                                                       1

Open in new window




-------------------

jjmck - responding to your comment, here's the way my hostnames are set up:

     - We have two sites at two different offices. Each site has a DC and an Exchange server. The sites are joined by a site-to-site VPN.
     - Site "A" is the one that is used for remote access, outlook anywhere etc.

My hostnames are as follows:

A.mycompany.com   -   A record resolving to the external IP address of site A
B.mycompany.com   -   A record resolving to the external IP address of site B
mail.mycompany.com   -   CNAME record for A.mycompany.com

The certificate has A, B, mail, autodiscover and a couple others listed, and "mail.mycompany.com" is the certificate's principle name.

It is a split DNS setup, so internally, the A.mycompany.com and B.mycompany.com and Mail.mycompany.com records all resolve to the internal IP address of the respective exchange servers.

Get-OutlookAnywhere
    ExternalHostname is set to a.mycompany.com
    InternalHostname is set to a.mycompany.com

Get-ActiveSyncVirtualDirectory
Get-WebServicesVirtualDirectory
Get-OABVirtualDirectory


The InternalURL and ExternalURL are all set to one of:

    https://a.mycompany.com/...rest-of-the-url
    https://b.mycompany.com/...rest-of-the-url

Depending on which CAS you are talking about. The powershell commands were taking forever so I doublechecked this in Exchange Control Panel under Servers->Virtual Directories.

Get-ClientAccessServer

AutoDiscoverServiceInternalURI is set to one of

    https://a.mycompany.com/autodiscover/autodiscover.xml
    https://b.mycompany.com/autodiscover/autodiscover.xml

Depending on which CAS you're talking about.
0
 
LVL 37

Expert Comment

by:Jamie McKillop
ID: 39839945
If you are only using Site A for remote access, all your external URLs should point to site A. If I understand you correctly, it looks like your activesync, webservcies, and OAB external URLs are pointed at site B.

-JJ
0
 
LVL 31

Author Comment

by:Frosty555
ID: 39843388
A bit of an update - I managed to get things working... a little bit...

It's that "Only connect to proxy servers that have this principal name in their certificate" option that is causing all the headache. I had the CertPrincipalName for the Outlook Provider set it to "msstd:mail.mycompany.com", which IS the common name on my certificate but for some reason it still fails. When I clear the tickbox in Outlook it works fine.

So I changed the CertPrincipalName for the EXPR and EXCH Outlook Providers to be the string "none". Now, lo and behold Outlook is now automatically configuring itself properly! Well, most of the time.... I'm still having intermittent issues sometimes depending on the computer I try to configure the account on which I need to investigate.

But - JJ I think you're heading down the right track. I DO want all external access to be from Site A,

I ran Outlook and did a "Test E-Mail Autoconfiguration" (by ctrl+right clicking on the Outlook icon in the system tray), and it is returning that Site B is being used for the various URLs. Even though Site A's mailbox is configured as the "active" mailbox.

I want it to return Site A all of the time for EXTERNAL access (ActiveSync, Outlook Anywhere, or OWA). HOWEVER - I want the workstations at Site B to use Site B's CAS for accessing their mailbox while they are locally sitting in the office.

What settings should I change?

I thought maybe I should set the $Server property for the Outlook Provider (e.g. Set-OutlookProvider EXPR -Server a.mycompany.com)

But JJ it sounds like you are suggesting that I should go into ECP->Servers->Virtual Directories, and change the various URLs for all of Site B's virtual directories to specify the Site A FQDN. Are you sure that's correct?
0
 
LVL 37

Expert Comment

by:Jamie McKillop
ID: 39847239
Yes, you want to only change the ExternalURL field on the virtual directories. Leave the internal URLs as is.

-JJ
0
 
LVL 31

Author Comment

by:Frosty555
ID: 39883135
Hi JJ,

I've set the externalURL options on the servers to all be site A. Now it shows site A URLs for everything, but this doesn't seem to have made any difference, I'm still getting the same failure as before.

Also, after further investigation I discovered that it is only working on MY computer. I'm running Outlook 2010 on a Windows 8.1 computer outside of the network and not joined to the domain. It works on this computer, but I get the same error about not being able to connect to Exchange on all other computers. I can't for the life of me figure out what's special about my computer that is making it work.

I installed Exchange 2013 Cumulative Update 3 on the request of the Microsoft tech support person, seems to have not had any effect.

The microsoft tech says he is seeing some sort of communication failure or logon issue in the rpcproxy logs on the exchange server, something about port 6001 but didn't provide any further details than that.

....... what now?
0
 
LVL 37

Expert Comment

by:Jamie McKillop
ID: 39883154
Are the computers you are having trouble with inside or outside your network? Does your autodiscover.mycompany.com A record point to the CAS server in site A?

-JJ
0
 
LVL 31

Author Comment

by:Frosty555
ID: 39898960
Hi JJ,

Inside works fine, the problem is with computers outside of the network. The public DNS servers for mycompany.com have an A record that points autodiscover.mycompany.com at the external WAN IP address of Site A. Port forwarding on Site A's router's directs port 80/443 to the CAS server in site A.

Inside the network, autodiscover.mycompany.com points to the internal IP address of the CAS server in site A. This IP is accessible from both sites, because of the site-to-site VPN joining the two networks

Autodiscover seems to work fine. Here's the results of the autodiscover response when I test it in Outlook.

Do you see anything fishy here?

<?xml version="1.0" encoding="utf-8"?>
<Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
  <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
    <User>
      <DisplayName>Test Test</DisplayName>
      <LegacyDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=c3fe530042a9467da54289f1b3159078-Test</LegacyDN>
      <AutoDiscoverSMTPAddress>test@mycompany.com</AutoDiscoverSMTPAddress>
      <DeploymentId>dcda95d7-84ff-4927-a659-a302e2dc7d9c</DeploymentId>
    </User>
    <Account>
      <AccountType>email</AccountType>
      <Action>settings</Action>
      <MicrosoftOnline>False</MicrosoftOnline>
      <Protocol>
        <Type>EXCH</Type>
        <Server>40309812-a288-4a0b-bf49-a47931685034@mycompany.com</Server>
        <ServerDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=40309812-a288-4a0b-bf49-a47931685034@mycompany.com</ServerDN>
        <ServerVersion>73C08307</ServerVersion>
        <MdbDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=40309812-a288-4a0b-bf49-a47931685034@mycompany.com/cn=Microsoft Private MDB</MdbDN>
        <PublicFolderServer>sitea.mycompany.com</PublicFolderServer>
        <AD>NMKT-DC.acyr.local</AD>
        <ASUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</ASUrl>
        <EwsUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</EwsUrl>
        <EmwsUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</EmwsUrl>
        <EcpUrl>https://sitea.mycompany.com/ecp/</EcpUrl>
        <EcpUrl-um>?rfr=olk&amp;p=customize/voicemail.aspx&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-um>
        <EcpUrl-aggr>?rfr=olk&amp;p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-aggr>
        <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?rfr=olk&amp;exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;&amp;realm=mycompany.com</EcpUrl-mt>
        <EcpUrl-ret>?rfr=olk&amp;p=organize/retentionpolicytags.slab&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-ret>
        <EcpUrl-sms>?rfr=olk&amp;p=sms/textmessaging.slab&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-sms>
        <EcpUrl-publish>customize/calendarpublishing.slab?rfr=olk&amp;exsvurl=1&amp;FldID=&lt;FldID&gt;&amp;realm=mycompany.com</EcpUrl-publish>
        <EcpUrl-photo>PersonalSettings/EditAccount.aspx?rfr=olk&amp;chgPhoto=1&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-photo>
        <EcpUrl-extinstall>Extension/InstalledExtensions.slab?rfr=olk&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-extinstall>
        <OOFUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</OOFUrl>
        <UMUrl>https://sitea.mycompany.com/EWS/UM2007Legacy.asmx</UMUrl>
        <OABUrl>https://sitea.mycompany.com/OAB/c578bdd6-417f-492f-a5fe-69e57e68f42a/</OABUrl>
        <ServerExclusiveConnect>off</ServerExclusiveConnect>
        <CertPrincipalName>msstd:mail.mycompany.com</CertPrincipalName>
      </Protocol>
      <Protocol>
        <Type>EXPR</Type>
        <Server>sitea.mycompany.com</Server>
        <SSL>On</SSL>
        <AuthPackage>Ntlm</AuthPackage>
        <ASUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</ASUrl>
        <EwsUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</EwsUrl>
        <EmwsUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</EmwsUrl>
        <EcpUrl>https://sitea.mycompany.com/ecp/</EcpUrl>
        <EcpUrl-um>?rfr=olk&amp;p=customize/voicemail.aspx&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-um>
        <EcpUrl-aggr>?rfr=olk&amp;p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-aggr>
        <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?rfr=olk&amp;exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;&amp;realm=mycompany.com</EcpUrl-mt>
        <EcpUrl-ret>?rfr=olk&amp;p=organize/retentionpolicytags.slab&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-ret>
        <EcpUrl-sms>?rfr=olk&amp;p=sms/textmessaging.slab&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-sms>
        <EcpUrl-publish>customize/calendarpublishing.slab?rfr=olk&amp;exsvurl=1&amp;FldID=&lt;FldID&gt;&amp;realm=mycompany.com</EcpUrl-publish>
        <EcpUrl-photo>PersonalSettings/EditAccount.aspx?rfr=olk&amp;chgPhoto=1&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-photo>
        <EcpUrl-extinstall>Extension/InstalledExtensions.slab?rfr=olk&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-extinstall>
        <OOFUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</OOFUrl>
        <UMUrl>https://sitea.mycompany.com/EWS/UM2007Legacy.asmx</UMUrl>
        <OABUrl>https://sitea.mycompany.com/OAB/c578bdd6-417f-492f-a5fe-69e57e68f42a/</OABUrl>
        <ServerExclusiveConnect>on</ServerExclusiveConnect>
        <CertPrincipalName>msstd:mail.mycompany.com</CertPrincipalName>
        <EwsPartnerUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</EwsPartnerUrl>
        <GroupingInformation>Newmarket-Office</GroupingInformation>
      </Protocol>
      <Protocol>
        <Type>WEB</Type>
        <Internal>
          <OWAUrl AuthenticationMethod="Basic, Fba">https://sitea.mycompany.com/owa/</OWAUrl>
          <Protocol>
            <Type>EXCH</Type>
            <ASUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</ASUrl>
          </Protocol>
        </Internal>
        <External>
          <OWAUrl AuthenticationMethod="Fba">https://sitea.mycompany.com/owa/</OWAUrl>
          <Protocol>
            <Type>EXPR</Type>
            <ASUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</ASUrl>
          </Protocol>
        </External>
      </Protocol>
      <Protocol>
        <Type>EXHTTP</Type>
        <Server>sitea.mycompany.com</Server>
        <SSL>On</SSL>
        <AuthPackage>Ntlm</AuthPackage>
        <ASUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</ASUrl>
        <EwsUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</EwsUrl>
        <EmwsUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</EmwsUrl>
        <EcpUrl>https://sitea.mycompany.com/ecp/</EcpUrl>
        <EcpUrl-um>?rfr=olk&amp;p=customize/voicemail.aspx&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-um>
        <EcpUrl-aggr>?rfr=olk&amp;p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-aggr>
        <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?rfr=olk&amp;exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;&amp;realm=mycompany.com</EcpUrl-mt>
        <EcpUrl-ret>?rfr=olk&amp;p=organize/retentionpolicytags.slab&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-ret>
        <EcpUrl-sms>?rfr=olk&amp;p=sms/textmessaging.slab&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-sms>
        <EcpUrl-publish>customize/calendarpublishing.slab?rfr=olk&amp;exsvurl=1&amp;FldID=&lt;FldID&gt;&amp;realm=mycompany.com</EcpUrl-publish>
        <EcpUrl-photo>PersonalSettings/EditAccount.aspx?rfr=olk&amp;chgPhoto=1&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-photo>
        <EcpUrl-extinstall>Extension/InstalledExtensions.slab?rfr=olk&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-extinstall>
        <OOFUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</OOFUrl>
        <UMUrl>https://sitea.mycompany.com/EWS/UM2007Legacy.asmx</UMUrl>
        <OABUrl>https://sitea.mycompany.com/OAB/c578bdd6-417f-492f-a5fe-69e57e68f42a/</OABUrl>
        <ServerExclusiveConnect>On</ServerExclusiveConnect>
        <CertPrincipalName>msstd:mail.mycompany.com</CertPrincipalName>
      </Protocol>
      <Protocol>
        <Type>EXHTTP</Type>
        <Server>sitea.mycompany.com</Server>
        <SSL>On</SSL>
        <AuthPackage>Ntlm</AuthPackage>
        <ASUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</ASUrl>
        <EwsUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</EwsUrl>
        <EmwsUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</EmwsUrl>
        <EcpUrl>https://sitea.mycompany.com/ecp/</EcpUrl>
        <EcpUrl-um>?rfr=olk&amp;p=customize/voicemail.aspx&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-um>
        <EcpUrl-aggr>?rfr=olk&amp;p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-aggr>
        <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?rfr=olk&amp;exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;&amp;realm=mycompany.com</EcpUrl-mt>
        <EcpUrl-ret>?rfr=olk&amp;p=organize/retentionpolicytags.slab&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-ret>
        <EcpUrl-sms>?rfr=olk&amp;p=sms/textmessaging.slab&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-sms>
        <EcpUrl-publish>customize/calendarpublishing.slab?rfr=olk&amp;exsvurl=1&amp;FldID=&lt;FldID&gt;&amp;realm=mycompany.com</EcpUrl-publish>
        <EcpUrl-photo>PersonalSettings/EditAccount.aspx?rfr=olk&amp;chgPhoto=1&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-photo>
        <EcpUrl-extinstall>Extension/InstalledExtensions.slab?rfr=olk&amp;exsvurl=1&amp;realm=mycompany.com</EcpUrl-extinstall>
        <OOFUrl>https://sitea.mycompany.com/EWS/Exchange.asmx</OOFUrl>
        <UMUrl>https://sitea.mycompany.com/EWS/UM2007Legacy.asmx</UMUrl>
        <OABUrl>https://sitea.mycompany.com/OAB/c578bdd6-417f-492f-a5fe-69e57e68f42a/</OABUrl>
        <ServerExclusiveConnect>On</ServerExclusiveConnect>
        <CertPrincipalName>msstd:mail.mycompany.com</CertPrincipalName>
      </Protocol>
      <PublicFolderInformation>
        <SmtpAddress>PublicFolderMailbox@mycompany.com</SmtpAddress>
      </PublicFolderInformation>
    </Account>
  </Response>
</Autodiscover>

Open in new window

0
 
LVL 31

Author Comment

by:Frosty555
ID: 39929379
Microsoft asked me to run a netsh trace, and give them the recent rpcproxy logs for the server and they've taken it away to go analyze it. I guess I have to wait and see now.

Any other suggestions in the mean time?
0
 
LVL 31

Accepted Solution

by:
Frosty555 earned 0 total points
ID: 39985127
Well, we finally got it figured out.

The problem ultimately was with NTLM authentication. In Get-OutlookAnywhere, the ExternalClientAuthenticationMethod was set to NTLM, and for some reason that wasn't working.  Microsoft claims it's a problem with the firewall, which I can't disprove but also seems strange to me because we just have a very simple consumer grade router on the network. I don't think it has the capability of blocking NTLM.

In any case, after we set the authentication method to Basic, everything started working.

This is baffling. I don't know HOW we managed to miss that. I also have my doubts that this is related to my original problem ("Name cannot be matched to a name in the address book"). At some point in teh troubleshooting process the error message changed from "Name cannot be matched", to "Exchange server must be online", so my guess is something changed and we accidentally fixed the problem without realizing it.

So at this point, I'm really not sure what the solution was, other than saying that Basic authentication for external users seems to work better than NTLM.
0
 
LVL 31

Author Closing Comment

by:Frosty555
ID: 39995811
No way to know what the real answer was
0
 

Expert Comment

by:Kitemare
ID: 41035195
I had the exact same message however mine was simply that I had infact hidden the account from the exchange address list
HideFromExchangeAddressList.JPG
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question