Solved

Cisco ASA 5505

Posted on 2014-01-10
7
524 Views
Last Modified: 2014-01-13
Hi,

I canceled my block of IP addresses with ISP and now I have only one public IP address. This is the address when I type whatismyipaddress.com. I have DSL modem. I reconfigured my ASA 5505 but I don't have internet connection now. I really don't know what is wrong now.  I added a static route as : route outside 0.0.0.0 0.0.0.0 192.168.0.1 ( DSL local IP address) 1.

Could you please help me on this ?

 I had a block of IP address before : route outside 0.0.0.0 0.0.0.0 65.184.101.118 1 which 65.184.101.118 was my gateway but I don't know  about now since I have DSL modem and one public IP address.

Please help.
0
Comment
Question by:roozbehdec
7 Comments
 
LVL 11

Expert Comment

by:Miftaul
ID: 39773016
What is the public IP address, is that on WAN interface.

Previously as you were using Public IP addresses intenally, NAT was not requires, but now NAT is required because you have private range of IP and to go to internet these Private IPs needs to be translated to your WAN public IP.
0
 
LVL 17

Expert Comment

by:lruiz52
ID: 39773308
Please post a sanitized config.

Also, what type of  DSL modem do you have. Check if it supports transparent bridge mode. This will allow to set the static ip assigned by your ISP as the wan ip on the asa.
0
 

Author Comment

by:roozbehdec
ID: 39774859
Here is my config:

65.101.184.118 is the public IP address when I type whatismyipaddress.com

:
ASA Version 8.2(1)
!
hostname ciscoasa
enable password 2KFQnbNIdI.2KYOU encrypted
passwd fnsJPtP.ksBdlll9 encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 65.101.184.118 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
 shutdown
!
interface Ethernet0/3
 shutdown
!
interface Ethernet0/4
 shutdown
!
interface Ethernet0/5
 shutdown
!
interface Ethernet0/6
 shutdown
!
interface Ethernet0/7
 shutdown
!
ftp mode passive
pager lines 24
mtu inside 1500
mtu outside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 10 192.168.1.0 255.255.255.0
route outside 0.0.0.0 0.0.0.0 192.168.0.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.5-192.168.1.9 inside
dhcpd dns 8.8.8.8 interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
username Alex password wd7JHU0B24Pow.1m encrypted privilege 15
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip
  inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:a6762d33a109cfb050d99c5cb08f8a22
: end
ciscoasa#
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 57

Accepted Solution

by:
Pete Long earned 500 total points
ID: 39775121
You outside route is on a different network to your outside interface?

If you only have one IP address are you sure there is not another in use on the modem/router?

With only one IP you would usually set the ASA to get its IP address on the outside interface via DHCP, then use the setroute keyword instead of having a route command.

like so

interface Vlan2
 nameif outside
 security-level 0
 ip address dchp setroute

This relies on the modem/router allocating the one IP address toy you, how that's done on the router/modem depends on the device and isp.

PL
0
 
LVL 17

Expert Comment

by:lruiz52
ID: 39775213
Since you only have 1 public ip, best hing would be to set your DSL modem to transparent bridge mode.
0
 
LVL 16

Expert Comment

by:InteraX
ID: 39777035
Has your ISP setup PPPoE? Usually a single public IP address on an ASA is setup using PPPoE.

Currently, your config is to still use a /24 block of addresses. (subnet mask 255.255.255.0) The subnet mask for a single IP address is 255.255.255.255 which I( don't think the ASA can handle in this way.

I doubt DHCP will work because I don't think this can handle the /32 subnet mask.

I have seen the configuration whereby you do have a single IP address on a larger block and this is filtered at the ISP end, but I have only seen this once. PPPoE is much more common.

Pete Long has a guide at http://www.petenetlive.com/KB/Article/0000831.htm
0
 

Author Closing Comment

by:roozbehdec
ID: 39777061
Thank you. I used command : IP address DHCP and it resolved my issue.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
catalyst 6500 - recover from corrupted IOS 4 58
VLAN Tagged traffic 2 35
Cisco universal IOS upgrade from ipbase to ipservices 4 65
syslog id vs. msg 2 20
How to configure Site to Site VPN on a Cisco ASA.     (version: 1.1 - updated August 6, 2009) Index          [Preface]   1.    [Introduction]   2.    [The situation]   3.    [Getting started]   4.    [Interesting traffic]   5.    [NAT0]   6.…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now