Brand new server - exchange 2013 major problems

Hello..

I've been working on this for some time now, and can't seem to find the answer.  I have a brand new server with gobs of ram and hard disk space.  Installed Server 2012 Datacenter and fully patched.  The server is in an AD Domain with server 2008 and exchange 2007.  In installed the Rollup 12 for exchange 2007 that is required for 2013 to co-exist with 2007.  I installed exchange 2013 on the new server (the only thing on that new server is server 2012 and exchange 2013).  

After the install of 2013 (FROM THE CU2 UPDATE INSTALLATION) nothing works.  

*Exchange Management Shell won't work and reports, "The WS-Management Service does not support the request"  
*Exchange toolbox bombs with an MMC error.
*The /ECP website states the webserver "declined to show the webpage".

I'm not having any luck, and I've been googling for hours.  I have seen people report the same issues, but the path to correcting it is a bit blurred.  

Any help from someone who's been there, done that?

Thanks!!
LVL 2
TimFarrenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TimFarrenAuthor Commented:
Update - I just discovered there is a 2013 CU3.  I'm downloading that now and will install.  I hope this helps.
Simon Butler (Sembee)ConsultantCommented:
Everything goes through IIS, so if there is a problem with IIS then it stops everything else from working. Gut instinct here is the SSL certificate is corrupt and needs to be recreated.

You can do that through regular PowerShell, then starting the Exchange extensions.

Simon.
TimFarrenAuthor Commented:
Simon - thank you for your response!  I'm really struggling here.  We have an existing exchange 2007 server in the network, and plan to do a migration.  It's got a purchased cert on it, but the 2013 has whatever occurs during a regular install of 2012 and exchange 2013.  I didn't specifically assign a cert.

To ensure everything works correctly, do I need to get another cert for this server, or can I use the same one?  The server's name is different than the 2007 server - so best practice, how to proceed with the idea in mind that we will move the mailboxes over to 2013 and then decommission the 2007 exchange?

Thanks again, and my apologies if this is basic stuff I should already know.
Get Blueprints for Increased Customer Retention

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

TimFarrenAuthor Commented:
Simon -

I bought a certificate.  I assigned it to a hostname we aren't using (mail.ourdomain.com) and applied it IIS.  Then I went through and set all the HTTPS bindings to use that new cert.  Then I went to DNS and created an A record (internally) to point to the internal IP address with the associated mail.ourdomain.com.  I can ping the name, and it resolves fine internally.  I can browse to https://mail.ourdomain.com  and the IIS 8 page comes up with no warning on the newly purchased cert.

I still:

*Cannot open the exchange management shell
*Cannot open /ecp  (says declined to show the page)
*Cannot open exchange toolbox due to MMC error.

Please.. any ideas?
TimFarrenAuthor Commented:
Simon -

FYI, in case someone else asks... I solved it with this:

dism /online /enable-feature /all /featurename:IIS-ASPNET45

IISRESET

All works now.  Thanks for your input.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TimFarrenAuthor Commented:
Additionally, OWA wouldn't send mail (said something like "can't send right now") until the following features were installed:

.NET framework 4.5 -> WCF Services -> HTTP Activation
Windows process activation service -> Process model
Windows process activation service -> Configuration APIs

All my problems were centered on .net 4.5 features being missing.  Why didn't MS require them for installation as prerequisites?
Simon Butler (Sembee)ConsultantCommented:
If you followed the prerequisites documentation, then that should have covered everything.
Either you missed it, it failed to install correctly or something was changed after Exchange had been installed. Certainly I have done a lot of Exchange 2013 installations recently and I just use the command listed on the prerequisites page on TechNet and have never seen a problem.

Simon.
TimFarrenAuthor Commented:
Hmm.. Odd.

I had no installation errors. There were a list of checks during the install, and I went through line by line and installed the prerequisites listed, until the precheck routine said it was ready. Well.. I know now for next time.
TimFarrenAuthor Commented:
I found the answer to my issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.