Solved

Windows Server 2008 and ping problems

Posted on 2014-01-12
40
2,484 Views
1 Endorsement
Last Modified: 2014-03-03
I have a problem with a new Windows Server 2008 setup. I have run the AD setup, DNS, DHCP, File and Print Services--all that went fine. Problem is that I have an accounting program that uses a SQL database that is hosted on this server. The accounting package uses the servername and not the IP (v4) address to connect to the SQL database--this is the problem. When I ping the server this is what I get (see below) The tech support said that the servername must resolve to the IPv4 address of 192.168.2.80 to work. I have unchecked IPv6, disabled the tunnel NIC found in Device Manager and can't for the life of me find a way to get a ping to resolve to a IPv4 address for the server. If I ping my workstations I get IPv4 addresses. HELP--please.
C:\Utils>ping srvr01

Pinging SRVR01.kbr.local [::1] with 32 bytes of data:
Reply from ::1: time=1ms
Reply from ::1: time<1ms
Reply from ::1: time<1ms
Reply from ::1: time<1ms

Ping statistics for ::1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms
1
Comment
Question by:lionelmm
  • 18
  • 9
  • 7
  • +3
40 Comments
 
LVL 24

Author Comment

by:lionelmm
ID: 39775049
FYI--when I ping srvr01 from Hyper-V (host) I het and IPv4 address
ping srvr01
Pinging SRVR01 [192.168.2.80] with 32 bytes of data:
Reply from 192.168.2.80: bytes=32 time=1ms TTL=128
Reply from 192.168.2.80: bytes=32 time<1ms TTL=128
Reply from 192.168.2.80: bytes=32 time<1ms TTL=128
Reply from 192.168.2.80: bytes=32 time=2ms TTL=128
Ping statistics for 192.168.2.80:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 2ms, Average = 0ms
0
 
LVL 56

Assisted Solution

by:Cliff Galiher
Cliff Galiher earned 100 total points
ID: 39775069
First, ping is a terrible tool for testing DNS. It is meant to test connectivity, hence the packet size, delay time, and TTL. Always best to use the right tool for the job.

Second, windows will do IPv6 and IPv4 concurrently when possible. This is normal, expected, and IPv4-only apps will still work. Don't disable IPv6. You almost always break more than you fix. Windows *really* likes IPv6 these days. Leave it on.

Third, test your IPv4 DNS using nslookup. You can even force an IPv4 lookup (so you are replicating what an IPv4-only application would see) using the -4 flag/option of the command line. If that reports a proper IPv4 address then your DNS is working as expected for the app and your problem likely lies elsewhere.

Finally, running SQL on a DC rarely works out. You may find your issue actually lies there and you'll want to reconsider that. Since it sounds like you have hyper-v in place, a member SQL server would be ideal.
0
 
LVL 10

Assisted Solution

by:Korbus
Korbus earned 200 total points
ID: 39775087
I agree with cgaliher;  this is the address your DNS server is returning.  use "NSlookup" command to find name-resultion results. and Definately do NOT turn of IPv6.

One last thing to note:  even though it IS using IPv6, it's seems to be working fine, your ping IS getting a response.  You may not NEED to fix anything.
0
 
LVL 35

Expert Comment

by:Mahesh
ID: 39775098
How did you disable IPv6?

By default IPv6 takes precedence over IPv4, so your ping results are normal.

NSLOOKUP defaults resolves to A (IPv4) records, so its also OK

If you disable it from the NIC properties it won't be totally disabled. To really get rid of it you need to make registry change as well as mentioned in below article
http://support.microsoft.com/kb/929852

You will find option there in registry in above article to change preference to IPv4 over IPv6 if you don't want to disable it as MS do not recommend to disable IPv6

Mahesh
0
 
LVL 10

Expert Comment

by:Korbus
ID: 39775099
Sorry, misread question: please ignore last part of my reply.
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39775101
Thanks. A second VM is out of the question. This is a small business with 4 users and an accounting package that uses SQL. We have had this setup for about 4 years with no major problems but then about 6 months ago the VM started exhibiting several different issues, ALL after various Windows updates (all of which I posted on EE and nobody could resolve them for me). After about 3 months of this I suggested we create a new VM instead of me spending all this time on a VM I inherited from the previous IT guy. When I use the accounting package and provide the address srvr01\kbr (where kbr is the SQL database name) it does not connect. How would I use NSlookup to find what the problem really is? Thank you.
0
 
LVL 10

Accepted Solution

by:
Korbus earned 200 total points
ID: 39775122
just suggesting you use nslookup, rather than ping, but the usage and reasons for using it are similar.
c:\>  nslookup srvr01
when this is returning an IPv4 address, you know you're set.

I have been unable to figure out how to get your server to return only IPv4, but dont forget to do an "IPconfig /flushdns" after you make a change, and before you test again with NSLOokup.

Hmm, I do see one anoying looking workaround:  since the hosts file is checked BEFORE the DNS server, you could put the IPv4 entry in there on the workstations:  http://www.howtogeek.com/howto/27350/beginner-geek-how-to-edit-your-hosts-file/
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39775137
What does this tell me? That an app login to srvr01\kbr should work and that is is more than likely a SQL problem and not an IPv4 problem?
C:\Utils>nslookup srvr01
Server:  localhost
Address:  127.0.0.1

Name:    srvr01.kbr.local
Address:  192.168.2.80
0
 
LVL 78

Expert Comment

by:David Johnson, CD, MVP
ID: 39775286
When you rebuilt the server did you open port 1433 in the servers firewall for the local network?
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39775595
I turned the firewall off to see if that would resolve the problem--it did not.
0
 
LVL 35

Expert Comment

by:Mahesh
ID: 39777449
Have you tried MS KB article as per my comment to give IPv4 preference over IPv6 in my 1st comment

Mahesh
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39778034
This is a NetBIOS name resolution problem.
Just try to use the IP address of srvr01 instead of its name and tell us if this is any better.
It's been decades now for Windows hosts have been able to use an IP address or a name.
You can perfectly specify \\192.168.2.80 as a NetBIOS name. Unless the client application has some king of logic to prevent you from using an IP address instead of a name, this should work.
If you want to know a littel more about it...
Don't use ping nor nslookup. These tool do NOT check NetBIOS names, they do check DNS names.
NetBIOS over TCP/IP resolution can use DNS, among other ways to resolve a netBIOS name into a TCP/IP addresses. These other ways are: NetBIOS-Name-SErver (WINS Server) and broadcast. Depending on how your client is configured, it will try these methods in various orders:
http://support.microsoft.com/kb/142309/en


http://technet.microsoft.com/en-us/library/cc958811.aspx

The tool to see what is stored in your netbios/tcpip cache is nbtstat. Launch it with
nbtstat -c
to display the current entries in the cache
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39778047
Something else to try:
In a CMD window from a workstation that is supposed to connect to srvr01\kbr, enter the command:
net use \\srvr01\kbr
If it asks you for a user name and password (or if you can connect), there is no name resolution problem.
If not, you have to resolve the issue (post the error message, it may help us helping you)

If it asks you for a name and password, enter ones that are allowed to connect to this share. The client application may have a username/password or may use the credentials of the user currently logged on. Either way, this shared folder is supposedly accessible from one of your workstations, so try that. When you can connect this way, you will know for sure that you do not have any name resolution or "Windows Networking" (aka NetBIOS) issue.
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39788471
vivigatt on your last comment you seem to have confused the issue with server shares (\\srvo1\kbr instead of a SQL call of srvr01\kbr, no "\\"). This is not a share but the command we put into the accounting app to tell is where the database is located, namely srvr01 (the server where SQL is located) and kbr (the name of the database on that server). As far as the netbios settinsg go they are properly set, thank you, and other systems on the network can ping just fine (4 Windows 7 PCs) and get the expected IPv4 response.
0
 
LVL 78

Assisted Solution

by:David Johnson, CD, MVP
David Johnson, CD, MVP earned 100 total points
ID: 39789906
try ping -4 servername    (-4 uses the ipv4 stack)
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39791591
I am not an expert in SQLServer and remote connection to it.
However, using a \ in a "dns resolved name" is very unusual. But it seems that this is the way it goes. Thanks for reporting my mistake, I've learned something.

When not to be able to ping with ipv4, one thing that really helps (usually) is to use a packet monitor (Wireshark or MS Netmon) on both ends, filtering on MAC address, IP address or protocols.
Of course, you doubled check that firewall was off or allowing pings (ICMP echo messages) on all the path.

Once you know a little more what happens (and you've solved your ping/ICMP connection issue), and if your problem is still not solved, you may want to use this tool (DTCTester) :
http://support.microsoft.com/kb/293799
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39800488
This is run through the accounting app--it is not a true SQL call, one you can put into SQL queries for example so if what I said is confusing I apologize. In the accounting program the server\database field is filled in by inserting srvr01\kbr.

I tried to ficure out where this was going wrong so I created a new VM and after each change I ran ipconfig and each time I got the same response as the current, funtioning server, until I added the AD role. Once I did that (which also requires install of the DNS), that is when ipconfig results changed. Does this help anyone with what may be going wrong?
0
 
LVL 10

Expert Comment

by:Korbus
ID: 39800707
lionelmm,  did you try the workaround I suggestead earlier, using the windows HOSTS file to specify the server name (http://www.howtogeek.com/howto/27350/beginner-geek-how-to-edit-your-hosts-file/)?  This will be used by the PC before DNS.  
Even if you dont want to use it as a workaround, it will narrow down your issue.  If it WORKS after making the hosts file change, the issue is 100% purely DNS (not SQL).
0
 
LVL 16

Assisted Solution

by:vivigatt
vivigatt earned 100 total points
ID: 39801249
The AD role you added included domain controller, right?
Then I guess that the 1st DNS server for the machine was 127.0.0.1 (itself). If not it has to be so or, if the server is not an AD controller, it must use one of your AD controllers as its 1st DNS.
For resolving names outside your own AD zones, you need to configure a DNS forwarder for your DNS server(s):
http://technet.microsoft.com/en-us/library/cc754941.aspx
Make sure the DNS the requests are forwarded are able to resolve your host.
You can also add A or PTR entries to your DNS zone so that the host name you want is correctly resolved
Something else to try: investigate the DNS suffixing issues. You may try to resolve/ping the host name with a trailing dot, so that  no implicit DNS suffix is added.
Try the name alone (Srv01.   with the ".") and the FQDN (Srv01.domain.extension.)
Depending on your DNS request suffixing, this will have different results.

Actually, I just made test and my own Windows DNS server can't resolve its own FQDName unless I add a trailing dot .
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39802099
The AD role you added included domain controller, right? Yes
Then I guess that the 1st DNS server for the machine was 127.0.0.1 (itself)? Actually the 1st DNS is ::1 and the second is 127.0.0.1
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 24

Author Comment

by:lionelmm
ID: 39802103
I made changes to the hosts file and now ping works and ipconfig shows up as expected. So what does that tell me--I made changes to my hosts file on the server and am pinging on the server.
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39802741
This tells you that you do have an ipv4 DNS name resolution issue!
Change the DNS for the server to have 127.0.0.1 as its first server, delete/rename the hosts file and see if this is any better.
0
 
LVL 10

Expert Comment

by:Korbus
ID: 39803314
Hi linonelmm,

The last step in that test would have been to try your SQL using app, to make sure that works with the hosts file entry in place.
Assuming that works, you will need to fix DNS (but not SQL).  I'm going to let some other experts work with you on the actual repair, not confident enough with myself.
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39811947
I checked the settings and the first DNS is 127.0.0.1 for Ipv4 and ::1 for Ipv6. The Accounting app can now successfully connect.
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39811959
Problem solved?
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39811969
No if I remove the additions to the hosts file the ping and the app do not work on the server itself. The weird thing is that from the Win7 PCs it works. I am baffled as to why the PCs using the same primary DNS as the server works but it does not????????????
0
 
LVL 16

Expert Comment

by:vivigatt
ID: 39811988
Have you tried pigs with a trailing dot on the name?
similar to:
ping srvr01.
and
ping srvr01.domain.tld.
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39812000
yes--I thought I reported that, sorry if I didn't. Still even without the . why does it work with the changes to the hosts file but not without it?
0
 
LVL 10

Expert Comment

by:Korbus
ID: 39812522
You cannot safely turn IPV6 off on the server, so when do you do a DNS lookup from that machine, you will always get back an IPV6 address for the server.  (you turned off IPv6 on the W7 machine, but not the server, right?)

Possible workaround:  similar to the host file, you can add a new A Record to your DNS server.  Call it say: srvr01ip4  and assign it ONLY an IPv4 address.  You can then specify THIS name in your accounting software.
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39812726
In earlier comments someone said that it is not an IPv6 problem and that turning it would not fix anything so IPv6 is on on all the systems.

If possible I want to stay away from workarounds. Someone earlier said this indicates a problem with my DNS but did not say how to fix it. if this is a DNS problem I want to set it up properly so that it is working as it should.
0
 
LVL 10

Expert Comment

by:Korbus
ID: 39812801
I don't know if you are going to be able to make it work the way you want WITHOUT a workaround, considering the limitations of your 3rd party software.  I think the host file test confirms that the problem is due to the server giving out an IPv6, rather than IPv4 address, which your software can't handle.

I've been looking like crazy, but am unable to find out how to tell DNS server to return an IPv4 address BEFORE returning an IPv6 address.  Perhaps another expert will know how to do this.

I am honestly not sure why your workstations are getting an IPv4 address with Ipv6 enabled on them, and no host file entry.  (Which is what your more recent posts are implying- is this correct?)
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39813024
(Which is what your more recent posts are implying- is this correct?) Yes.

Plus the previous server was NOT doing this and it had IP v4 and 6. I just want to make sure there in nothing wrong with my DNS setup which may lead to problems down the road, thus my hesitation on a workaround. If it end up being that the DNS is setup properly (how do I determine that) then I will not mind a workaround at that point.
0
 
LVL 10

Expert Comment

by:Korbus
ID: 39820238
hmm, DCDiag has functions to test DNS configuration of your domain controller/dns server.

http://technet.microsoft.com/en-us/library/cc731968.aspx
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39825670
OK I ran this
dcdiag /DnsAll /f:C:\Utils\DNSTest.Log /s:srvr01 /e /v
and the attached file is the result--1) Did I run the proper test & 2) does the results mean the DNS is setup and working properly?
DNS-Test4SRVR01.txt
0
 
LVL 78

Expert Comment

by:David Johnson, CD, MVP
ID: 39825740
is sql server located on srv01 and is the instance name of kbr ??
try the sql management studio and check that you set it up (SQL Server) properly.. did you also add the database?
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39825927
1) is sql server located on srv01 and is the instance name of kbr ??
Yes
check that you set it up (SQL Server) properly
2) SQL is working properly--if I use the workaround suggested by Korbus all is well, when I remove it the accounting program will not connect
3) did you also add the database?
Yes.
0
 
LVL 10

Expert Comment

by:Korbus
ID: 39826826
The command you used LOOKS good, but it MUST be wrong because I see this in the results:

   "Test omitted by user request: DNS "  in four different places.  Or perhaps this is a clue.

Though I've used it before, I'm no master of DCDIAG, so perhaps another expert can help more here.

What do you get if you try this command, same result?
dcdiag /test:DNS /v /e
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39826861
I ran that command on another domain another server and the same thing is there, it must be the options of /DnsAll is not really all but maybe all the most basic tests. Upon reading the link provided by you above additional tests can be run. I think we should wait till someone who is better than me or you to look at my log and see if that indicates that there is no real issue with the DNS--I may just remove the DNS role--reboot and then put it back on and see if that resolves it.
0
 
LVL 24

Author Comment

by:lionelmm
ID: 39844411
We can't seem to get this solved so I am going to awards points for all those ho tried to help--any objections?
0
 
LVL 24

Author Closing Comment

by:lionelmm
ID: 39900898
Thanks.
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Join & Write a Comment

We recently endured a series of broadcast storms that caused our ISP to shut us down for brief periods of time. After going through a multitude of tests, we determined that the issue was related to Intel NIC drivers on some new HP desktop computers …
This article explains how to reset the password of the sa account on a Microsoft SQL Server.  The steps in this article work in SQL 2005, 2008, 2008 R2, 2012, 2014 and 2016.
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now