Improve company productivity with a Business Account.Sign Up

x
?
Solved

VMWare -Cisco physical switch configuration for etherchannel

Posted on 2014-01-12
3
Medium Priority
?
878 Views
Last Modified: 2016-11-23
i have a dell R710 connected via dual 10Gbps connections to a Cisco nexus 5548 switch. I am trying to configure the switch to use both 10Gbps ports in a port channel. when I apply the port-group 204 command on both the end ports, I lose connectivity to the host. What am I missing or could it be something on the vSwitch?


interface Ethernet1/23
  description HostA-10gig01
  switchport mode trunk
  switchport trunk native vlan 999
  switchport trunk allowed vlan 1-3,107-108,126
  spanning-tree port type edge
  flowcontrol receive on
  flowcontrol send on

interface Ethernet1/24
  description HostA-10gig02
  switchport mode trunk
  switchport trunk native vlan 999
  switchport trunk allowed vlan 1-3,107-108,126
  spanning-tree port type edge
  flowcontrol receive on
  flowcontrol send on


!Command: show running-config interface port-channel204
!Time: Sun Jan 12 23:42:53 2014


interface port-channel204
  description HostA-10Gig
  switchport mode trunk
  switchport trunk native vlan 999
  switchport trunk allowed vlan 1-3,107-108,126
  spanning-tree port type edge trunk
  flowcontrol receive on
  flowcontrol send on
0
Comment
Question by:jbla9028
  • 2
3 Comments
 
LVL 126

Accepted Solution

by:
Andrew Hancock (VMware vExpert / EE MVE^2) earned 2000 total points
ID: 39775877
Are you VLANs correct?

and is the management network in the correct VLAN?

e.g. the Tag is specififed on the portgroup?
0
 
LVL 1

Author Comment

by:jbla9028
ID: 39821665
I found my problem. I copied the configuration off of my production nexus 1000v. When I did this I included the line on my system uplink port.


channel-group auto mode on mac-pinning


In my enviornment I am only connecting to 1 switch (redundant switch is not there yet). This command is only used on VPCs from what I understand to tell the 1000v to pin the mac to a specific port rather than balancing traffic between ports.  We enabled this setting on the individual ports and the uplink port-profile. both ports then were allowed to be channeled.


channel-group auto mode on
0
 
LVL 126
ID: 39822017
ha ha, missing config, it happens!, glad you found your issue!
0

Featured Post

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Want to create a VM?  Here's how you do it.
The following article describes how to recreate the VMDK file of a virtual machine. It is important that this file is always in the datastore where the VM is stored, because if the VM is not present, it will not be able to turn on and an error …
Teach the user how to edit .vmx files to add advanced configuration options Open vSphere Web Client: Edit Settings for a VM: Choose VM Options -> Advanced: Add Configuration Parameters:
This Micro Tutorial steps you through the configuration steps to configure your ESXi host Management Network settings and test the management network, ensure the host is recognized by the DNS Server, configure a new password, and the troubleshooting…

607 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question