Solved

GPO to append safe sender list does not work for Outlook

Posted on 2014-01-12
4
6,965 Views
Last Modified: 2014-01-17
Hi team,

We do have a GPO that currently imports a safe sender list into User's junk folder in Outlook. This GPO has been in place for a while, but suddenly the safe sender list are not added to user's email

There is a logon script under User configuration that basically runs the “import_registry.bat” file for a user at logon.

From that I can see this batch file basically imports the contents of “JunkMailImportLists.reg” file located in \\domain\sysvol\domain\Policies\{xxxxxxxxxxxxxxxxxx}\User\Scripts\Logon into the HKCU.

As per attached screenshoot. This is the registry entry we are applying in the GPO. Currently it only does Outlook 2007,

To make it work for other versions of outlook [2010,2013], we have added he necessary subkeys:

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\1x.0\Outlook\Options\Mail
Note The 1x.0 placeholder represents your version of Outlook (11.0 = Outlook 2003, 12.0 = Outlook 2007, 14.0 = Outlook 2010, and 15.0 = Outlook 2013).

The GPO works in a sense that the registry keys are created under HKCU, however the safe sender list is not under junk’s email folder

Any ideas why outlook is not importing the safe sender list?

As per link below,

Reg keys come thru to machines with gp but when I open Outlook 2010/2013  the junkmailimportlists value is set to zero. Where's the catch

http://social.technet.microsoft.com/Forums/exchange/en-US/3d3abee5-ebf2-4dae-9f48-300b93af07c8/gpo-to-append-to-safe-senders-need-two-extra-registry-keys?forum=exchangesvrclientslegacy

Our exchange environment as per below

2 CAS/HUB Exchange 2010 SP3 running Windows 2008 R2 latest updates , one for each datacenter

2 MBX in a DAG Exchange 2010 SP3, running Windows 2008 R2. One mailbox server for each datacenter

All VMs resides on a hyperV host, no performance issues, and users run Outlook 2010/2013 Windows 7/8. Domain Forest functional level Windows 2008 R2
Cached1.jpg
Cached2.jpg
0
Comment
Question by:Jerry Seinfield
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 12

Accepted Solution

by:
SreRaj earned 250 total points
ID: 39775993
Hi,

In order for Junk Mail settings to work, you will have to install main Group Policy Template and custom Group Policy Template for respective versions of Outlook. For example, you will have to install main Group Policy Template for Office 2010 and custom Group Policy Template, outlk14-junkemailtrigger.adm for Junk Mail Settings to work for Outlook 2010. In Outlook 2013, custom Group Policy Template is not required. After these templates are installed, you will get different folders for each version of Outlook inside GPO and path to safe sender list should be selected in each folder.

Please refer 'More Information' section in the following KB.

http://support.microsoft.com/kb/2252421
0
 

Author Comment

by:Jerry Seinfield
ID: 39776642
thanks for the information,.
As per link http://support.microsoft.com/kb/2252421

The JunkMailImportLists registry value is the trigger that is used by Outlook to determine whether junk email list settings are applied when you start Outlook. This value for some reason  is set to zero (0),therefore Outlook will not apply any of the junk email list policy settings that may exist in the registry.

Any ideas why this registry value is set to zero? I did change this value manually, but after a few minutes is set back to 0
0
 
LVL 20

Assisted Solution

by:compdigit44
compdigit44 earned 250 total points
ID: 39778056
have you tried to set the Junkfilter settings globally using the Exchange EMC? Then deploy the safe sender list via GP???

http://community.spiceworks.com/topic/317220-junk-filter-turned-off-in-outlook-2010-still-getting-emails-in-junk-folder
0
 
LVL 12

Expert Comment

by:SreRaj
ID: 39778699
I feel the value JunkMailImportLists is setting to 0 is a normal behavior and this prevents from updating the Safe Sender List each time Outlook is started. If this value is set to 1 always, then safe sender list could get updated each time Outlook is open and this could create duplicates in the safe sender list.
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Uncontrolled local administrators groups within any organization pose a huge security risk. Because these groups are locally managed it becomes difficult to audit and maintain them.
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

696 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question