Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Change routing of website on a sharepoint server

Posted on 2014-01-13
10
Medium Priority
?
414 Views
Last Modified: 2014-01-24
Hello,

we have an internal sharepoint server website, which is reachable via public IP from outsite. The Sharepoint itself server has a private IP.

URL of website: https://server1.com/default.aspx.

So when I'm working on the machine and enter the above website on the local Sharepoint Server, I will be forwarded to extern first and then, because of the .com DNS resolution, I'm being routed back to our network again.

According to Microsoft technet articles how to upgrade Sharepoint 2010 to 2013, I created a virtualized environment with an internal network only with DC, SQL and Sharepoint Server - so no access to the internet.

Now I cannot enter the above website now, because due the webite has a .com in the URL, my DNS try forward this request to external - without success.

My question is now:
How can I adjust the routing on the local Sharepoint server in that way that I'm not being routed to the internet but directly to the local webserver and can open the website properly?

Regards

insi01
0
Comment
Question by:insi01
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
10 Comments
 
LVL 38

Expert Comment

by:Justin Smith
ID: 39776327
Add a HOSTS file entry.  On the SharePoint server open C:\Windows\System32\Drivers\ETC.  Edit the HOSTS file and add an entry at the bottom that looks like:

127.0.0.1     server1.com


This tells your machine to stay local when visiting that domain.

If you get prompted several times for user/password and it won't accept, you'll need to disable loopback check by doing the following:

Click Start, click Run, type regedit, and then click OK.
In Registry Editor, locate and then click the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
Right-click Lsa, point to New, and then click DWORD Value.
Type DisableLoopbackCheck, and then press ENTER.
Right-click DisableLoopbackCheck, and then click Modify.
In the Value data box, type 1, and then click OK.
0
 
LVL 44

Assisted Solution

by:Rainer Jeschor
Rainer Jeschor earned 800 total points
ID: 39776383
Hi,
I agree with ACH1LLES for the hosts file update but I would never ever recommend to disable the DisableLoopbackCheck completely BUT instead setting a set of allowed names through the reg key BackConnectionHostnames.

See this solution: http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/MS-SharePoint/Q_27819495.html
(referencing both the MS KB entry http://support.microsoft.com/kb/896861
and this blog post:
http://blogs.technet.com/b/sharepoint_foxhole/archive/2010/06/21/disableloopbackcheck-lets-do-it-the-right-way.aspx)

HTH
Rainer
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 39776394
Disabling loopback entirely is quite appropriate in this situation, and 95% of all situations.
0
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

 

Author Comment

by:insi01
ID: 39776452
Hello,

I have tried, but doesn't work. Procedure is also valid for https sites?

The loopback check was already configured.
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 39776458
Yes procedure is valid for https.  When you ping your URL, are you getting the 127 address?
0
 

Author Comment

by:insi01
ID: 39777070
I ping the url and get the 127 address.

Still cannot reach the website.

Any Idea? Do I have something to change within AAM or any binding settings?
0
 
LVL 38

Accepted Solution

by:
Justin Smith earned 1200 total points
ID: 39777074
You need an AAM to match the URL you are using, and you need an IIS Binding to match the URL you are using.
0
 

Author Comment

by:insi01
ID: 39777465
Ok, will try tomorrow.
0
 

Author Comment

by:insi01
ID: 39782193
Sorry guys, but this all didn't help.
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 39782225
Please send screenshots of IIS bindings and AAM.  If you don't want to post here you can email justinsmith317@Yahoo.com.
0

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
These days socially coordinated efforts have turned into a critical requirement for enterprises.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
In this video, Percona Solutions Engineer Barrett Chambers discusses some of the basic syntax differences between MySQL and MongoDB. To learn more check out our webinar on MongoDB administration for MySQL DBA: https://www.percona.com/resources/we…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question