Link to home
Start Free TrialLog in
Avatar of sglee
sglee

asked on

Contact on my phone have contacts beyond my Outlook contact

Hi,
 
 I have EXCH 2010 and Samsung Galaxy Note 3 phone. I created an exchange account on my phone and email & calendar are synching just fine.
 But I see way too many contacts (that I don't even recognize, certainly they are not in my Contacts list in my Outlook) on my phone and I learned that some of these additional contacts from PUBLIC folder.
 I also confirmed that this has been happening to a couple of other user's phones too. So it must be happening to all smartphone users and they did not tell me about it.

 I don't think I have changed anything in Exchange Configuration, but I don't know what triggered and how to fix it.

 Can you help?
ASKER CERTIFIED SOLUTION
Avatar of Will Szymkowski
Will Szymkowski
Flag of Canada image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of sglee
sglee

ASKER

@Will Szymkowski
In Exchange Account on my phone, there is no additional option beyond 'ON' or 'OFF'.
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of sglee

ASKER

@btdownloads7
I went thru "Contacts to display" &  "customize".  None of them worked. I know where these additional contacts are coming from - they are from Exchange PUBLIC folder.
My question is how to remove public folder contacts from my phone.
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of sglee

ASKER

When I choose "Contacts to display", select "Customized list", choose my exchange email account and press "expand option" button, I see three options:
(1) My Contacts  (2) Personal  (3) All other contacts
If I only choose  "All other contacts", I get contacts from PUBLIC folder (total 1129, my own contact included). However if I choose (1) and/or (2), I only get several contactss (<10). I have 250 names in my Outlook Contact.
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of sglee

ASKER

User generated imageUser generated imageHere are the screenshots of my Outlook showing My Contact and Public Folder.
When I manually count all the contacts in contact folders listed in public folder, it comes out to be 985.

I just don't know how and why these public folder contacts made it to my phone contact list.
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of sglee

ASKER

@btdownloads7
It is weird isn't it?
When I had my Samsung Galaxy 2, it never used to do that. Since I switched to Sasumg Galaxy Note 3, it started happening. Then I asked other users and learned that it has been that way all along for them and they never bothered to tell me that.

Thanks for your help. I am going to close the case at this point as there are no solutions to fix the problem.
You should still try to use a different Exchange app on your phone -- just to see if it's an issue on the server, or if it's just the stock contacts app on your specific phone that's messing up.

Touchdown has a free trial version that you can play with.
Avatar of sglee

ASKER

OK. I will try it now and post the result.
Avatar of sglee

ASKER

In Touchdown app, it only showed the contacts in my Contacts folder, nothing from PUBLIC folder.
Then it's a problem with your phone's native Contacts app, and there really isn't anything that you can do, except start using Touchdown. You can either just use their app for everything (and completely remove your Exchange account from your phone's settings), or you can set up Touchdown to only sync your contacts, and then keep using the stock email and calendar apps (and disable contacts sync for your Exchange account in your phone's settings)
Avatar of sglee

ASKER

This Samsung galaxy note 3 syncs just fine with email and calendar. I have removed my exchange account from my phone and re-created it, but to no avail.
I guess I can't disable the exchange contact, but then it will cause inconveniences.
Let me call Samsung tech support to see if they can shed some light on the subject.
I don't want to purchase Touchdown if I can make my EXCH account working with native sync function on the phone.