Solved

Apache cert

Posted on 2014-01-13
15
1,095 Views
Last Modified: 2014-01-14
Im getting the below error on my Apache error.log, we have a wildcard Cert and am not sure if that is the issue. Could anyone help tracking the cause and resolution for this issue?

[Mon Jan 13 08:53:35.083158 2014] [ssl:warn] [pid 1308:tid 400] AH01909: RSA certificate configured for APP03a:443 does NOT include an ID which matches the server name
[Mon Jan 13 08:53:35.661285 2014] [ssl:warn] [pid 1308:tid 400] AH01909: RSA certificate configured for APP03a:443 does NOT include an ID which matches the server name
[Mon Jan 13 08:53:35.661285 2014] [mpm_winnt:notice] [pid 1308:tid 400] AH00455: Apache/2.4.2 (Win32) OpenSSL/1.0.1 configured -- resuming normal operations
[Mon Jan 13 08:53:35.661285 2014] [mpm_winnt:notice] [pid 1308:tid 400] AH00456: Server built: May 11 2012 16:55:33


regards,
0
Comment
Question by:atorex
  • 7
  • 5
  • 3
15 Comments
 
LVL 3

Expert Comment

by:cristiantm
ID: 39777135
The certificate is issued for a wildcard domain (*.something.com), but your vhost is not on that domain (APP03a), thats why the *warning* (not error) appears.
0
 

Author Comment

by:atorex
ID: 39777189
Thanks for the reply,
there is an application that connects to it, using the FQDN URL to it, I'm getting an ssl handshake error that made me think was due to this error.

the error from the Application,

08:48:55.168:WARN:oeji.nio:java.io.IOException: An established connection was aborted by the software in your host machine
INFO   | jvm 1    | 2014/01/13 08:50:08 | javax.net.ssl.SSLProtocolException: handshake alert:  unrecognized_name
0
 
LVL 58

Expert Comment

by:Gary
ID: 39777195
Do you have something like this

<VirtualHost 127.0.0.1:443>
ServerName www.domain.com:443


If so remove the :443 from the ServerName line
0
 
LVL 3

Expert Comment

by:cristiantm
ID: 39777221
If this that cathal mentions is not the case, could you post the main parts of your vhost config?
0
 

Author Comment

by:atorex
ID: 39777236
I have  the below in the httpd-ssl.conf


<VirtualHost _default_:443>
0
 
LVL 58

Expert Comment

by:Gary
ID: 39777281
And the rest of it...
0
 

Author Comment

by:atorex
ID: 39777285
Sorry here it is


<VirtualHost _default_:443>

#   General setup for the virtual host
DocumentRoot "/Apache24/htdocs"
ServerName https://app03a.globoalwork.com
ServerAdmin admin@example.com
ErrorLog "/Apache24/logs/error.log"
TransferLog "/Apache24/logs/access.log"

#   SSL Engine Switch:
#   Enable/Disable SSL for this virtual host.
SSLEngine on
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 3

Accepted Solution

by:
cristiantm earned 500 total points
ID: 39777326
Is your wildcard cert issued for *.globoalwork.com??

By the way, is it really globoalwork.com ? Not globolwork.com or globalwork.com ? ;) would be a very common mistake, and looks like this is the problem since I can see that globoalwork.com is an unregistered domain. So I think you just have a typo there.
0
 

Author Comment

by:atorex
ID: 39777343
yes its *.globalwork.com fat fingered it, and that is what the cert was issued to.

I may have an idea why this is having issues, the server's fqdn is app03a.globalHQ.com
when the admin created the server that's the Domain they put it in!
0
 
LVL 58

Expert Comment

by:Gary
ID: 39777349
Looks like cristiantm has hit the nail on the head
0
 

Author Comment

by:atorex
ID: 39777382
I corrected the fat finger error but still the same issue, that didn't resolve the issue, could this FQDN be the issue?
app03a.globalHQ.com
0
 
LVL 3

Expert Comment

by:cristiantm
ID: 39777389
You say the domain for the site is app03a.globalHQ.com? then you need a cert for app03a.globalHQ.com (or wildcard cert for *.globalHQ.com) and to setup the apache vhost name to app03a.globalHQ.com.
0
 

Author Comment

by:atorex
ID: 39777421
OK so that's likely the issue, the HQ domain is an internal domain so The server boys will have to move the server to the correct domain.
0
 
LVL 3

Expert Comment

by:cristiantm
ID: 39779141
Yes, that is correct. The SSL certificate Common Name will need to match the domain. If the site is in this domain just for testing/development, then you can use a self-signed (or in-house PKI) certificate for testing only.
0
 

Author Comment

by:atorex
ID: 39779204
Thanks, we are getting some self signed certs.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hi, in this article I'm going to teach you how to run your own site, and how to let people in (without IP). I'll talk about and explain each step... :) By the way, everything in this Tutorial is completely free and legal. This article is for …
In Solr 4.0 it is possible to atomically (or partially) update individual fields in a document. This article will show the operations possible for atomic updating as well as setting up your Solr instance to be able to perform the actions. One major …
Along with being a a promotional video for my three-day Annielytics Dashboard Seminor, this Micro Tutorial is an intro to Google Analytics API data.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now